K-9 mail stopped working

I am using K-9 Mail on Fairphone 2. It suddenly stopped receiving and sending (cannot make connection) although I can access emails on web mail. The server settings are the same as on my laptop. Assistance would be apprciated.

I was reading your posting in march when you first used K9. Interesting news to me about the original FP2- app for mail. I am using K9 for years without problems. From my provider WEB.de I learned that his cost free account doesnot allow connection every minute. It takes 15 minutes after one connect to reconnect again. Are you sure that you cannot connect after a while ?

Maybe the diagnosis entry in K9 , settings/diagnosis , can record information that you want to share for analysis ?

Web.de has abolished this behaviour before a few years. I experienced this issue in the past, but not in the present. Now I can check my e-mail so often I want.

1 Like

Hi anon9505190,
Thanks for your response. I don’t think it is connection time. I have tried to reconnect many times -Settings - Accounts - Add Account [K-9 has disappeared from this page] - Personal (IMAP) - Email address- Personal (IMAP) - Password (as on my other devices - Port 143 - Security STARTTLS. Result: Couldn’t open connection to server!!

Please remove the STARTTLS and change it to SSL port 993 or TLS port 143 for incoming messages.

For outgoing messages it’s SSL poort 465 / TLS poort 587

Hi Lidwien,

Thanks for replying. On incoming I have port 143 on SSL/TLS (Accept all
certificates). It still will not open a connection. SSL/TLS 993 did not
work either. I am not sure where to find the outgoing messages set up. I
winder if I should re-install K-9 which has worked fine up to now.



Re-installing seems like a good idea.

What is the best source for K-9?

and thanks for the help.


I usually take it from fdroid, but it’s also available in Google Play Store.



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.