Issues with the forum

FYI: I tried the same, and had the same result. As in: enabling the Share button does not solve the issue.

2 Likes

If you enter a Web Site in your profile it is shown twice in your user card and profile.

image

2 Likes

After installing Discourse v2.6.0.beta3, following the instructions in the thread on Discourse Meta, quoting is now fully functional again.

4 Likes

Alas, not fixed by the v2.6.0.beta3 update.


Duck duck go doesn’t show all the content in portrait orientation and only shows what has happened in landscape orientation.

Known Issue. See here:


It helps to change to old Theme (at least for your mobile device) in your profile settings -> Interface -> Theme Fairphone Original.

5 Likes

Did it. thank you for even providing tutorial!

1 Like

Strange issue… I wanted to open @alexka’s profile, I clicked on the avatar twice, and it brought me… to my own profile, @Alex.A. I can’t understand. All other profiles work fine, and this issue is 100% reproducible.
Now, would it be because @alexka and @Alex.A have only one character different? But still, that would be strange… Could someone check if it works for them?

I do get to their profile when either clicking on your mention above or their profile pic in a different topic.

3 Likes

Same here, I can’t reproduce this, it works like it should for me.

Usually you should be able to see where a link will lead you before you click it. Is the link to the user profile wrong already for you?

Totally strange. I could construct a farfetched chain of events to get alexka out of a search for Alex.A, but not the other way around.

(In a case-insensitive search using regular expressions, Alex.A would match forum users alex.a as well as alexka because of the wildcard character of the dot. Getting alexka as the search result would then only need the search to encounter or return it first.)

3 Likes

No, here it’s right.
Also, manually changing the user from …/u/Alex.A to …/u/alexka in the URL works.

So, I tried clearing the cookies, I tried another browser, I tried safe mode, I tried another computer, and the issue is still here in all cases.
I tried logging in with my test account, and the issue doesn’t appear with this one.
I tried changing my username to @Alex.At, and the issue disappears. Changed it back to @Alex.A, comes back again.

1 Like

You mean the visible link target is …/u/alexka and clicking the link you actually end up at …/u/Alex.A?

1 Like

Yes.

2 Likes

Must be :joy:

I renamed my test account to @Alex.A (Edit: I had originally written @alexba), and have an identical problem… Can’t understand.

Help… What’s happening in this forum, it must be haunted.
Edit: It seems that when changing the usernames, the forum considers alexba and Alex.A as identical, and renames alexba to Alex.A

No, I got it wrong!

I’ll open a topic on Discourse meta one day if I have time.

This still doesn’t happen for me. Usernames getting distinguished totally fine.
Windows 10 Pro 21H1, Firefox 88.0.1, Vivaldi 3.8.2259.42, Edge 91.0.864.37

You can’t see the same as me?
image

Debian 10.9; Firefox 78.10.0esr (64-bit), Chromium Version 90.0.4430.212 (Developer Build)

I meant they get changed in the posts.

Well, I see that, too, and that’s messed up, but I don’t know whether that’s the same issue.
The user profile links still lead to the correct user profiles for me.

Test … @alexka , @Alex.A … screenshot …

Does that display differently for you?

Links lead to

https://forum.fairphone.com/u/alexka

https://forum.fairphone.com/u/alex.a

1 Like

I found this here …

https://meta.discourse.org/t/incorrect-canonical-url-for-user-profile-page/190847

… but this still doesn’t explain how something would get from alexka to alex.a.

Quoting the user names still works for me, too. Screenshot …

Since you tried with different computers and (browser?) safe mode … must be your account. Don’t ask me how :slight_smile: .

2 Likes

Works fine for me on Firefox ESR Raspberry Pi Buster. Each goes to the correct profile.

Could it be a cache issue that cuts the search short and you get the same. I note it is also case insensitive
https://forum.fairphone.com/u/Alexka
https://forum.fairphone.com/u/alexka

https://forum.fairphone.com/u/Alex.a
https://forum.fairphone.com/u/alex.a
https://forum.fairphone.com/u/AleX.A

what about
https://forum.fairphone.com/u/alexa
or
https://forum.fairphone.com/u/alex

1 Like