Issues with Apps after update to Open OS 18.10.0 (Android 7 Nougat)

I was a user of the Fairphone OS (including google stuff). Including apps like EZ-GUI Ground Station (Multiwii) and Swell Pro App both for QuadCopter Flightcontroller setup. Now I updated to the most recent Open OS (18.10.0 - Android 7 Nougat), everything works fine EXCEPT these 2 apps. EZ-GUI Ground Station (Multiwii) is compatible with Android 7 but when I try to install it through Aptoide it starts installing (as usual) but then tells me that it was not installed due to my phone not beeing compatible. The Swell Pro App does install and start but after a few secs just closes again without any message.
I can think of several issues like having a rooted phone now, missing google apps (may be for maps or else), etc.
Can somebody give me some hints or explain to me how to figure what issue it is exactly (e.g. rooting can be hidden using exposed stuff) ?? Is there a way to debug apps I do not develop myself?

Thanks and Greetings

One thing would be catching a logcat, either via adb or internal. There are some apps for it. This way you should catch the error causing the app to force close

Concerning logs … Here’s a short post (about LineageOS, but sounds pretty universal) …

And here’s a long one …

:slight_smile: That was exactly the next I did (using and found that the SwellPro app needs google maps (may be the EZ-GUI too as it features a map too). So the next question would be is there a way to trick the app into thinking google maps is installed (I have rooted it, xposed is installed, etc.) or do I need to use ?

edit: I forgot to thank for the fast responses.

If you are 100% dependent on these Apps functioning, you will need the real deal, i.e. Open GApps.

If you are content with a little tinkering or Apps working perhaps suboptimally or not at all for a time, then you could look into microG, which tries to mimick Google without any Google stuff.

Quite a few of us here use LineageOS for microG, where this is robustly built-in for hassle-free installation, management and updates. But LineageOS is not an OS supported by Fairphone.

No for now they don’t need to work as I don’t work with GPS waypoints atm.

I looked into microG and as far as I understand would I still have to install maps and microG just replaces the framework stuff - not maps itself - correct? So no way around opengapps anyways. Did I miss something?

Correct. If you have an App that really needs the Google Maps App, you will need to install Maps.

Maps might work on microG, though, as Maps uses the Google services microG tries to mimick :wink: .

Just realized installing opengapps is a bit more than just installing some apps (involves TWRP/recovery boot) and makes future updating complex.

Is there any way to pretend the presence of maps (a not working one returning dummy values is fine)? xposed?


  • Download OS OTA update file and latest Open GApps ZIP to the phone
  • Reboot into TWRP
  • (Perfect opportunity to make a backup of the system when in TWRP anyway.)
  • Queue update file and Open GApps for installation
  • Install
  • Reboot

I did exactly that for quite some time with Fairphone Open OS and LineageOS 14.1, when I still used Open GApps.

Also, once installed, opengapps survive an update. I only ever so often flash anew opengapps, while more often updating my LOS install


I would accept the argument about the complexity of installation. But from what I read about uninstall of opengapps I am not eager on installing them. Thanks for the hints anyway!

May be it is not fair to say (but I am quite sure about it) that the SwellPro app won’t be updated anymore as the released a new app with the new drone (v3 - my stuff is v2). Furthermore I had to download and install the apk manually anyway. So I decided the best to do is just remove all gapps (mainly maps) dependencies from the apk using apktool/apkstudio. However here is one issue; I need help in doing so as I am not familiar with java and android apps. I have no idea where the entry point is, what the directory structure means, etc. I am quite confident - so much that I would bet on it - that this is a simple task (if one is familiar with app development in the first place). So I would appreciate any hint on how to do this. ATM I just removed gapps from manifest file and 2 sources - the resulting apk starts and than stops/crashes - so some debugging and hints from more advanced users than me is/are needed.

I you are curious the app apk can be found at:


Another question; is it possible to install just google maps and nothing else of gapps? (no services etc) Is there a more detailed howto available than Android Auto (and Google Maps) on Fairphone Open ? Thanks.

edit: Even though I still think modifying the apk to not use google stuff anymore by just deactivating it is the most sensible and fairphone-ish way to solve that issue (actually there was a nice solution in the past for blackberry; Play Services Patcher formerly GMaps Patcher) I gave up and tried to install microG (in order to install google maps as briefly described in the first link). The result was that Greenify immediately crashed and Sophos a few seconds later… so now I don’t have any further ideas… (I don’t want to have to return to Fairphone OS honestly…)

Well, if the Apps are your priority and the OS perhaps not so much … you could still try LineageOS for microG. It’s Android 8.1 currently and has microG robustly built-in as said before. I’m using that myself for a while now.

May be I should have written “leave Fairphone Open OS”… :wink: (sorry)

According to this post ✏ How to install any app on FP Open OS (for beginners and experts) it should be possible to solve my issue, right? :wink:

Meanwhile I also installed maps (without anything else - no nogapps, microg…) but actually this did not help, it looks like I need more (a google play services, gms surrogate) or else.

Logcat Extreme reports “Unable to start activity […] Attempt to invoke virtual method ‘void’ on a null object reference” so I interpret this as microG would solve my issue IF microG would work (not crash several other apps…).

OK - I can answer some of my questions now; maps, Greenify and Sophos do all work IF they get installed AFTER microG. So uninstalling and reinstalling them helps.

I learned from this thread that:

  • a logcat app is very useful (a “must have”)
  • I prefer microG much over opengapps due to ease of installation (however it still incoporates quite a number of steps (see ✏ How to install any app on FP Open OS (for beginners and experts) step 5.5):
    • add the microG repository (from website) to F-Droid
    • Install the latest microG Services Core
    • Install the latest microG Services Framework Proxy
    • Install the latest FakeStore
    • Install at least one UnifiedNlp backend - I use LocalGSMBackend and NominatimGeocoderBackend
    • Install an app for signature spoofing - I use FakeGApps Xposed module
    • patch needed to make unified register: change microG Services Core and microG Services Framework Proxy to be system apps (instead of user apps) - do this manually or use an app like Link2SD
    • Open microG Settings
    • grant/give/allow all rights and permissions asked for
    • Do the “Self-Check”
    • Ensure that all points are checked. If one of the points is not checked, read its description.
    • Tap on “UnifiedNlp Settings” and set up the Nlp Backends you installed in a previous point
    • Reboot
    • you might need to enable location stuff in andorid phone settings
    • Open microG Settings > Self-check again. Now all points should be checked. If so then you succeeded!
  • some apps need to be installed AFTER microG in order to work (un- and reinstall them)
  • the Swell Pro App works with microG and maps
  • the EZ-GUI Ground Station App not (actually it complains not beeing compatible with the device - but it’s the OS, as it worked with Fairphone OS in the past on the exactly same device before the update)

1 of 2 apps do work now (the more important one, as it cannot be replaced or substituted by anything else I know).

Thanks to all for your support!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.