Issues decrypting data in TWRP on Fairphone Open OS

Just succeeded in encrypting my FP2 with open OS. Up to now TWRP worked fine without encryption. After encryption I can boot to TWRP. But TWRP informs now:
“Unmodified System Partition
TWRP can leave your system partition unmodified to make it easier…”

If i press “Keep Read only” i get during back-up info that back up failed.

Now my question:
Is it still not possible to back-up encrypted partitions with TWRP or is it neccessary to allow the modification of TWRP instead of “Keep Read only”?
If TWRP does not back-up, there is also the question what to use TWRP for?

Can you post the exact error message or a screenshot?
I backup my encrypted phone all the time with TWRP, but I doubt I kept it read-only.

See photo:

It can’t decrypt your /data partition. Are you on the newest TWRP?
When starting, it’ll ask you for the passwort for decryption.

1 Like

Good question.Well, I use the TWRP which came with Fairphone open. I did not install it. I just looked at the TWRP homepage and found for Fairphone 2 really a newer version 3.1.1-2.
I understood that i can download it to my phone, boot to TWRP and flash it.
Hope that it will not destroy any data. My last backup is only some days old but was done with non-encrypted system.
Will do it tomorrow.

Another question to people having experience with TWRP as I never reinstalled a TWRP image:
Does TWRP back-up all my data, i.e. also passwords of apps etc. The only exception of backup will be photos?

Not just photos, but any media won’t be backed up. All app data on the other hand should be saved unless an app saves something in media (which of course would make no sense for stuff like passwords).

1 Like

That’s right, and for safety TWRP even states this while making the backup … there’s a screenshot in this old post …

1 Like

Correct. No photos, music or generally downloads will be backed up. On the other hand, system, apps and “immediate” app data {that is config, passwords etc) are backed up so that you can return to the status you had at the time of the backup.
I’m not sure your twrp version already can flash img updates… In case you might get yourself the twrp app from their web site or the play store. With it you can install the current version. From that point on you can do it from the recovery also (when there will be the next update…)

1 Like

Thanks . Final question before I install latest TWRP version.
In the beginning prior to changing to FP open (I use now the open version) I got some trouble with TWRP because TWRP did not allow to update with the Fairphone updater. I did not try to solve the problem because I wanted to change to Fairphone open and flashed the open version which automatically brought me the version of TWRP I now have.
If I flash now latest TWPR - what will happen in case the next Fairphone update will arrive. Think it will be due within short.

How to update?

Updated TWRP to latest version but mounting problem with backup remains. "failed to mount data…"
Do you have any idea?

IT does ask you for the passphrase when starting?

No it does not ask. This was very astonishing for me, because the “data-volume” is encrypted.
Something is wrong concerning decryption/encryption. Also TWRP shows data partion with zero "0"
files/data despite the fact that there are a lot of data. In Linux showing “0” for a volume is always an indication that it is an unknown file system.

In addition to the above info I want to point out that I unlock display with Password/Pin and not
with a sign. Unlocking with a sign was indicated in the web as possible reason for reported TWRP problem.

I’m using a pin also. But i encrypted my /data under LOS. I hope this doesn’t matter and FP Open doors not use different signatures (don’t think so, as it’s using dm-crypt as far as i know…). Can you use the mount option in twrp and try to mount /data?

I tried mount already. It is not possible for data. All the other partitions are automatically mounted and also backed-up by TWRP.

I will also have a look on Titanium backup. I cannot and do not want to use Google store but i think I can download direcctly from Titanium.

One thing still crossed my mind… Do you need to enter the pin while booting to Android?
I can’t think of anything else. Maybe @z3ntu knows something more as he’s intimate with the inner workings of twrp

Which FP Open version?
Which TWRP version?

The “Keep Read only” slider is not really important (and it shouldn’t matter)

1 Like

Yes, if I reboot i have to indicate at first the pin, than the pin for the SIM-card and than the pin for the display.
I am using: Fairphone Open 17.11.2 and I flashed twrp-3.2.0-0-FP2.img

That’s how it should be.

Works fine with my encrypted phone (although LineageOS like @lklaus).