Issue with sd card since Android 13 update

I have been using Shuttle as my music player for some time, all my music being on an 250 gb sd card mounted as external

However after the 13 update I found that not all of the tracks were being shown, random artists, tracks missing.

I assumed that the app might not be compatible with 13 so I uninstalled it. I tried several other apps which all had the same issue.

In fact it got worse because the last couple of apps couldn’t now read the card and it wasn’t visible in a file manager.

I therefore connected it to my pc and could see all the tracks and played one as a test which worked fine.

Having detached it from the computer I then opened the music player app and it was again able to read the card but a large chunk of music was still missing. Does anyone have any thoughts as to why this might be happening please.

If it’s a large amount of data, the device will need a while to re-scan/re-read all the media contents. I would recommend you start your music app and give it some time on the first try until everything is read.

I for my part have a ton of music (200-250 GB) on my SDXC card, and I’m using VLC for a long time now because it allows me to deactivate that scan and play the music directly from the folders on the SDXC card in VLC’s “folder” view. If I would let VLC scan for media contents, the app would later keep freezing and stalling if I tried to browse by albums or artists.

Thanks for responding. I tried VLC but it didn’t play the track I selected.

Have tried again and it does now seem to play the tracks and show them all, although there are so many I cannot be sure.

The only problem with it is that it leaves the track on the drop down screen which means you have to force stop it every time which is a bit of paid. There may be something in the settings so I will have a look.

To be honest, I’m not sure I’ll address your issue here, but it cannot do harm …

When I want to play an album (not just an individual track) via VLC’s BROWSE tab, I navigate to the album in my folders, then HOLD the album folder to mark it. To actually PLAY it, it’s the black play button at the top then (not the orange one), see here:

Thank you.

Mine doesn’t look like that at all.

It comes up with an album cover and the next click a list of tracks. You either then press play at the top, which I assume plays the album from top to bottom, or press an individual track which then plays.

As I said it then leaves the app hanging as it were but I now find a right swipe closes it so I am happy with the app and thanks you for your help.

This does leave the issue with the other apps though. Definitely not showing all tracks as far as I can see.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.