English

Issue with camera & photo gallery

Hi, I’m new, I have had a FP3 for about 2 months now, and I have a bug with the camera and the Google photo app. I have read a bit on this forum, and haven’t found that bug anywhere.
When I open my camera app and take a picture, the picture does not appear in the round thumbnail in bottom left corner before a very long time. After a minute or so, the picture finally appears and I can share it or see it. The picture does not appear in the Google photo gallery neither.
I tried installing another camera from Android store and it works fine. I also tried to change the gallery app, but the same problem occurs.
If the camera app has been opened for a long time, this problem does not occur and the pictures show straight away in the round thumbnail. It’s as if it needs time to “warm up”.
Has someone got this issue ? I tried updating the camera app software, but can’t find a way to update it or even dis install/reinstall it.
I am currently using Open Camera instead of the FP3 camera app, but it is less convenient. I wish the built in one would work fine !

Thanks for you help,
Elsa

Hi Elsa!
I have a “light version” of the issue you’re describing. At times the thumbnail picture is delayed.
But I am using an SD card to store my pictures so I figured that caused this. Are you using a card or internal memory for your pictures?

best regards / Joan

Ha Elsa,

Why don’t you move to Google Camera Mod ?

You will have much more better results than the default one and the link with Google Photo can be set directly from the application.

You’re experiencing an inconvenience which will offer you better than expected !

Hi Joan,
I am currently using SDcard, but I tried with internal memory at first, and the same thing happened.
Thank you for your message.

Regards,
Elsa

1 Like

Hi GamTrad,
I already did, but I don’t really like this camera for quick shots, there is this HDR+ treatment that comes up every time I take a picture and it lasts ages, so I can’t shre the picture right away and I can’t share it, so it’s just as bad as the original camear I guess. It does great night shots though, that’s why I kept it on the FP3, but the photosphere mode does not work.
Now I currently have 3 camera apps on my phone, none of which I am happy with.

  • the original one, I like best if t was not for this bug I reported
  • the Google phone one, (tried both apk 9.4a and 9.6) but the HDR+ ruins it (don’t know what it is for and couldn’t turn it off in the settings)
  • the Open Camera : good and quick, but the photos are a lot more blurred even if I don’t move much.
    Thank you for your suggestion!

I found that in default Camera App, if you want to save all the photos you take in SD Card, you have to select twice:

  • Select rear camera view and go to settings and select SD Card.
  • Select front camera view and modify the storage folder too.

As I realiced, if you only select SD card with, for example, rear camera view activated, then the FP will save your front camera photos or videos in a different folder (actually in the phone memory, not in the SD Card). This is pretty weird, I know, but maybe this is related to your problem. Hope it will help you :slight_smile:

2 Likes

Hey man,

I have the exact same problem !
Did you find a solution ?

Or at least a better working app ?

Thanks !

I have an annoying problem with the camera, too.

It had been working fine since I received the FP3+ on 1 October 2020 until today, 17 October 2020.

I went for a walk, took perhaps 20 photos and two videos. While I was out, everything seemed to be working OK. I could see the little thumbnail in the circle.

I got home and wanted to transfer the files to my Linux computer, so connected with the USB cable and told the FP3+ to use USB for file transfer.

This has worked consistently in the past: I can usually see the FP3 appear in the sidebar of Nautilus (file browser) then click on it to see Samsung SD Card displayed as a directory.

So as normal, I click on the icon for the Samsung SD Card, go into the DCIM directory then into Camera. But where I would normally see icons for the different files, I get an alert: “This location could not be displayed. Sorry, could not display all the contents of “Camera”: libtmp error: could not get any object handles.”

I have unmounted the filesystem, disconnected the phone and looked using the phone’s file browse in Samsung SD card/DCIM/Camera and I see “No items”.

I did a little test. I used the front and the back camera to take a photo with each. The thumbnail appeared after an unusually long delay, and after the second photo I touched the thumbnail to view the photo… and there I just see the “working on it” circle go around and around.

I took a few more photos, and then looked in Images/Camera… see the screenshot below.

It looks like the files are being badly saved, with a size of 0 bytes and with the wrong timestamp… Error in the camera software?

I have found a solution, it seems to have to do with the micro SD card where I store my photos.
I had just reused the micro SD of my previous phone, and after I have saved it, formatted it and put it back, it works ok now.
So maybe, the camera app didn’t like the fact that I had all my old photos in the same directory that it uses to store the photos.

Anyway, after a factory reset of the phone and especially a format of the SD card, it works fine. I did all these things because I wanted to prepare the phone to send it to support. I don’t think I still need to.

5 Likes