Is Magisk affected by the locked bootloader bug?

Hi, I just got my fairphone 4 and I want to customize it and get rid of google apps. Ideally I would like to install CalyxOS or IodéOS, but with the Locked Bootloader Bug I’m super afraid of doing it. Plus, third party camera apps can’t use all the features yet because of the Camera2 API issue.
I could live with an unlocked bootloader, but if one day I absolutely have to use an app that requires a locked bootloader i’ll be stuck so I need to be able to revert it to its original state. And the warning requiring confirmation to boot is kind of annoying.

So while those problems exist, I thought I could install Magisk alone with NanoDroid + MicroG. But can I relock the bootloader while having magisk ? Like, is boot.img checked by avb ? edit: after reading the avb docs it seems boot.img is checked
I’m afraid to get in this situation:

  • Install Magisk (keep unlocked bootloader)
  • Decide I don’t want it anymore
  • Uninstall magisk and lock bootloader (eg for banking apps…)
  • Trapped with “corrupted os”

And there is one last thing i don’t understand (i don’t know if i should ask it here or on the original topic?). The people who encountered the locked bootloader bug, why did they have a “corrupted os” screen, while it used to boot fine ? Is it because of some one-in-a-hundred chance of having a corrupted OS still able to boot (because of a bad USB cable or something), or did they not flash avb_custom_key, or does it happen randomly/we don’t know ? I’m super new to avb and the A/B system so i’m a bit lost

Any advice is appreciated !

1 Like

If you ever decide to unlock your bootloader, I’d suggest not relocking it until it is known what exactly causes the bricks (and the issue has been fixed). The state of your bootloader also doesn’t impact the security of your data, so it isn’t too big of an issue to just keep it unlocked. I’ve tested some apps known for not working on rooted phones (including banking ones) and all but one worked with minimal setup.

About the bootloader issue: As of now we do not know :sweat_smile:. There should be ways around this issue, but I’m not aware of a 100% safe method.

Thanks for your reply, i already intend to keep the bootloader unlocked as long as i don’t need it locked, but my biggest fear is that the bug is never solved (like maybe it’s an issue with the bootloader itself, and it’s been 4 months since it exists)

AFAIK it’s not a warning that you have to confirm. It’s just a warning that pops up and disappears after some seconds.

No, this is not possible. As long as you have Magisk installed, you cannot lock the bootloader.
And remember that after locking the bootloader, the phone will be completely wiped. So you would have to set up your Fairphone again.

That is not quite clear yet.
But you can use fastboot flashing get_unlock_ability to check if unlocking the bootloader is still possible before you actually lock the bootloader.
If the result is 0, you can no longer unlock the bootloader and you should not proceed with locking the bootloader.
If the result is 1, it should be possible to unlock the bootloader again.
Here is a post describing the process of installing iodéOS:


Oh well, then i guess i’ll wait until we have more information. At least I want to be sure it’s not something in boot.img that resets the get_unlock_ability thing, so that i can reflash the original boot.img safely

That’s nice, it is much less annoying

Thanks for your answer, I’ll wait for a few months before taking the risk.

Just in case you didn’t see this in other posts: If you want to keep FPOS for now, it might be less risky to avoid flashing the boot.img patched by Magisk to the phone.
You can instead have fastboot boot from a patched image located on your computer. That way you can leave the phone partitions unmodified and still get root access temporarily until you reboot. I do this to make my banking app happy and I only need root for backups or rare one-time changes anyway. The banking apps I know don’t need locked bootloaders, but they do detect Magisk even with hide enabled.
I recently used this approach to port my FP2 apps to my new FP4 with Titanium backup and it worked very well. It all depends on how often you actually need root and whether you are happy with FPOS.

I can confirm that this is the case. Booting continues after a few seconds, but you can press a button to pause on the screen.


That’s not a bad idea, i’ll probably try this. I very rarely reboot my phone so it should be almost permanent.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.