Installation of Google Playstore and Play Services


I bought an old FP1 from a friend. He already pre-installed some stuff for me, but also deleted the Google Playstore and I cannot get it running again.

I downloaded and installed the APK file and the Playstore shows up in the APP Manager. But when I try to start, it only flashes up and freezes. I installed version 7.3.07.K.

I recognized that I also do not have the Google Play Services installed. I guess I need the Services for the Playstore to run, am I correct? Which is the correct APK version to install (see And do I also need a Download Manager? I think this is also missing. Are there other prerequisites for the Play Store?

Hoping for some input! And besides: I am a total Smartphone n00b, so please be patient.

If your FP1 is on the latest operating system (Kola Nut 1.8.7), you should be able to install Google Apps through the app “Fairphone Updater”. Have you tried that? :slight_smile:


Thanks, that solved the problem.

One more question: is it advisable / possible to restrict what data is sent to Google?

It’s possible using the #xposed framework. This topic, for example, has more info:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.