Install update using mobile data?

Hi
The Updater app is telling me that an update is available, to Fairphone Open 17.09.3.
When I try to install it, however, it asks me to connect to a WiFi network, which I cannot do.
I have a generous mobile data allowance, though: Is there any way I can persuade the Updater to use that instead?
Thanks,
Graham

1 Like

There is a feature request in the bugtracker about this, but for now this is not possible.
I’m sure you can find a wifi you can.use somewhere (friend, coffee shop, …)?

2 Likes

OK, yes, it looks like I’m going to have to!
Thank you.

1 Like

Do you have another mobile (e.g. old hardware) where you can put your SIM inside and turn on Tethering/Hotspot functionality? With this you can use Wifi on your Fairphone and use the updater, it will then function as desired.

4 Likes

Or you could just manually download the update and afterwards install it by opening the zip file with the updater app.

2 Likes

Thank you for these ideas.
How do I ‘manually’ download the update, please?
I can see how to download the latest version as a whole, but not the update.
I don’t want to have to re-install everything from scratch.
Thanks,
Graham

Check this page for instructions:
https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-installation-instructions.html

Thank you for that. Unfortunately those instructions seem to require the use of a computer, which I don’t have. It looks as if I’m going to have to find a WiFi connection somehow.

shouldn’t be for method 1. you just need to download the right file and then open it on your FP with the updater. I found something in the forum but already got confused where. I tryed that method too and I was able to download it on my FP. Just for me the updater wouldn’t do anything after hitting the update/install button.

I did what I think was being suggested, and downloaded the ‘manual update package’ zip file that is linked-to at the start of the instructions for ‘Method 2’.
I then ignored the rest of the instructions and simply opened the zip file with the Updater.
It appeared to be working, but after the phone re-booted, the update had not been applied and it still had the old version of the OS.

Thank you for that clever, lateral-thinking suggestion, Amber. Unfortunately my old phone doesn’t have WiFi, so I can’t do that.

I meant Method 1 and I think the right file should be: fp2-sibon-17.09.3-ota-userdebug.zip

1 Like

The Method 1 instructions link to this page: https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html#download-releases
The first link on that page says “Upgrade from an earlier Fairphone Open build.”, which is what I’m trying to do, so it looks like fp2-sibon-17.09.3-ota-userdebug.zip is the correct file, as you say.
But it doesn’t work.
After running that file with the Updater and re-starting the phone, the operating system is still the old one, 17.08.1.

Aha!
I tried it again and this time it has worked.
The only thing I can think of that I did differently the second time was that I opened the zip file from Amaze rather than from the download dialog thing that slides down from the top. (What is that properly called?)
Anyhow, problem solved.
Thanks to all who helped.

3 Likes

That was probably the relevant difference…

I remember having had a similar iaaue lately. Opeming the file from the download dialog actually opened the Updater app but there only showed a cryptic name and no update was executed.
When opening the file from Amaze first a dialog requesting file access rights (for the Updater app iirc) appeared, then the Updater opened & displayed the file correctly and started the update process.

2 Likes