Install the app "Plan it"


I’ve got the fairphone 2 yesterday.
Today I wanted to install an app which is called planit. It is for fotography and I use it allready on my tablet with android 4. It’s the best app which allows me to plan the weather, the position of the milky way, the sunrises etc.
The fairphone don’t install it, because it is incompatible.
How can this be? Is there a way to install it? I would love to have it on my mobile, because I don’t want to bring my tablet with me every time.

Hi @sinawali,
I just tried to install this programm. On my FP2 I am running the Open Os without any Google apps. The installation went through without any problem, but I could not start the program. It asks for a new version of the Google Play Services, I don’t have and I don’t want. But with the Fairphone stock OS the program should run. What error did you get, when you tried to install it?

1 Like

I could install and run it (the free version) on FPOOS with opengapps installed

1 Like

Suppose you’re referring to “PlanIt! for photographers” released by Ying Wen technologies? I’m using Android stock fpos on fp2 and it installed the app in version 6.0 without any problems.

1 Like


it is the “PlanIt! for photographers”, indeed.
It just don’t start to install. And Google Play Store says, that it is not compatible.
It’s my first smartphone, so I don’t know too much about Android, because my tablet is used mostly for work, I don’t do much with it.
I wrote to the devlopers and they said, that the app is compatible, but they don’t have the fairphone on the hardware list.

Very strange. Which version of Fairphone OS are you using (you may start “updater” app to check that)? Which language do you have selected?
Did you try to install free version or paid version?

I use German as language and Android 5.1. I tried to install the commercial version, because I bought it for my tablet this year.

I’m using German also, and it is offered for me, i could install the commercial version, which i aborted when asking for payment…

I moved the thread to #fairphone2help because it seems that other people could install the app, so it’s a specific problem with your configuration.

Just as a test: are you able to install the free version?

Yes, I was able to install the free version.

OK. Then my impression is that it might be saved somewhere in Google play that you’ve paid the old version of the app and it’s trying to install you an old version (which may not work together with current 5.1 Android). Try to check if the version it’s trying to install is really the current version of the app!

Might be possible, because I use the version for android 4 on my tablet. Unfortunately I’m not able to buy the newest one, because google refuses the payment, I tried it several times.

I recommend you write again to developers and they can help you out there. I don’t think it’s a FP2 issue…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.