Install Google play (FP1 second production run)

I haven’t used my FP in absolute ages, but want to again. It didn’t have anything on it at all.
I tried using the widget to setup Google Apps, but it said Download Failed.
I tried going to but the built in browser and duck duck go browser (which I could install from F-droid) aren’t suitable as it says the Aren’t Supported.
I tried the APK of of Google play but there are dozens of versions, and the one which seemed right (ARM android 4+ 240-440dpi) didn’t install…

Do I need play services first, of a different version, or am I doing something else wrong? Any help (links would be great!) is much appreciated.


Assuming you’re running 1.8.7, try Fairphone Updater > Advanced Mode > App Stores > Google Apps.


You might have to clear the cache of the Fairphone Updater, or alternatively you can do a factory reset of the phone.

If it’s only about the apps from Google Play Store, install Yalp Store from F-Droid.

I couldn’t find this, but thanks,Yalp solved my problem!

Yeah, it was just to get apps. Thanks yalp was the answer I needed. Fantastic.