Install /e/ on a Fairphone FP4 - “FP4” (beta)

Seems that installing /e/ other roms is no longer a one way street…
Thanks for help

Try sudo gpasswd -a bruno adbusers (assuming bruno is your linux username)

Yes ! :slightly_smiling_face:

1 Like

Hi everyone!

I finally want to install /e/OS on my FP4,
but in the /e/OS-instructions I read:

Caution: Ensure that you flash an image with a security patch level greater than the level of the existing security patch. Failure to do so will prevent you from locking your bootloader.

According to the instruction the /e/OS-image has the security patch: 2022-04-05
My phone has the security patch: 2022-05-05

Does that mean that I need to wait for a new image? (The most recent image seemingly has been created on the 2022-05-26, but no idea if this means that the security patch topic is okay in my case…)

Can somebody advice me on how to proceed?


in the ‘’ file, there are three img files: dtb.img, ramdisk.img, ramdisk-recovery.img who are not used to flash the rom. The e/os installation guide do not mention them. Why ? Are they created during building of the files ? Are they necessary or not ? Thanks if you can reply to my question.

Hey Fairphone-Community,
Hi @yvmuell

yeah, my 1st post will begin with a question as I already read for a few days now, because actually I wanted to install /e/os on my phone and while I saw that it should run /e/os without problems I also bought one, but without the preinstalled OS from Murena.
Now I’m a bit confused and/or afraid at the same time, because I read this “brick” stuff all the time.
I haven’t flashed anything yet, but unlocked the boot loader and afterwards I trapped myself in a boot loop, which is not a brick, as I thought before.
What I did was changing the boot slot from b (which was default) to a.

So now here is my question: Is it really possible to brick the device completely or is it always possible to install any bootloader with adb or change just change it to the non-default slot (to a in my case) and work with that.

I thought if the device doesn’t boot anymore, I always could change to b and do whatever I want.
(like a backup bootloader) - I heared about that on Google- or Samsung-Phones.
So I never had the risk to brick my device completely.

At the moment I can’t install /e/os because of a message saying so from /e/os-Easy-Installer (idk why), but if I really can brick my device I’m not in the mood for that even though I’m disappointed about the display, not even 90Hz…
That would be a really expensive “Briefbeschwerer” for me… :innocent:

I hope you can clarify or make me calm myself :wink:

Best regards to ya’ll.

Welcome to the community :wave:
I’ve moved your post to this topic, since you seem to want to install /e/, not iodé.

Short answer: Yes, if you lock the bootloader you can absolutely brick your device.
Slightly longer answer: If get_unlock_ability was reset to 0 on your phone (so OEM unlocking got disabled during installation), you didn’t enable it again and something goes wrong when locking the bootloader, like for example you installed an older ROM than the one you had installed before, triggering Anti Rollback Protection in the process, yes.

If you lock the bootloader you lose the ability to do that.

What’s the message about? Stock FPOS version you had installed too new and no matching /e/ release available? :thinking:


Hi @hirnsushi,

thanks for moving, I try my best to participate in the right threads.
I wanted to install but I also stuck reading at iodé which also sound pretty nice to me.
So I also considered to check that out, too; but my story started with /e/os…

My version is (I guess the latest):
FP4.F_P4D.A.163.20220826 (updated a few days ago, tight after I received it)…

You think it could be a version incompatibility with that one to install?
If I install a new one I don’t care what I have on it, because I delete that anyway, right?

Strange :thinking:
but what was first? The Chicken or the egg?

Sorry, but I didn’t understand at all, maybe because of missing know how and why anti rollback protection can kick me.
Imho I should be able to install old or new OS as I wish. So I can do on my Computer.
Am I not able to install a stock ROM, like a reset, which also install FP stock rom, locks the boot loader, etc. like it was shipped?
I just can compare the ability on Samsung Devices with Odin or whatever was used for.
Everything was recovered, partitions, Boot loader, Recovery System, the flashing counter was reset, even the providers Logo appeared and everything was back to the state when you receive a new phone. By any mistake you were able to restart the rooting or flashing process.

However, maybe I should learn now: “never Lock the Bootloader” :wink: thanx.

But to understand this, you say that this OEM process is locking the boot loader and I have to unlock it before proceeding?
Maybe that’s a stupid question, but: If I recover my System with OEM Software, as I described… everything is back to normal. So I will have a functioning running OS with locked boot loader.
What’s wrong with that?
Why is that bricking the device?

At the moment I can’t lock the boot loader anymore (option is grayed out) - so I’m save.

So just one commemt to the Screenshot ,for the rest @hirnsushi is more knowledgeable

You can’t use the easy installer yet to install e/OS you would have to do manually


As @yvmuell mentioned, you’ll need to follow the manual install process.

Changing the slot manually is only available on an unlocked bootloader. The slots aren’t meant for you try different OS, they provide a (automatic) fallback after an OTA update. If your bootloader is locked and you are in the wrong slot, you’ll have to unlock it again to change it, if you can’t unlock it, your phone is bricked.

Anti Rollback Protection is meant to prevent malicious actors from installing previous versions of an OS that might contain known vulnerabilities, that could be exploited to gain access to your data.
Once you are at a certain patch level, installing a previous version and locking the bootloader will trigger it, rendering the phone unbootable and potentially bricking it.

Yes and no, you can go back to stock, but you won’t be able to go back to the state you where in when you took your phone out of it’s packaging (if you performed an OTA update at some point).

Well, if you want the flexibility you mentioned above, yeah, don’t :slightly_smiling_face:

There is a bug in the FP4’s bootloader that can reset OEM unlocking when flashing a ROM. OEM unlocking is a separate switch you have to toggle in the Developer Settings, that needs to be set to ON for you to be able to use fastboot flashing unlock.
If that happens and something goes wrong when locking the bootloader, you can’t unlock it again.
At that point you own a fancy :brick: :smirk:


Thank you for the Docs, I’ll try to dig deeper into it.

I was too slow on answering. So I just edit now coz I can’t delete.

I wanted to say, that I can not lock it. That option is grayed out inside the running OS.
The stock FPOS is still starting and I am still able to change between the slots.

Do I already have to be careful in this case with the rollback stuff you mentioned before?

Thank you so far.
To be honest, haven’t expected to receive an answer soooo damn fast… :innocent:

No worries, better to ask questions now instead of having to deal with Fairphone support (and Cordon, the repair contractor) later :smirk:

If you are on the latest stock FPOS release (which you need to be to unlock the bootloader for the first time), you need to be aware of the current patch level:

The available /e/ OS images are older…

/e/OS build : R stable (Security patch: 2022-07-05)

…so whatever you do, don’t lock the bootloader!

Edit: Apparently 1.4.0 seems to be up-to-date and available in stable, so mabye someone just forgot to update the docs :thinking:


Didn’t see your edit, just create a new post…

That’s the OEM unlocking switch and it doesn’t lock or unlock your bootloader, it changes your ability to do so. While your bootloader is unlocked that switch is greyed out (at least on stock FPOS).
Is the switch set to ON? What’s the output of fastboot flashing get_unlock_ability?

As long as you don’t lock your bootloader you’ll always be able to switch between slots. Doesn’t mean you should though, you generally only need that if the OS you just installed doesn’t boot. But, most install instructions should have put you in the right slot already.
Better forget about the ability to change slots, it’s not meant to be used manually, the OS / OTA updates will manage your slot.

If you don’t lock your bootloader, no.
If you plan to, don’t install anything older than 1.4.0, check get_unlock_ability and before locking it double-check the patch level under Settings → About phone → Android version.
I generally would still advise against it, if you don’t need the added security features of a locked bootloader. There’s always a risk involved and personally I’d rather be able to fix any issues myself instead of having to deal with support / Cordon, ain’t nobody got time for that… :smirk:

1 Like

I would like to underline @hirnsushi 's point again, as I also had such an “accident” :roll_eyes:
Reset the phone to factory settings (if necessary), compare the security patches of the new OS, if there is “the slightest doubt” do not install and wait for an update/security patch of the new/other OS. :point_up:

Wooow… I have read that now multiple times. Is it really that bad? :roll_eyes:

…please, excuse me for writing such confusing stuff. :man_facepalming: Of course you’re right; it’s just the ability given.
So if greyed out, it’s unlocked, like the output of your following command confirms:
first booting to bootloader and running:
fastboot flashing get_unlock_ability

Meanwhile I played around with preinstalled stock FPOS.
I locked and unlocked the bootloader and now I feel a bit more safe; thanks to y’all.
I will keep it unlocked now :crossed_fingers::innocent::crossed_fingers:

I updated a few days to: FP4.FP4D.A.163.20220826
So I assume Version FP4D.A.163; Patch level date 20220826
I also found that command in your other post with CalyxOS to show version with adb-command:
first booting to FPOS and running:
adb shell getprop

The 1.4.0 Version seems to be from 202209 (September), so its newer like FPOS, but the easy installer keeps saying that its still not installable yet.
Maybe the easy-installer has to be updated?
I swaer that I’ve seen a link to the manual installation of /e/os, you posted? I don’t find it yet anymore, but I found this…
…and there is no Fairphone 4 listed in the compatibility overview for /e/os.

That’s maybe why the title of this thread contains “(beta)” :wink:

Well, FP support is constantly overwhelmed and takes some time to respond, Cordon (at the beginning) often declared bricked phones as unfixable and had to be convinced they were actually repairable.
The process has been improved I imagine, but we are still talking potentially some weeks till you get your phone back.

Nope, on stock FPOS, if it’s greyed out your bootloader is unlocked, on /e/ OS it’s not greyed out even if your bootloader is unlocked, the important part is if it’s set to ON.
That command doesn’t tell you if your bootloader is locked / unlocked, it tells you if you have the ability to lock / unlock the bootloader (so essentially the state of the OEM unlocking switch mentioned above), which you absolutely should check before locking the bootloader.

Oooff, you shouldn’t play with that, especially since you switched slots as well, and definitely don’t feel safe, people have bricked their phones from less. Let’s just say you wouldn’t be the first…
I mean you technically checked get_unlock_ability before and it returned 1, but my nerves, uff, I’ve seen too many :brick: :see_no_evil:

The important part isn’t when it was released, but, as mentioned in the linked merge request, they actually pulled in the newest proprietary stock FPOS bits. Outdated releases often get published even after Fairphone releases new versions, since it takes some time until those updates get picked up.

As mentioned before, the FP4 isn’t compatible with the Easy Installer yet, you’ll have to follow the:

1 Like

That’s the easiest way at first to close tickets :wink: … but yeah… that makes it more complicated to convince the support as a customer…

Roger that :saluting_face:

at least it looked good on the screenshot… I will keep the switch position in mind (if I manage to install /e/OS.
I read that link from @yvmuell and you and as I find I should skip the last part, because they are writing about locking the boot loader - what I better should leave as unlocked…
And they also make a mention about lock_critical…

…but after our conversation I guess I just should skip that part, right?
In my case the command failed after I did fastboot flash unlock
fastboot flash unlock_critical
it feels as if it is the same command like without the word ‘critical’.

And that brings me to my next question, if I look to the manual installation.
They show 44
fastboot flash foo_a *.img    and
fastboot flash foo_b *.img    commands.
Ok, got that so far.

My thoughts now are:
As I said my default slot is B.
Do you think it would be a good idea to chose only the A-commands, because the last command is
fastboot --set-active=a
and could keep my “default-B-slot” :wink: or am I misunderstanding something at this point?
In this case I have to change the slot because the Howto says to do so.
Is it right, that I can have two operating Systems installed side-by-side?
Or do you recommend to execute all commands like they are shown?

And unlike a Screenshot, which I can’t find right now, secure boot is set to yes.
Is that a problem?
Should I change it to no?


Yep, you don’t need to lock critical again.

As the output suggests, it failed because it was already unlocked, which it should be if you followed the official Fairphone instructions to unlock the bootloader, so that’s fine :+1:

fastboot flashing unlock unlocks your bootloader
fastboot flashing unlock_critical unlocks the critical partitions, so you can flash those (which you’ll need)

Don’t mess with the install instructions, the slots aren’t meant to be used by you. OTA updates just alternate between the slots and they expect certain content to be there. A / B slots are there as a fallback if an update fails.
You start in slot a, the next update is installed to b from a running system, after a reboot the system switches to b, but if something goes wrong will fallback to a.

You can’t install two operating systems at the same time (not for long anyway), just ignore the slots, they aren’t really useful apart from their intended purpose.
I mean you can try a lot of stuff if you don’t lock the bootloader (or decide to repartition the phone), but I’m assuming your goal is to have a usable system in the end :nerd_face:


Good morning :person_raising_hand:

In the end you are right and …

what can I say?
I did it after reading the repartition-Link.
And it worked a 100% like a charm (or how do I say it correctly?).
Why are you @hirnsushi not an Fairphone-Angel?
In the end you also helped @bookworm, too in repartitioning.

Anyway, the outputs (just for the protocol), Success:

But first I set the path variable to my adb-platform-folder, so that I didn’t have to replace the path to IMG-Files and I was able to copy/paste the commands from the Howto.

I started by booting into the bootloader and rebooted into it again, just to make sure, that the commands are working with the new path entry.

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot reboot bootloader
Rebooting into bootloader                          OKAY [  0.001s]
Finished. Total time: 0.006s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash bluetooth_a bluetooth.img
Sending 'bluetooth_a' (940 KB)                     OKAY [  0.030s]
Writing 'bluetooth_a'                              OKAY [  0.005s]
Finished. Total time: 0.077s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash bluetooth_b bluetooth.img
Sending 'bluetooth_b' (940 KB)                     OKAY [  0.029s]
Writing 'bluetooth_b'                              OKAY [  0.005s]
Finished. Total time: 0.075s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash devcfg_a devcfg.img
Sending 'devcfg_a' (42 KB)                         OKAY [  0.012s]
Writing 'devcfg_a'                                 OKAY [  0.002s]
Finished. Total time: 0.043s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash devcfg_b devcfg.img
Sending 'devcfg_b' (42 KB)                         OKAY [  0.004s]
Writing 'devcfg_b'                                 OKAY [  0.002s]
Finished. Total time: 0.026s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash dsp_a dsp.img
Sending 'dsp_a' (65536 KB)                         OKAY [  1.613s]
Writing 'dsp_a'                                    OKAY [  0.139s]
Finished. Total time: 1.803s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash dsp_b dsp.img
Sending 'dsp_b' (65536 KB)                         OKAY [  1.559s]
Writing 'dsp_b'                                    OKAY [  0.171s]
Finished. Total time: 1.775s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash modem_a modem.img
Sending 'modem_a' (146188 KB)                      OKAY [  3.665s]
Writing 'modem_a'                                  OKAY [  0.331s]
Finished. Total time: 4.057s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash modem_b modem.img
Sending 'modem_b' (146188 KB)                      OKAY [  3.566s]
Writing 'modem_b'                                  OKAY [  0.360s]
Finished. Total time: 3.971s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash xbl_a xbl.img
Sending 'xbl_a' (3298 KB)                          OKAY [  0.090s]
Writing 'xbl_a'                                    OKAY [  0.013s]
Finished. Total time: 0.165s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash xbl_b xbl.img
Sending 'xbl_b' (3298 KB)                          OKAY [  0.084s]
Writing 'xbl_b'                                    OKAY [  0.011s]
Finished. Total time: 0.134s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash tz_a tz.img
Sending 'tz_a' (2944 KB)                           OKAY [  0.076s]
Writing 'tz_a'                                     OKAY [  0.011s]
Finished. Total time: 0.126s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash tz_b tz.img
Sending 'tz_b' (2944 KB)                           OKAY [  0.077s]
Writing 'tz_b'                                     OKAY [  0.011s]
Finished. Total time: 0.130s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash hyp_a hyp.img
Sending 'hyp_a' (399 KB)                           OKAY [  0.021s]
Writing 'hyp_a'                                    OKAY [  0.004s]
Finished. Total time: 0.067s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash hyp_b hyp.img
Sending 'hyp_b' (399 KB)                           OKAY [  0.019s]
Writing 'hyp_b'                                    OKAY [  0.004s]
Finished. Total time: 0.048s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash keymaster_a keymaster.img
Sending 'keymaster_a' (257 KB)                     OKAY [  0.015s]
Writing 'keymaster_a'                              OKAY [  0.004s]
Finished. Total time: 0.053s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash keymaster_b keymaster.img
Sending 'keymaster_b' (257 KB)                     OKAY [  0.011s]
Writing 'keymaster_b'                              OKAY [  0.004s]
Finished. Total time: 0.049s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash abl_a abl.img
Sending 'abl_a' (148 KB)                           OKAY [  0.011s]
Writing 'abl_a'                                    OKAY [  0.004s]
Finished. Total time: 0.045s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash abl_b abl.img
Sending 'abl_b' (148 KB)                           OKAY [  0.012s]
Writing 'abl_b'                                    OKAY [  0.004s]
Finished. Total time: 0.033s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash boot_a boot.img
Sending 'boot_a' (98304 KB)                        OKAY [  2.424s]
Writing 'boot_a'                                   OKAY [  0.221s]
Finished. Total time: 2.697s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash boot_b boot.img
Sending 'boot_b' (98304 KB)                        OKAY [  2.373s]
Writing 'boot_b'                                   OKAY [  0.231s]
Finished. Total time: 2.666s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash recovery_a recovery.img
Sending 'recovery_a' (98304 KB)                    OKAY [  2.474s]
Writing 'recovery_a'                               OKAY [  0.231s]
Finished. Total time: 2.762s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash recovery_b recovery.img
Sending 'recovery_b' (98304 KB)                    OKAY [  2.409s]
Writing 'recovery_b'                               OKAY [  0.243s]
Finished. Total time: 2.689s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash dtbo_a dtbo.img
Sending 'dtbo_a' (24576 KB)                        OKAY [  0.616s]
Writing 'dtbo_a'                                   OKAY [  0.056s]
Finished. Total time: 0.730s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash dtbo_b dtbo.img
Sending 'dtbo_b' (24576 KB)                        OKAY [  0.596s]
Writing 'dtbo_b'                                   OKAY [  0.057s]
Finished. Total time: 0.691s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash vbmeta_system_a vbmeta_system.img
Sending 'vbmeta_system_a' (4 KB)                   OKAY [  0.012s]
Writing 'vbmeta_system_a'                          OKAY [  0.002s]
Finished. Total time: 0.063s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash vbmeta_system_b vbmeta_system.img
Sending 'vbmeta_system_b' (4 KB)                   OKAY [  0.006s]
Writing 'vbmeta_system_b'                          OKAY [  0.002s]
Finished. Total time: 0.051s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash vbmeta_a vbmeta.img
Sending 'vbmeta_a' (8 KB)                          OKAY [  0.002s]
Writing 'vbmeta_a'                                 OKAY [  0.001s]
Finished. Total time: 0.021s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash vbmeta_b vbmeta.img
Sending 'vbmeta_b' (8 KB)                          OKAY [  0.009s]
Writing 'vbmeta_b'                                 OKAY [  0.002s]
Finished. Total time: 0.044s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash super super.img
Sending sparse 'super' 1/4 (780797 KB)             OKAY [ 20.677s]
Writing 'super'                                    OKAY [  0.002s]
Sending sparse 'super' 2/4 (751633 KB)             OKAY [ 27.026s]
Writing 'super'                                    OKAY [  0.002s]
Sending sparse 'super' 3/4 (726194 KB)             OKAY [ 19.988s]
Writing 'super'                                    OKAY [  0.002s]
Sending sparse 'super' 4/4 (586888 KB)             OKAY [ 22.007s]
Writing 'super'                                    OKAY [  0.002s]
Finished. Total time: 91.259s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash aop_a aop.img
Sending 'aop_a' (174 KB)                           OKAY [  0.016s]
Writing 'aop_a'                                    OKAY [  0.004s]
Finished. Total time: 11.880s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash aop_b aop.img
Sending 'aop_b' (174 KB)                           OKAY [  0.011s]
Writing 'aop_b'                                    OKAY [  0.004s]
Finished. Total time: 0.037s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash featenabler_a featenabler.img
Sending 'featenabler_a' (84 KB)                    OKAY [  0.005s]
Writing 'featenabler_a'                            OKAY [  0.003s]
Finished. Total time: 0.034s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash featenabler_b featenabler.img
Sending 'featenabler_b' (84 KB)                    OKAY [  0.006s]
Writing 'featenabler_b'                            OKAY [  0.004s]
Finished. Total time: 0.028s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash imagefv_a imagefv.img
Sending 'imagefv_a' (524 KB)                       OKAY [  0.022s]
Writing 'imagefv_a'                                OKAY [  0.004s]
Finished. Total time: 0.057s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash imagefv_b imagefv.img
Sending 'imagefv_b' (524 KB)                       OKAY [  0.021s]
Writing 'imagefv_b'                                OKAY [  0.004s]
Finished. Total time: 0.064s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash multiimgoem_a multiimgoem.img
Sending 'multiimgoem_a' (13 KB)                    OKAY [  0.009s]
Writing 'multiimgoem_a'                            OKAY [  0.002s]
Finished. Total time: 0.044s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash multiimgoem_b multiimgoem.img
Sending 'multiimgoem_b' (13 KB)                    OKAY [  0.011s]
Writing 'multiimgoem_b'                            OKAY [  0.001s]
Finished. Total time: 0.039s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash qupfw_a qupfw.img
Sending 'qupfw_a' (53 KB)                          OKAY [  0.010s]
Writing 'qupfw_a'                                  OKAY [  0.003s]
Finished. Total time: 0.041s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash qupfw_b qupfw.img
Sending 'qupfw_b' (53 KB)                          OKAY [  0.008s]
Writing 'qupfw_b'                                  OKAY [  0.002s]
Finished. Total time: 0.028s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash uefisecapp_a uefisecapp.img
Sending 'uefisecapp_a' (121 KB)                    OKAY [  0.012s]
Writing 'uefisecapp_a'                             OKAY [  0.003s]
Finished. Total time: 0.068s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash uefisecapp_b uefisecapp.img
Sending 'uefisecapp_b' (121 KB)                    OKAY [  0.012s]
Writing 'uefisecapp_b'                             OKAY [  0.003s]
Finished. Total time: 0.035s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash xbl_config_a xbl_config.img
Sending 'xbl_config_a' (94 KB)                     OKAY [  0.007s]
Writing 'xbl_config_a'                             OKAY [  0.006s]
Finished. Total time: 0.039s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash xbl_config_b xbl_config.img
Sending 'xbl_config_b' (94 KB)                     OKAY [  0.009s]
Writing 'xbl_config_b'                             OKAY [  0.004s]
Finished. Total time: 0.032s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash core_nhlos_a core_nhlos.img
Sending 'core_nhlos_a' (108556 KB)                 OKAY [  2.751s]
Writing 'core_nhlos_a'                             OKAY [  0.263s]
Finished. Total time: 3.066s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot flash core_nhlos_b core_nhlos.img
Sending 'core_nhlos_b' (108556 KB)                 OKAY [  2.623s]
Writing 'core_nhlos_b'                             OKAY [  0.250s]
Finished. Total time: 2.923s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot erase userdata
******** Did you mean to fastboot format this ext4 partition?
Erasing 'userdata'                                 OKAY [  0.733s]
Finished. Total time: 0.762s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot erase metadata
Erasing 'metadata'                                 OKAY [  0.018s]
Finished. Total time: 0.034s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot --set-active=a
Setting current slot to 'a'                        OKAY [  0.027s]
Finished. Total time: 0.041s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot.exe getvar current-slot
current-slot: a
Finished. Total time: 0.006s

c:\IMG-e-1.4-r-20220920220047-stable-FP4>fastboot reboot
Rebooting                                          OKAY [  0.000s]
Finished. Total time: 0.008s

It was easier than the easy-installer from /e/os website, I’m gonna delete it :wink:
The whole install-procedure via CMD took less time than uninstalling easy-installer. :+1:

Thank you, Thank you, Thank you.
It started up without any errors.

Best regards


There’s a local aspect to it, “heavens” usually get assigned to (bigger) cities, I live in the middle of nowhere at the edge of the alps. And I also hate answering emails :smirk:

That’s great news :tada:
I hope you have fun with your new /e/ installation :slightly_smiling_face:

Just out of curiosity, could you check fastboot flashing get_unlock_ability, it’s always interesting to see if the reset still happens.

1 Like