Incredibly slow and inaccurate GPS

With the same 1.6 OS my experience is

  • the convergence time is very poor (to the extend you cannot use it in a street to check where you are), but quite less than 15mn anyhow (2~3mn generally -outside homes of course)

  • once converged it does work for what I use it for : turn-by-turn GPS guidance for instance, with Osmand+, as long as it maintains a reasonable view to a car’s window or windscreen (on dashboard, etc. -not at the bottom of the car).

There are settings that will improve things: you must allow, for instance, the “assisted GPS” function, that will use neigboring wifi (and possibly GSM towers) to quickly converge to a raw location.
This generally means you also allow Google to know everything about your location and the wifi networks in your area, unless you try an alternative database, but these while numerous seem to be either too small (not exhaustive, not covering your area) or indeed not yet implemented (you can find an app recording GPS along with wifi towers to build that database, but not yet use it).
At least, I didn’t find a real alternative, while I am still very interested in this area…
The Google way seems to only work if you have a data connection (in my case).

Indeed the GPS is THE feature I hope will be much improved in the next Fairphone.
On this model it is close to ridicule… and really a factor of failure for many apps that use this function.

My experience is somewhat different…
With GPS EPO assistance and A-GPS enabled I usually get a fix in about 15 seconds.Accuracy (when using google maps’ navigator function in my car) is exact enough. If you’re a land surveyour it might be not be accurate enough, but I guess a phone is not the proper tool for that kind of job anyway.
Updated EPO files help a lot. The default updating function was crap till it changed with the 1.8 update (something to do with server settings), but if running 1-6 you can get around that if you install the FP1-EPO autoupdate app.
And I don’t think that A-GPS is linked to Google in any way. Ticking the 'Wi-Fi & mobile network location" box is a completely different thing. And of course NSA, GCHQ, DGSI and the others will always know where your phone is located, unless you keep it switched off…

@Herve5 In the release notes of Firefox for Android 35, it is stated that you can activate location scanning for Mozilla’s WiFi database.

@CDG I think the first step in your case is to deactivate EPO at all. (Settings > Location access > GPS Satellites and untick EPO). I read somewhere over here that EPO somehow is blocking A-GPS. And if you don’t mind Google having your data, you can also tick the option “Location via WiFi and network”.

If you want to give your data to e.g. Apple or another location database, you could have a look at UnifiedNlp.

Thank you all - I didn’t even know that there as a menu screen if I tapped GPS on/off button!

I am not sure I’ve done exactly what you seemed to suggest (as I said, I’m not too technologically oriented). This is what I have done:

  • Unticked GPS EPO assistance.
  • Ticked A-GPS.

Does that sound right? Anything I need to do re: EPO and A-GPS settings?

Huge thanks again!

I wonder what database you are referring to. Not the Nokia one, that’s for sure. :smile:
For the record, with the settings


my phone (using EPO and A-GPS) usually is quick to find my location - if (NB!) I did not change position in between by more than 200km. If I got a lock in, say, Paris, and take a train to say, Amsterdam, it takes up to 10 min to find my new position. That said, my old and trusted Garmin GPSMap60csx also takes some time. (But not as much.)

@CDG, I think you try with and without EPO. I’m not sure if @Stefan is correct. Stefan, can you find the source of the claim that EPO and A-GPS do not work together? They seem to do, in my case.

@humorkritik: i have to be more scientific when talking to you, always providing sources :wink: here is part of my assumption: A post by @keesj.

It’s not really a technical explanation, it’s more an experience they had during testing.

Sounds to me that the first fix based on EPO alone takes a while, while a first fix based on A-GPS works faster. Nothing wrong with that. Around 0.5 +/- 1 min is what I experience with EPO alone when not moving for more than several dozen km. Maybe @keesj can specify if he experiences a longer wait for a fix if EPO & A-GPS are both on.

(@stefan Sorry, matter of [habit][1]. :wink: )

1 Like

No need to apology! :wink:

My own reading of keesj’s post (which of course is pure guesswork on my side) was that he compared EPO only with EPO and A-GPS. As I already mentioned above, I have both EPO and A-GPS enabled and for the last few months (before upgrading to 1.8) have had no problems with getting fixes. Earlier I do have had the same experience as @humorkritik - when enabling GPS after a long journey it takes some time. Not the other week, though, when turning GPS on after a 130 km trip, I got a fix almost instantly.

I use “GPS status” ( You have a lot of similar apps that do the same that work as well.

In my case, GPS worked well in the beginning, then suddenly was very slow and inaccurate. With the app, I now know when the signal is ready. Sometimes I reset the gps-data or download extra data, if my gps-signal takes too long or is wrong.

I noticed no difference in selecting Google or Nokia where you can choose between those two.

Appart from, in my case, a far better response and first fix time in 1.8 than in 1.6, i found that my phone had a much faster fix when it was NOT being charged in the car. I than wrapped the cable around a ferrite ring and the fix was faster and more stable.
Using the aboce mentioned GPS status i can see the signal strenth of the sats is better when using the more ‘noice free’ charge cable.
Hope this helps as well.


My experince is: since I have 1.8 I get a quasi immediate and accurate fix.
I am now very happy

Hey…I wonder why nobody in this post recommended the following app (as *.apk available), which a FP user directly programmed for other FP users:

It can update the EPO files e.g. every 24hours (via WLAN or DataConnection) in order to have everytime the most up-to-date positions of the GPS satellites. Without this app the FP android version is not able to download this file relieable, which causes the problems.

I tested this nice, small piece of software now for more then 3 months (the very first version) and my result:
If I am outside with a moderate view to the sky I repeatedly get a first GPS fix within 15s (A-GPS is disabled), also if I travelled some 10-100 km or didn’t use the GPS for some days-weeks.

Give it a try, report back in some time and if it works recommend it.

Cheers, Robert

This is the reason why:

(The following posts are also interesting to read!)

@Stefan, @keesj :
OK, I missed to read this post, but anyway I claim this is not true, because:

–> correct!
The problem is here:

–> not correct!
The reason, that FP decided to disable the Android standard EPO usage in v1.8 resulted from problems of downloading the EPO files automatically from the Mediatek servers and apply the correct checksums.
Therefore the TimeToFirstFix is incredibly slow (>1min), because there are in deed no actual values for the satellite positions.

Exatly this problem circumvents the “FP1-EPO Autoupdate, by downloading the EPO files correctly, fast and with desired time intervals.

If you update regularly and automatically (in my case every 2 days) I never had a TimeToFirstFix of more than 30s, when beeing outdoor, normally about 12-15s.
During GPS usage I always disabled A-GPS as well as data connection.

You can read all the details on F-Droid and the linked XDA post.

If anybody does not agree: please give it a try and report back here about your experiences!
Cheers, Robert

Hi @therob are you saying that the current “1.8” http download is still failing on the checksum?
I already stated why we disabled the EPO download

@keesj: YES! I would state this, wehn using the build-in Android EPO download.

As far as I know the problem are at the side of the mediatek servers, where the MD5 checksums are wrong calculated! Therefore Android is thinking they are corrupted and trying again to download until it gaves up.

Otherway round: because of the problem with the EPO checksum, FP developer decided to completely turn-off the EPO download in v1.8. ( @anon90052001: correct me If I am wrong)

The “FP1-Auto-Update.apk” calculates his own MD5 checksum and therefore do not have this problem!
You can read more details here, which I already posted above.

Cheers, Robert

Just out of curiosity: if the MediaTek servers calculate the checksums wrongly, why on earth don’t they fix this? I would assume this would affect all MediaTek devices then - and they claim that’s about 30% of the Android market?

1 Like

My EPO update experiences:

  1. Right from the beginning, I turned off the automatic update function. I almost always disable all automatic updates on all computer-related stuff, partly to avoid unwanted data traffic, partly to be in control of my gadgets.
  2. Under previous FP OS versions, right up to and including 1.6, updating the EPO files manually has been more or less impossible (after twenty-something attempts it has sometimes worked). The FP1-EPO app solved this problem.
  3. After upgrading to 1.8, the built-in manual update function works perfectly, no doubt because of the switch from FTP to HTTP as described by @keesj here. So the FP1-EPO app is therefore not necessary.
  4. I have not noticed that enabling (updated) EPO files delays getting a first fix. On the contrary: I normally get a fix within 15-20 seconds, while it takes longer if I disable EPO.

This tip is a great tip. Now I understand why the gps is so slow in the car, but works fine outside. In the car I always connect the power. I tried it in the car without the usb power cable, and yes, a quick fix.
I always thought the metal roof of the car messed things up, but alas…
Now I just need to get a ferrit ring.
thanks a lot for the tip.