English

Inactive screen doesn't stay on for more than 30 seconds

Hello,

After installing Android 6.0, I can’t have my screen stay awake for more than 30 seconds if I’m not using the phone.

The Sleep setting is set to “After 5 minutes of inactivity”.

However, if I leave the phone alone, the screen goes black after maximum 30 seconds…can’t get it do stay longer.

What can I do?

Thanks in advance for your feedback.

I have the same issue!

I switched to Fairphone after being an iPhone user of 10 years and love it, I’m a complete convert but this is verging on being a show stopper. It is certainly putting my partner off from making the switch as well.

It is extremely annoying, you can be having a conversation with someone and the screen keeps going to sleep. Watching a video clip on Instagram and the screen goes to sleep. You get 25 seconds before the screen dims, then 5 seconds later it sleeps.

I have seen a post about being able to get around it by installing the open OS but I don’t want to go down that route for what surely is such a simple thing to resolve.

PLEASE fix this and allow me to sing the praises of the Fairphone to everyone I come into contact with, rather than saying ‘yeah, its good but until they fix the screen sleep issue I wouldn’t bother’.

I am keeping my fingers and toes crossed - I want to love this phone!!

Do you use any third party battery saving / profile switching / lock screen apps? It seems strange that only a few users are affected by this. @nvdw reported that it is stuck at 2 minutes.

No, my phone is about as vanilla as it gets as I have only had it about a week.

It surprises me that more people don’t have the same issue, I was hoping someone would say ‘duh, you gotta tick a box’ or something.

Yeah, I have the Settings -> Display -> Sleep set to “After 30 minutes of inactivity” - and it behaves so, i.e. basically I have to press “Power off” in order to turn the screen off.

I would be much happier if it did that instead of switching off after 30 seconds all the time.

It was reported in the thread below but I don’t see having to resort to Open OS as a viable solution:

This continues to be the major issue for me with my Fairphone since switching, have tried everything I could find via searches etc to try and fix but no luck.

If anyone has any suggestions I would be extremely grateful!!

There is a solution in the thread that you are referring to, but it requires root (not necessarily Open OS). If you don’t want a permanently rooted phone, you could temporarily boot with a rooted boot.img, apply the fix and then go back to the original boot.img.

I’m also pretty sure that a factory reset would fix it (since the faulty value is stored in a database which gets erased when wiping the phone). But I understand that this is something most people would want to avoid.

(After reading through the linked discussion it still seems a mystery why this happens to some phones after all.)

2 Likes

Hi,

Sounds interesting.

How would one boot with a rooted boot.img though, could you give some more explanation on that?

Thanks a lot!

A rooted boot.img may be found on the server of @retsifp at https://fp2.retsifp.de (depending on the is version you’re running).

An information about how to use fastboot (e.g. to start this boot.img) may be found e.g. here: https://forum.fairphone.com/t/howto-use-twrp-without-flashing-it-e-g-for-backup/23747

3 Likes

Success!! A factory reset did the job and fixed it.

I did a factory reset and when the phone came back on I didn’t configure anything, just clicked through without logging into a Google account or setting anything to see how the phone behaved and sure enough, the display sleep setting acted as it should do.

I then did another factory reset but this time logged into my Google account and restored the last backup. This time however the issue returned!

A 3rd factory reset and this time I logged into my Google account but I didn’t restore the backup and pleased to say the display was back to working.

So… the fix for me was, a factory reset but don’t restore from backup.

Thanks for everyones help and input with this, much appreciated :slight_smile:

1 Like

This topic was automatically closed after 182 days. New replies are no longer allowed.