English

Impossible to take phone calls after OS update

Dear all,

some days ago I updated my FP2 OS (at that time I didn’t know it was doomed due to the end of support for the bottom module), and since that day, I cannot take phone calls anymore. No icon displaying incoming calls appears on the screen; I need to close all applications and look for the telephone, and then, maybe, in < 50 % of cases, a question arises “return to incoming call” or something in that line.
Is that a bug? Someone else also had it?
Someone knows how to fix it?

Thanks a lot for your help!

Eva

Hellooooo!
No one able to help me?
No one having the same bug?

Best regards,

Eva

First you might check if all permissions are set for the phone app and if the app is allowed to run in the background and if there’s an exception for power saving set.
If all that is ok then you might try out a different phone app.
You can also check if there’s enough free space on internal storage.
Also try out to clear cache (and maybe data) of phone app.
If all that doesn’t help you may do a backup (via Google or via TWRP) followed by a factory reset. Then you should try again.

3 Likes

Volker,
that was the solution!!! Thanks a lot.
I simply didn’t think that the app parameters were modified during the update. The phone app was not allowed to pop up when the phone was ringing.

Problem solved!

Eva

4 Likes

where do you find that?

Long press on the app’s icon→App Info→Permissions→Advanced→Display over other apps
(and you can also check the other permissions at the same time)

Yes there is an popup, if I swipe the small phone icon on the top, i can use the answer button, but then the screen is again black, ik cannot close a call, only with using the fysical button, cannot open my agenda, I use the standard phone app, This is since the upgrade, i have two simcards, Normally i got an blue or an green screen, then I knew if it was a private or business call.
I am googling for answers, nut have not found it yet

I think you just have to recalibrate the proximity sensor. Go in the settings→System→Maintenance→Proximity sensor calibration, and follow the instructions.

2 Likes

Yes, thank you, that solved it

3 Likes