English

Impossible to reach the bootloader on FP2 [SOLVED]

Tags: #<Tag:0x00007f05daedeec8> #<Tag:0x00007f05daeded88> #<Tag:0x00007f05daedec48> #<Tag:0x00007f05daedeae0>

Hi,
I tried to install LineageOS on a FP2. Unfortunatelly, the phone stays stucked on the home screen :
FAIRPHONE
POWERED BY
Android
when I try to turn it in fastboot mode.

I tried to unlock it with this command :
fastboot oem unlock
even with sudo but unsuccessfull. In fact, I don’t know if the phone is blocked or not.

Can you help me to made the phone booting in bootloader ?
Many thanks for your help.

Does the LED flash blue when you do that?

Have you followed the instructions at https://wiki.lineageos.org/devices/FP2/install?

It sounds as you’re in fastboot mode at this stage.

No need for that. FP2 is always unlocked.

As described in the document linked above the steps are to

  • start with fastboot and install TWRP from there
  • start recovery (TWRP)
  • install LOS when TWRP started via adb sideload or via “install” function of TWRP
3 Likes

I start the phone, entering the PIN code.
Then, I enter the command :
adb devices to be sure the phone is recognized with adb

So, after entering :
adb reboot bootloader
the phone seems to reboot (it vibes 3 time) and stay on the home screen (starting screen) and the blue led flashes slowly. And that’s all…

Yes, that is the exact description how Fastboot mode looks like. Fastboot mode means that your phone becomes a passive recipient of commands.

2 Likes

Yes !

I have installed TRWP but I can’t reboot in recovery… I’m still stucked on the home screen.

Once TWRP is installed on the FP2, you can unplug the phone from the computer. You can boot into TWRP by holding the POWER button and the VOLUME UP button simultaneously for a long time.

2 Likes

I finally managed to install Lineage. I guess the keys combination I was using to reboot was wrong (“sound down + power on” instead of “sound up + power on”).
Anyway, thanks a lot for your help.

Small subsidiary question: will Lineage updates be offered automatically as soon as one of them is available or is there a special procedure to upgrade the OS?

1 Like

Settings > System usually offers you updates on a daily basis, so you will have to trigger one manually.

1 Like

Thanks. :slightly_smiling_face: