Impossible to enable data after roaming


My provider has a poor network and made an agreement with another provider so that customer can switch automatically on its network when they have no connection.
Often the evening when I want to enable mobile data nothing happens…The network logo won’t change, and I have no internet at all.
The issue began last week, it was only when my phone was roaming at first, switching back to my provider solved the problem.
Now it happens even when not roaming. I have to reboot the phone, using airplane mode is not enough to solve it
I assume it happens if my phone has been roaming during the day.

Does anyone has had this issue yet, or has any clue on this issue ?

Thanks for you replys

Edit 1 : Typo / improving comprehension

If the software doesn’t know anything about the agreement between your provider and the other one, this is the way things should go.

You can override this behaviour by enabling mobile data in roaming (it should be inside the SIM settings).

The solution would be Fairphone implementing this agreement. (Is it new?)

I have already enabled mobile data in roaming.
I have been using this provider since 2012, back then this agreement already existed.
I use a Fairphone since last summer, and it worked fine until last week.
There has always been limitations on roaming (clients of the over provider have priority, so data connection is poor when roaming), and it’s getting worst since they changed their agreement to reduce further brandwidth ( < 1Mb/s since the beginning of the year).

I guess it’s due to these changes, since my problems started then. I’m going to ask on my provider’s customers forums wether other people meet this issue.

Thanks !

That is weird.

Could you try

  • booting your phone
  • waiting a bit
  • putting to phone into flight mode
  • waiting a bit
  • start to collect logs (normal and radio buffers in D, please)
  • disable flight mode so that you should be roaming
  • removing any personal information
  • posting it here?

(The logging commands should be something like

$ adb logcat -b radio \*:D >> $(date -I).radio.log &
$ adb logcat \*:D >> $(date -I).normal.log &

I wanted to link this tutorial, but sadly it’s not there, yet.)

1 Like

Did you ever connect manually to a network? Then it will only connect to this one.

Even if not, try the following:

Settings > wireless&networks > … More> Mobile networks >Network operators.

As soon as the networks are found, tap on “Choose automatically”

I have gathered the logs you asked,but its ~ 6k lignes for radio, and ~9k lines for normal. Can you tell me which lines I have to look for ? I can’t upload text or archive files.

Irina_Spitznagel -> I have tried to use “Choose automaticcaly”, but it doesn’t work. Only a reboot would work…

Thanks for your help

You could try looking for something data or APN related. I don’t really know.

I have been having the exact same issues for a week now. I somehow thought this was related to the latest FPOpen update (I am on 16.12.0 now). It is really a hassle. Had to reboot five times yesterday.

I hadn’t made the link with roaming, just noticed that connectivity was lost randomly when I was on the move. This never happened before, for the same commutes. And I didn’t change any settings.

I will try to gather logs as well, as soon as I have time.

Same issue here (in France) with FreeTelecom provider using Orange network!

Did someone had any chance to have more insights on this behavior or maybe a fix?

In fact i’m a FreeTelecom customer too.

According to this article, it’s not a Fairphone issue, lots of FreeTelecom customers havethe same issue with different phones. I’m considering changing provider soon. I’ll tell you then if it solves this.

lots of FreeTelecom customers have the same issue

Somehow it is good to know where the problem comes from (even if it does not solve it since this one is network related). Thanks for the info ! :wink:

Your article points out to a dedicated (French speaking forum) discussion and today’s messages point out a possible technical solution from operator ! Let’s see if it turns out as a solid and stable resolution. :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.