Howto install Calyx OS on FP4

On the Matrix testing channel I read that there could have been a bug that messed with lock/unlock in earlier images that has been fixed in the latest image. So maybe that’s what could have happened to you?

Possibly. But if so, re-flashing with the latest image does not fix things. When I tried this at first I was happy because immediately after flashing get_unlock_ability was 1 - but after booting into CalyxOS OEM unlocking still was disabled/greyed and get_unlock_ability again was 0.

OK, I’ll wait if someone finds a safe way to fix this. :grinning:

I know it’s not mentioned in their instructions and they weren’t clear about it when people asked them on Matrix in the past, but they are shipping critical partitions and there is code in to flash those. What would be the point of including those if you don’t want them to end up on the device? :man_shrugging:

Fairphone had to be made aware of that command as well and they subsequently changed the documentation to include it. So if you follow the official Fairphone guide to unlock the bootloader, you’ll end up with critical partitions unlocked as well.

As I was saying, those critical partitions are still the same across the different custom ROMs (and stock FPOS) as far as I can tell, so you probably don’t have to change something on your newly installed system because you already were on the right version, but that might not be the case in the future.


So one thing that apparently does not work when you haven’t used unlock_critical is automatic OTA update. At least the first one. According to information from the Matrix channel, you need to sideload the first OTA update. But the next should be fine and work as expected.

To sideload the Calyx OTA update do the following

  • download the full ota-update from

  • make sure that USB Debugging is enabled in Developer Options

  • connect you FP4 to your PC and run adb reboot recovery

  • when the FP4 has rebooted, the android lying down will appear and on the bottom of the screen it should say “no command”

  • press Power & Vol +. This should open the recovery menu

  • with Vol - select Apply update from ADB. Confirm with Power

  • on your PC run adb sideload Your PC will show a percentation progress, your phone will show some status messages. This will take a few minutes

  • when finished, the menu will appear. Select reboot now

Phone should reboot into updated Calyx OS

1 Like

I followed all the steps but got this message and after reboots its in a boot loop. I can get to to bootloader but Calyx dont start.?

Waarschuwing: ‘stripe’-breedte 1 is geen even veelvoud van ‘stride’ 2.

/tmp/TemporaryFile-44cKFP: Ongeïmplementeerde Ext2-bibliotheekfunctie tijdens aanmaken van superblok
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

That sounds like a problem with Android Platform-Tools.

  • What OS and version are you running the script on?
  • What’s the output of fastboot --version and mke2fs -V?

Since you are only failing the "wipe userdata" step, have you tried booting into recovery (fastboot reboot fastboot and select “Enter recovery”) and using “Wipe data/factory reset”? :thinking:
I’d still fix that problem on your PC afterwards if I were you :upside_down_face:

I will look at the things you said. It’s probably outdated…as you say. For now I switched back to FPos. I made a clean install

Some (Calyx-)newbie questions:

  1. Where can I find all the Fairphone 4 builds? In the thread you linked some builds (an install build in the first post and OTA here) and you stated to check for newer builds, but where? leads to a “403 forbidden”
  2. Can I still root with Calyx or is it completely against the concept? (Yes I read Security FAQ , but I really like to use apps like Neo Backup, to transfer my data, which will not work without root)
  3. If there is a way for 2. - what does it mean for all the bootloader locked or not locked discussions and/or possibility to use OTA Updates? When I read the thread here it feels like the locking does not work well together with OTA, Magisk (root) does require an unlocked bootloader - probably only the fastboot flashing unlock is needed for that.
1 Like
  1. Here is a link to the latest 3.7.2 version, it’s only almost released that’s probably why there hasn’t been a blog post about it yet. I’ve been running it for a few days already and so far no issues.
  2. + 3. You can, Magisk works great, I can’t live without it either. You can’t lock the bootloader since Magisk modifies the boot partition. OTA updates are not a problem though, just follow these steps:

3.7.2 is still in Beta, and they’ll probably make a news post once it hits Stable. that being said, I haven’t encountered any issues running it.

1 Like

Thx for the quick reply. Most of the stuff is clear to me now.

Just some details / double check questions:

  1. When we talk about unlock bootloader is it just the fastboot flashing unlock or also fastboot flashing unlock_critical? The last one was discussed here in some posts and it seems that also /e/OS and official Fairphone guides point on that. So do you leave this second option unlocked as well or do you lock it again (at least in between updates or so)? As far as I understood it should stay unlocked as well, at least in regards of the following two issues (correct me if it is wrong):
    ** during first installation with the factory version → to get rid of a lot of FAILED (remote: 'Flashing is not allowed for Critical Partitions')
    ** prevent problems during OTA updates

  2. The update procedure is performed within the running CalyxOS (except the reboot of course), right? (uninstall Magisk within the Magisk App; run the OTA update; install Magisk again [via inactive Slot option] ← never saw that up to now tbh - anyway.

  3. the first installation of Magisk procedure, you explained here, is still the recommended way? (with a boot from the patched boot image in between) - I didn’t get the A/B boot image point up to now, so I feel a bit unsafe and I think I will pick the boot.img from the Calyx factory zip for patching in Magisk App.

(Last point: I can edit the initial post as well (handled like a wiki post I think - and depending on the privileges some users can edit). @R2D2 do you mind when I (/we … whoever can) edit it, in case there is anything to add/re-word (first example might be 'unlock_critical`)?)
EDIT: Will eventually create a separate guide for Calyx including root and don’t touch this one…


  1. I read some more stuff and I think both should stay unlocked, as boot partitions are critical partitions. So Magisk setup would fail without it. Also at a later stage during OTA updates Magisk will be uninstalled and installed to inactive Slot, which will probably fail, when the critical partitions are locked again, right? Furthermore locking in between does not really make sense in such a setup, as it always wipes everything ´unlock_critical´ as well as ´lock_critical´.
    With that said I think 1. is answered. Feel free to add/correct.
  1. Yes you should use fastboot flashing unlock_critical and I would keep it unlocked. I’m not sure if there are still problems with locked critical partitions when it comes to OTA, haven’t seen anything scroll by on Matrix. :man_shrugging: But since you have to keep your bootloader unlocked for Magisk anyway, might as well keep everything easily accessible.
    Magisk doesn’t touch critical partitions though, so you could lock them, it’s just more hassle if you do (and have to fix something)
  2. Yes, performed on a running Calyx system. Just a quick Magisk uninstall → OTA update → Magisk install to the other slot. I’ve used that method on several updates without any problem.
  3. The Magisk install procedure is still the same, you just use the boot.img from the Calyx factory images, that’s correct :+1:
1 Like

And thanks for all your informative posts and your quick reply, @hirnsushi , they really help to get things sorted (it was a bit different with the FP2 which is still in use here :wink: ).

Also thanks for that, will use it, when I going to flash the first time, but with my first question here I meant more a page like Lineage has (example for FP2: LineageOS Downloads ) where I can see the builds listed or so!? With that way you can just point to the lastest build. Right now, it feels more like one has to know the URL. ^^

1 Like

Yeah, I always have to dig through their news section myself when I need the link. Can’t seem to remember putting it in my notes :see_no_evil:
CalyxOS on the FP4 is still in the testing phase, not installable through their “easy installer”, that’s why it isn’t featured more prominently on the website.

Regarding the link, I just took the latest link from their news ( and swapped the old build number 22305000 with the newer 22307020 mentioned here.
That usually works with all kinds of stuff :smirk: (for example Fairphone kernels)


Worked well. Thanks again @hirnsushi

Phone is running with CalyxOS 3.7.2 + Magisk 25.2 :white_check_mark:


Hello all, many thx to R2D2 and hirnsushi for the nice guide and support. After some trouble with the drivers on windows and the usb connectivity at ubuntu i finally made it. 3.7.2 works very well right now. THX!

I checked on for newer updated and found the version 3.7.3 did anyone already flashed this version?


That version has only been released for the Pixel 6a for now, have a look at the checklist :white_check_mark: in that issue.
Might still be some time till this reaches the FP4 :slightly_smiling_face:

Oh and welcome to the community :wave:

Did the Calyx install script also overwrite the recovery?
At least there is one step executed during the installation (I saved it when I installed 3.7.2):

extracting recovery.img (96 MB) to disk... took 0.326s
archive does not contain 'recovery.sig'
Sending 'recovery' (98304 KB)                      OKAY [  3.703s]
Writing 'recovery'                                 OKAY [  0.254s]

Now I was looking for a way to flash a zip (in my case it just contains an app, which should be installed as system app - background is a test with a camera installed as system app - see here).

So I have a flashable zip and was looking for a way to install it. Normally there were options in recovery (probably I remember TWRP) to install such a zip directly or to start adb sideload and flash it on that way.

First thing which confused me was the way of accessing the recovery (I don’t remember that I booted into recovery with my FP4 before, so I cannot tell if it always looked like that):

  1. device off (no cable connected)
  2. hold “Volume Down” key + insert charger (release “Volume Down” key, when the fp logo shows up)
  3. select “recovery mode” (with “Volume Up/Down” keys) and confirm with power button
  4. I will boot in a “No command” screen (I did not remember from other recoveries I used before)
    Recovery no command
  5. Hold “Power” + “Volume Up” keys … and it will finally boot into the recovery menu

I assume in there
Android recovery
I can use “Apply update from ADB” to sideload a zip?

Or is there any other recommended way to do this?

  • flashing a different recovery first with some more options or
  • install system apps without flashing e.g. like described here (copying the apk to the right folder, set correct access permissions and reboot)

Flashing random .zips usually isn’t a feature in any of the modern recoveries, those were the good 'ol TWRP days :face_with_monocle:. But even if it was, I would strongly advise against using it, you will break OTA-updates.

Don’t modify /system directly, create a Magisk module.

1 Like