How to switch/downgrade from Lineage 15.1 to Fairphone Open?

Sorry, I can’t find an answer to this, I’d be grateful if someone could point me to it:

I’m trying to get to the bottom of random reboots (mostly happening while charging but not always) and since I’ve tried the paper under the battery (and even in the sd-card-slot), not using the case, not using a simcard, switching the sd-card I now want to try to reinstall the OS without an sdcard and while doing that I’m thinking giving Fairphone Open a try (I was on LOS 14.1 before and upgraded to 15.1 a few weeks ago). I think I’m not ready for Ubuntu or Sailfish yet :slight_smile:

I guess I’ll need to wipe system/data (and cache/dalvik) when downgrading from LOS to FO?
Thanks in advance!


Well I found and tried this and that didn’t work +___+ Got an error that Dalvik-Cache isn’t found and phone reboots after starting apps. Back to LOS for now (hopefully …).

Unfortunately, I don’t know a solution either, but I feel bad that no one has answered you, so here, have an answer (even if it doesn’t help you) :slight_smile:

Haha, thanks, that’s so nice! :grinning: I was wondering why no one was answering because usually people here are super fast and I thought that others probably have done what I’m trying to do, but mabye not.

Anyway, TWRP-Backup saved the day again, I’m back to LOS 15.1 for now :ok_hand:

Will probably install LOS without an sd-card at some point to see if that’s the problem.

At which point did you get this error?
In TWRP when wiping Dalvik cache, or in the OS installed afterwards?

1 Like

Hi, I don’t have an answer, but I also have this while / after charging reboots.
With the last update of LOS 15.1 I dropped xposed to see if this changes the situation, but can’t say anything yet.
I left Fairphone Open because the browser was stuttering, so going back is no option for me anyway.

Which browser? The stock one? There would be alternatives …

1 Like

No Dolphin because of scrolling with volume keys, it even lagged doing pagedown

I got the Dalvik-Cache-error after flashing the Fairphone-Open-zip in TWRP. It also said something about like „Script succeeded with result of [t]“ which I though was weird, I think it’s supposed to be [1] or [0] usually?

Then when rebooting TWRP warned be that no OS is installed. Thought I’d give it a try anyway and after booting for a long time the usual messages when booting a clean Android for the first time started to appear („Starting Android“, „Starting apps 1/23“). That last bit that was interesting because I think that means was an OS installed after all not just a bootloop, or am I wrong?

After that I tried to flash a up-to-date LOS 15.1-zip but it gave a super weird error saying something like „This zip is for FP2 but you phone is .“ (Just a an empty space where supposedly the phone name should be).

Restored the LOS with TWRP backup after that, super happy that this at least worked :grimacing:

Interesting, so did you also have reboots while charging on Fairphone Open or did that start with LOS?

Which TWRP version are you using?
This error happened with rather old versions and could be resolved by flashing a recent TWRP.

Sorry, I can’t remember anymore, it’s been some time, and the stutter issue was the biggest problem, other problem was mail checking interval not reliable, this was “solved” through another workaround…
as far as I remember I always had some reboots (but I always had tweaking apps as well)

1 Like

I just double-checked, I’m using version 3.0.2-0, that looks like it’s up to date, isn’t it?

Ah, ok, no worries :slight_smile:

3.0.2-0 comes with Fairphone Open OS since ages and is way old (and on the Fairphone 2 doesn’t even support decryption of an encrypted data partition).

3.2.3-0 is current as you can see on the page you linked to (3.0.x isn’t even on the list there anymore), I would recommend trying to install any OS again with the current TWRP.

1 Like

OMG, you’re right, I didn’t even realize! I was transposing those digits hard … :sweat: Cool, let’s update that!

But also: Am I seing thinks or are some of these links colored slightly different? I thought I had already downloaded the last three.


but… my phone just booted while charging, so dropping xposed doesn’t help

I am using Fairphone open and can tell you the random reboots are happening too.

Although the reboots are not entirely random: they only occur when there is some data being fetched, and there is no stable data connection.
Switching to flight-mode when on the move is an option to prevent it (but what’s the use of a smart-phone then ?)

You say it’s mostly happening when charging the phone. Could it be that it is at a spot where there is a bad GSMreception?

1 Like

Cool, thanks for the reply, so I probably don’t need to try Fairphone Open then (even though, there are obviously many reasons for reboots …).

For me reboots mostly happen very early in the morning when I’m sleeping and the phone is charging (If I don’t wake up from the vibration while restarting I can still tell because I need to reenter the password for Threema after each reboot).

The phone is in Flight Mode during the night so it’s probably nothing to do with GSM reception. I’m using Battery Charge Limit, so I can’t really tell if the phone is rebooting while charging or not. But reboots are also happening randomly during the day.

I still think it’s probably the sd-card (or rather the card slot since I tried different cards) because I also have problems with icons of apps that are on the card dissappearing when rebooting (I’ve been told that this happens because the sd-card is mounted after the system starts up) and other weird sd-related stuff.

Now that I think about it I don’t remember the phone rebooting while I was activly doing anything with it, it’s always when it’s in my pocket or on a desk somehwere. Weird.

Hi, I don’t see this reception-connection, but if I don’t forget I’ll charge in flight mode the next time!
About reboot while fetching data: the last reboot was in standby with display off, don’t think that there was much data transfer.