English

How to root the Fairphone 3?

Hey @AnotherElk, tnx :-).

Lineage works just fine now, except for the ‘debugger’. I wanted to install Magisk to be able to root my phone, because I wanted AFWall+ to work. I read the ‘Magisk’ link you send. I presume that is just fine to do (I will not lock the bootloader again ;-)). Do you think there is a solution to get the debugger working again? Or is this functionality gone forever?

tnx again.

Update:
It seems I can make a connection with the phone in ‘recovery’. With ./adb devices in terminal it says: ’
List of devices attached
[number] unauthorized

When I write ./adb sideload Magisk-v20.4.zip in terminal I get:

adb: sideload connection failed: device unauthorized.
This adb server’s $ADB_VENDOR_KEYS is not set
Try ‘adb kill-server’ if that seems wrong.
Otherwise check for a confirmation dialog on your device.
adb: trying pre-KitKat sideload method…
adb: pre-KitKat sideload connection failed: device unauthorized.
This adb server’s $ADB_VENDOR_KEYS is not set
Try ‘adb kill-server’ if that seems wrong.
Otherwise check for a confirmation dialog on your device.
'adb sideload connection failed: device unauthorized /

Maybe this information help in solving the problem.

Or should I do a factory reset? The last time I got back to google I got the debugger-problem so it seems that resetting is not the solution (?).

That means that you once have to access the phone via adb during normal system start. Then on the phone there should be a pop-up asking for permission to allow USB debugging from this computer (select the checkbox to always allow this computer).

1 Like

Hi @Ingo, accessing the phone during normal start is the problem (waiting for debugging). Or do I not understand you well? Do you mean that I have to try to make ‘during’ normal system start? How does that work?
Or did you mean to make a normal system start, make the connection and so on in the normal way. I tried it this way, but that still doesn’t work. I don’t get a pop-up for USB debugging permission.

Hi all,

the solution above does not seem to work. I don’t get a pop-up asking for permission to allow USB debugging.

I installed TWRP and LOS 17.1. I unlocked the phone, flashed Magisk en locked the phone again. The last step was apparently the the problem. I did a factory reset. Got back to Google. Then I was able to manage to unlock the phone again via fastboot and flash TWRP and LOS again. I could do this while ADB said I have an unauthorized phone.

Is the above to say that my phone is bricked? I mean, I have a working FP3 (with LOS) installed.

The only problem is that I am not able to connect the phone via adb. I tried a lot to fix the problem via information on several threads of xda-developers and stackoverflow.

And if there is no solution for this, please let me know!!

btw my bootloader is unlocked

btw 2. I tried to install Magisk in this way:

But that didn’t work either, because I got stuck at step 8. 'And finally install MagiskManager-v7.5.1.apk

Do you have a notification saying “USB debugging activated”?
You can try to go in the developer settings, tap on “Revoke USB debugging authorizations” and try again.

If you can access fastboot mode, your phone isn’t bricked.

What do you mean you got stuck? You didn’t manage to download the apk?

Hi Alex,

tnx :-). I can access fastboot mode. The thing is I that when I try to start twrp via fastboot boot (in this way ‘./fastboot boot twrp-3.4.0.0-FP3.img’) I get the following message in terminal:

< waiting for any device >

So, that’s where I got stuck…

Why ./ in front of the command? There is no need for it.

A little remark: It’s 3.4.0-0. I hope it’s just a copy paste problem.

It’s a mac (mini). Terminal doesn’t recognize just ‘fastboot’. With 3.4.0-0 I (still?) get the same message ‘waiting for any device’.

btw adb recognizes my phone now.

If adb recognizes your phone that means you are not in fastboot mode. Are you sure you are in fastboot?

1 Like

ah, tnx man! I feel so stupid, but ok. It’s solved :smiley: :smiley: :smiley:

2 Likes

Hello folks,

It take me me times but I succeeded. My Fairphone 3 is now rooted and I wrote a tutorial about it:

Please look at: https://adminblog.foucry.net/posts/info/root-fp3/

Thanks for reading me.

2 Likes

Sounds cool, thank you for sharing.
Someday I will try it on my FP3+, when I will feel daring enough! :grin:

Hey jfoucry,

Such good news! :smiley:
I just started to follow your guide for my brandnew FP3+ which runs LOS 17 now.
There it says:

“Go inside it with the cd command”

As a Windows user I never had any contact with Linux and am not really familiar with command lines. So I got no idea what the “cd command” could be and how I could use it. :thinking:

Could you please help me?
edit: ah, ok, you just want to look at the files in that folder.
All right and done :slightly_smiling_face:

Here’s a very good and short 1 page introduction to the basics …

3 Likes

@barney
Oh! I’m sorry, I did know windows so my commands are for unix like OS.

Happy to read that you found what i mean.

But would the guide work with LOS17.1? I mean you take the boot.img from the stock ROM. Not from Lineage.

With LOS it’s “easy”. Boot into twrp and install Magisk.
Only thing is (and i hope someone will prove me wrong) that you have re-flash after an update

He made another “guide” that says take the LOS17.1 image and do the same like you did in the guide.

What do you mean with boot into twrp and install magisk. If I look on the magisk website I also see only the guide that says "patch the boot.img and flash it. I don’t see any file that says “hey just take me and flash me an everything will be allright”. Ok. Maybe the next update kills magisk. But you can flash the file again. But there is no file like this. If you have a source for this file. Then show it please.

You take the flashable magisk zip from here: https://github.com/topjohnwu/Magisk/releases
That’ll patch the boot.img for you.
Also, you’ll need magisk manager as app, but this will survive updates (and update itself)

2 Likes

Hello @lklaus

It’s not what I reading in the magisk_manager doc. I need to find a boot.img and patch it with magisk-manager.

Now LinegageOS support officially FP3, where can we find the corresponding boot.img.