How to install XPrivacy/Xposed on Fairphone 2 with the Open OS?

I finally managed to get my contacts synchronised with my new Fairphone, which made me happy. And then I discovered that Skype had immediately sucked up the entire address book, hundreds and hundreds of phone numbers now irrevocably handed over to Microsoft, without ever asking my permission.

This makes me really angry, I honestly expected this information to be protected somehow. I know it says what permissions are being granted, but there’s no option to say “no” other than simply not install the app. What am I supposed to do, only install apps from developers I’m happy to see every aspect of my life? Because that’s precisely none of them.

Anyway. It seems the definitive solution is to install XPrivacy. But the page here is not much help. It links to the Xposed framework but there are no instructions on how to install it. I’ve now downloaded two separate apps, one called “Xposed Downloader” and one called “Xposed Installer”. The former downloads a file, but I don’t know what to do with it. The latter claims that “Xposed is not (yet) compatible with Android SDK version 22 or your processor architecture (armeabi-v7a).” And yet people do seem to be using it.

So is there some definitive step-by-step guide out there on how to get this all up and running on an FP2?

I sorta knew that the world had collectively given up on privacy, but I’m still shocked to see it in action like this. Perhaps a reasonably user-friendly guide to installing XPrivacy could go some way to changing people’s expectations.

You might check this thread:
But please be aware that you need to flash xposed v87 with the current os.

1 Like

Xposed finally has made it to F-Droid!!! :smiley: :smiley: :smiley: :tada:

Edit: It doesn’t yet work on my FP1…
Edit2: Not even after installing Busybox… Somehow it “doesn’t find the zip files”, whatever that means.

You could also wait some weeks until Android 6 Marshmallow arrives on the Fairphone 2. It has a permission control (which is less powerful than XPrivacy).

I did see that thread, but it doesn’t make things much clearer. It’s certainly not a step-by-step guide. I don’t even understand what “flash xposed v87 with the current os” means.

1 Like

Yep, that’s one of the apps I tried, and it didn’t work for me either. But perhaps this means it’s under active development and it might work soon?

Reading about Marshmallow’s permissions editor, it seems to suffer the same obvious flaw as the iPhone I’ve been using the last few months: apps can simply refuse to run until you give them the permission they want. WhatsApp pulls that trick. I solved that problem by simply keeping the address book empty. And I guess that’s what I have to do now.

Also I’ve deleted my Skype account, hopefully Microsoft will respect that and actually delete the address book too. But I’ve discovered that Amazon and WeChat probably both did the same thing. Certainly nothing I can do about the latter, and that also implies the Chinese government has a copy.

Maybe I’ve led a sheltered life, but I’m just flabbergasted that people are happy with this.

1 Like

If i remember correctly in that thread there’s a link to the xda thread, which might explain more… On other hand, if you’re not (yet) comfortably with flashing you might be better off getting the concept first. It’s not that difficult, but it’s better to know you way round, as you have the possibility to shoot yourself into the foot easily

1 Like

We have a step by step guide integrated in this wiki:

If the XPosed Installer from F-Droid doesn’t work yet just use the one linked above.


Hooray I got it working! Thanks for that, pretty much exactly what I was after. I took the liberty of adding a link to the XPrivacy installation instructions, since even after getting most of the way through it was still non-obvious. Also non-obvious - how to “reboot to recovery”. I figured it out, but if there’s a wiki page for that, should link to it. And if not, there should be…


Glad it worked and thanks for the tip to link to the “recovery” dictionary entry. :slight_smile: