How to get back the native calendar app?

I did not use the native Fairphone calendar app, so I thought I might just as well remove it. Apparently not, because now my Exchange calendar won’t sync anymore. Does anyone know how I can get that native app back?

Do you mean this one? :slight_smile:

EDIT: If not, maybe this helps. Forum post from someone with a similar problem.

Ha ha, is it really that simple? I didn’t realize that it was Google Calendar that was installed. Thanks!

My problem isn’t entirely solved unfortunately, because now Google Calendar won’t sync my Exchange calendar either :-S

Hmm, I’ve found something similar on another forum. Perhaps this will help. I’ve also found this article, it might be worth a read. Good luck and please get back to me whether it did or did not work :slight_smile:

Thanks so much for helping me out! In the meanwhile, I’m OK again. I did a factory reset (!), which at first didn’t solve the problem, but after using Fairphone Updater to update both Stock Android and Fairphone OS, I got my calendar back (as well as a tiny app called Calendar Storage, which I apparently removed as well…).

So I’m all up and running again! The only thing I now get (which I didn’t get before) is an occasional warning saying “ has stopped”.

Thanks again!

I’m glad it worked out, however the warning you’re getting is the fact the process behind Google Apps has stopped working, which is not such a good sign. Could you tell me when exactly this error appears?

Well, I’m trying to figure that out (it seems rather random so far). I’ll keep you posted as soon as I understand the pattern. :smile:
I googled this issue, and at some forums it is adviced to disable and enable the Download Manager, but I can’t disable this app (the disable button is greyed out).

OK, I just got the “ has stopped” message again after I signed into Evernote (first sign in after installing the app). Installation and signing in went OK, the message appeared about 5 - 10 seconds after I was able to sign in (Evernote didn’t stop).

Did you sign in using a Google account?

Nope, I entered my Evernote username and password.

Hmm, I’ve read online that (besides disabling the Download-app, which is indeed not possible) you could also try and reset the applications preferences.

By going to Settings > Apps > (slide right) All > Left soft button (left to your home button) > Reset app preferences. As explained in this very sketchy youtube video :slight_smile:

Ah yes, I found that too and tried it this morning (before the post-Evernote message) - sorry, forgot to mention! Didn’t help, obviously :smile:

Hmm, very strange. I’ll look around some more and see if there are any more fixes available on the internet.
Perhaps another user on this forum will know a solution. @Chris_R, have you seen anything similar?

@karinslegers - this one may be a long shot - do you have you default storage set to SD card? You can find this in Settings > Storage. If so, try changing to internal storage.

I do have the default storage set to SD card, but I’d rather not change that to be honest.

Wow, that was a hunch!! An issue was reported with Bluetooth doing similar issues when SD card was used for storage. It’s reported as a bug already - it looks like it’s related to the change to the unified storage partition.

Can you verify for me that if you set the default storage to Internal Storage that the problem stops? You can set it back afterwards, it’s just to understand if this is the same issue. If so, I’ll update support to make them aware it’s happening to other apps too :smile:

Sure! It might take a while before I would get such a message again though (I got three or four today, but as I just did a factory reset, I’ve been fiddling with my phone a lot today). Keep you posted!

By the way, I’ve always set the default storage to SD, but I’ve never received those messages before today.

@karinslegers - Do you have a FP1 (from before July 14)? If so, had you previously upgraded to Fairphone OS v1.6 and also run the unified storage partition? If you have a FP1U (from July 14 onwards) were you on v1.5 or v1.6 before your reset?

Yes, it’s a FP1. And I had already upgraded to v1.6 before the reset. I only used the Storage Upgrader after the reset today.

Does that answer your question? :-S

1 Like