[HOW TO] Flash a custom ROM on FP3 with GSI


I can’t since I don’t use the stock ROM anymore…
@Matombo wanted to try to have a full update yesterday. Anyone else?

note : That’s why we should find out how the update_engine ask for an OTA URL

How do you get security updates on GSi?

System update are done by the GSI maintainer, we’ll do flashable zip for other partitions

I’ve asked to LineageOS team if the GSI will be an official image. They answered that it is discussed internally and we’ll have a public announcement when it’ll come to a decision :slight_smile:


Any success with the last ZIP I uploaded?

1 Like

(diff from A.0105… Fortunately, we do not need a full ota anymore :slight_smile: )

Fortunately, yes ! I messed up with the system partition, so I had to revert to stock rom. I did it with your last zip. Thanks again !

You installed it via TWRP, yes?

Yes. I have done it several times. Actually, when I flash the stock rom, after reboting, the bootloader sends me to a revert to factory menu and then the phone can boot to the stock system.

I suppose that this happens because I have a problem flashing GSI. In fact, after flashing the gsi image on the two slots, the phone can’t boot on the new system and it’s stuck in a boot loop. So I have to flash the phone back to the stock rom. I suppose that I made a mistake somewhere.

Edit : My bad, I flashed the wrong GSI images. I read the instructions too quickly : I flashed the treble_arm64_avN to the a slot and the treble_arm64_bvN to the b slot :smile: ! It may explain the corruption of the data partition.

You should apply the ZIP on both slots now.

What ROM did you try? Were you in version 0105? Were the 2 slots actives? Did you install magisk?

Just as additional information, in this case Magisk is needed, because installing Magisk disables verity.
It should also be possible disabling verity by doing this before flashing system:
fastboot --disable-verification flash vbmeta vbmeta.img

but I think @pigpig tried that and was unsuccessful so far?

1 Like

Exactly, I tried

  • vbmeta 1.0
  • stock vbmeta with --disable-verification
  • stock vbmeta with --disable-verity --disable-verification

And all of them didn’t work. I guess it is how the FP3 bootloader handle it. There is other phone who need to disable verity in the boot (e.g. Razer). It is also possible to not root the device if we do something to disable verity in the boot (special boot, or a flash zip), but we have to do it.

Well, that’s exactly what Magisk does… it patches the boot.img
Not sure why the vbmeta thing doesn’t work. Might have to take look on UART if @basxto lets me :wink:


It would be very nice!

I know, but it doesn’t only patch the verity :slight_smile: (to have a non-rooted custom rom)

I’m running ArrowOS official GSI
Working: SMS, NFC, bluetooth pairing, W-LAN, GSM, flash, both cameras, external keyboard via usb-c, finger print sensor
Not tested: Calling, GPS

Regarding the boot loop:
It is not able to boot automatically.
First boot fails and I have manually press Start when it tells me that my phone is corrupt and it will poweroff in 30 seconds. But then it works.

1 Like

Nice! Is it still maintained?
That’s because the boot is unlocked :wink:

If that was because of unlocked boot, that should also pop up when just installing Magisk or TWRP.

The image is from the 27th, but it appears they have no OTA updates.
The first message is normal, yes. It just starts the rom after 5 seconds.
Starting the rom appears to fail and it reboots.
The second one is not normal and shuts down the phone after the 30 seconds.

Finally, I finally could boot to the GSI ROM. The data partition was corrupted, but I could format it thanks to the stock recovery. Before this corruption problem, I wiped the data partition through the TWRP wipe menu. Did TWRP mess with the data partition ? I don’t know.

Anyway, I have now this message at boot that tells me that the device is corrupted and if I don’t press the start button the device will shut down… as @basxto

Edit : probably TWRP is not to blame. It was my mistake, as I reported here.

I can’t boot Havoc. I managed to boot Resurrection Remix, but it throws errors in logcat like it’s the end of the world.

I’m now trying Bliss.
Also note: Bliss and Arrow allow to enable the navbar via the quickmenu, but you have to edit the quickmenu first.

Working: SMS, NFC, bluetooth, W-LAN, GSM, flash, external keyboard via usb-c, calling, LED, both cameras (camera app crashes, but OpenCamera works)
Not tested: Finger print sensor, GPS