How to change the volume behavior?

Hi everyone !
About the volume system of the FP2. Two things.
First, the maximum volume is still very low. Most of time, when I’m in a non silent environment, it’s impossible to hear anything when videochat (skype, messenger, wechat …) Or just watching videos on internet…
Second, when i plug my phone to headphones, speakers or my car, the volume steps are not regular at all. Sometimes no difference between two steps, sometimes the volume almost double… It should be linear, no ?

So my question is : how can I fix the volume behavior myself ? I have rooted phone. Using LOS now, but those problems exist since the beginning in FPOS.

I’ve tried a few app which are supposed to boost the volume but they are using memory, battery, sometimes don’t work, and full of ads. Not convenient. I’m looking for a real solution.

Thanks for assistance.

1 Like

On your own risk you might try to change volume values within /etc/mixer_paths.xml
There are many internet pages describing that.
But wrong values might damage speaker or ear!


See at what level your sound is set.
Go to Settings,
Go to Sound & notification
At my phone sometimes out of the blue the Media volume is down to zero. I just have to turn up the volume untill it happens again.

1 Like

Alright I’ll check how to do. I never did this kind of things on Android.

I’m not sure i understand what you mean. I already putted all my volumes on max.

In case you might do any change within the file you should make sure to create a backup of it before!

1 Like

Just to be clear: which OS-Version is installed on your FP2?

When looking at my phone (Fairphone OS 18.01.01), I have no options for volume of notifications and progressive volume available. If you are on an elder version, please update your phone to the current version and try again.

1 Like

I’m in Android 7.1.2 with LineageOS 14.1.

Ah o.k. So I can only say that the problems with weak sound have been fixed in FPOS.

And just now I see that the thread has been moved to LOS …

So now, the problem occurs only with LOS. Did anyone know if it’s going to be fixed by lineage update ?

Here’s the bugtracker.

1 Like


I just posted my two sound problems in the bugtracker. I hope it’s going to be on their fixlist. :slight_smile:

Until then, I may try to fix it myself within /etc/mixer_paths.xml. Thanks Volker

I explored the /etc/mixer_paths.xml file. The default value for the speakers is 87. Changing it to 92 increases the volume, but the sound quality is terrible. Seems that the hardware cannot really be louder. Pitty.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.