How to be able to install and use any app on FP Open OS [meta discussion]


Some (more ;)) thoughts:

  1. “mocking” … is distributed across level 4 and 5. Level 5 actually seems to be more (rather: only?) about the DroidGuard/SafetyNet than about the mocking, which was already “started” in level 4.

… now i was about to suggest moving the µG instructions to level 4, but then again, all old references to “Level 5, Step 5” would be lost. meh :frowning:
(It would make a lot of sense though)

  1. it would be good to explain that for µG you do need signature spoofing (also only got this later, that this is because of the gms… name) and that there multiple ways to achieve this.

  2. in level 4 it should be made clear that one of the three options might already help to get the app working.

I can formulate some of this, if you ask me. But i’ll wait for you to finish, so we do not do things in parallel…

1 Like

Well mocking is just a word I used, it doesn’t describe a technical procedure.
You mock (or fake) the existence of Google Services in both Levels, but in Level 5 you go a step further and also mock/fake a SafetyNet check.

You are right, in hindsight it would have made more sense to put the µG instruction into Level 4 and only reference to it in Level 5 instead of the other way around. But I believe it’s better to leave it be now.

Great minds think alike. I did that in Level 4.

Good point, I’ll add that.

Another great point. I’ll tell you when I’m done, please check then what I missed.

PS: OK, done. I also changed some other things. E.g. Level 4 still explained how to use systemless XPosed, with the explanation that “you can use that in Level 5 too”, but that’s not true anymore since quite a while.

1 Like

great, i think this should be much more helpful for people playing around with these things for the first time. i just corrected 3/4 obvious things (typo, missing right parenthesis), which you can see highlighted with the compare fuction.

I suggest to change this:

If the above-mentioned Xposed Module doesn’t do the trick you’ll need microG.
Install the Xposed Module “Fake GAPPS” as you installed other Modules above and then do Step 5 in Level 5: Mocking an unmodified OS. (As an alternative to installing the Xposed module (which microG needs for “signature spoofing”) you can also use tingle as explained in Level 5, Step 1a).

To something like this:

If the “This App will run without Google Play Services”-module doesn’t do the trick, then you will need to mock the existence of the Play Services by installing microG, as explained in Level 5, Step 5.
In order to work, microG needs something called “signature spoofing” (read HERE (LINK???) why). There are two ways to achieve this: 1) Install the Xposed module “Fake GAPPS” as you installed other modules above. 2) Patch the framework.jar of your phone with Tingle, as explained in Level 5, step 1a.
(Whether you prefer 1) or 2) might depend on whether you already have Xposed installed and how comfortable you are talking to your phone via your PC terminal.)

yeah, well, not sure about the last hint, but i thought i’d leave it in for now, maybe somebody can come up with a better wording.

1 Like

I just have three concerns about this:

  1. If we explain why something is needed for every step in every level of the guide it will become very very long. Instead I’d rather add an entry to the forum dictionary and then simply link to it like this: microG needs this for signature spoofing.
  2. The signature spoofing bit should come before the reference to 5.5 to avoid people missing this step.
  3. Although you make it clear that the two ways to signature spoof are independent you should still use bullet points instead of numeration. If someone just reads:

They think they’ll have to do both.

Forum Dictionary??? – Wow, why did I not see this before? :wink:
Yes, links make sense, of course! (that’s what i meant by ‘read here why’)

Hello guys,

Since I’ve FP Open OS, I couldn’t use snapchat. I installed FakeGAPPS and microG like in the How to install any app tutorial and that worked partially. But when I tried to connect with my account I had the “failed login” error. It seems snapchat can detect if root is activated even with rootCloak. So I unrooted like in the tutorial I linked and uninstalled Xposed (I don’t know if it’s necessary). Without Xposed I couldn’t use FakeGAPPS so I used Tingle. Then I had not error message when I tried to connect and after the connection I re-rooted (flashing the SuperSu zip with TWRP) and Xposed :slight_smile:

I will improve this ‘tutorial’ with your sharing.

1 Like

Hi !
That is basically the same process I did for “Poke monGo” without the re-rooting at the end :slight_smile:

Did Snapchat’s error message actually say anything about root?

I believe there was something else going wrong. Did you do microg’s self check? Did it say that signature spoofing was active and working? (with the XPosed Module I mean)

If re-rooting and re-XPosing didn’t re-introduce the login error, then I’m pretty sure it hadn’t been caused by root or XPosed in the first place.

I have read something about that topic: Snapchat doesn’t care about root, but doesn’t like Xposed (because there are Xposed modules which modify the behaviour of the Snapchat app). So Snapchat refuses to log in when Xposed is installed. So Xposed has to be uninstalled to log in in Snapchat. After you have logged in, you can re-install Xposed, Snapchat won’t complain anymore (unless you have to log in again).

1 Like

Do you happen to know if you can trick Snapchat by using Systemless Xposed?

The message didn’t say anything about root but I did the microG’s self check and everything was checked. Furthermore I searched answers on the web and that’s what comes out the most.

Snapchat seems to do the control during the login process, once you’re connected the tricky part is beyond.

It’s possible too, maybe it’s just xposed or just root or both. I don’t know but if someone does the test, I will improve my post :slight_smile:


I have FPOOS since a few months and until now I had problems to make some apps run, some displaying a message on launch saying they need Google Play Services, but then when you clicked Ok the message would disappear and the app would run perfectly. But some did not run at all (like Google Maps for example).

Now, I’ve started from scratch. I’ve successfully installed FPOOS 16.12.0, and installed XPosed Module “This App will run without Google Play Services” like explained in step 4 of this tutorial (✏ How to install any app on FP Open OS (for beginners and experts)).

And to some extent, it works. The apps no longer display the pop-up message saying they need Google Services. And apps like Google Maps run smoothly.

The only thing is that a lot of apps generate a notification now, saying “app won’t run unless you update Google Play services”.

Given the configuration explained in the tutorial, is there a way now to “update” the faked Google Play services, or do I have to live with these annoying notifications?

Thanks a lot in advance for your advice.


Which Apps are these and do they work other than generating that message?

The XPosed module you installed was last updated in 2015 and worked for every GMS update. So I wouldn’t wait for an update of that module.

Instead I’d try the very next step in the guide. “Mocking G%§$e with microG” will not only suppress those messages but also provide free alternatives to some of the G%§$e Services, so even more apps will run smoothly.

The apps that do it are for example The Guardian, Le Monde, Xperia Clock, … and yes, they do work, there’s just this notification now and then that’s quite annoying.

You’re suggesting step 5 in the guide. Do I really have to start from scratch and wipe the phone if I’ve done step 4?

Can the phone be rooted again afterwards?

No, you don’t have to do the full Level 5. The last point in Level 4 is to install another XPosed Module and then do only Step 5 in Level 5.

Alright, I’ve done level 5, and it seems to be fixed now.
I’ll be back if it’s not. :wink:

Thanks a lot for the very quick help, much appreciated!



Hi guys,

I’m very happy with my rooted fairphone. However, to access my company e-mails I need to install microsoft intune, which won’t run on a rooted phone. I tried running Root Cloak, which didn’t do the trick.

Although I was just getting into Xposed and all possibilities with a rooted phone, I am afraid I have to get back to being unrooted for the time being.

I googled and looked on the forum, but I didn’t figure out how to “unroot” my rooted device. I would like keep the FP open system. Any help for a newbie?

I don’t think FP Open can be un-rooted?! Since root is built-in, you can only hide root, not remove it.

Thanks retsipf for your reply.
I found this threat on “installing any app”. Reckon I have to use step 5. Step 0 is straight forward, but can someone tell me if I need both 1a and 1b?

Step 1a: Patch the framework.jar with Tingle to be able to spoof signatures.
Step 1b: Uninstall root.