How to backup files when FP1(U) doesn't start any more?

Good morning. Thank you very much for your answer!
I meant in my file browser, but now I tried it with ADB. Unfortunately it doesn’t work.
That’s why I attached a copy of what I can still see on the phone depending on when I connect it or start it and of the results of ADB. Perhaps this may help you to find another solution.

Ok, this is might make it difficult.

Have you tried to use ADB in the recovery mode? Can you access the recovery mode?

I also see you are using Windows. I have read that quite some Windows users had issues with also installing the right drivers, and that there were different issues regarding different Windows versions. So let me first ask you, have you successfully used ADB with your computer before, to connect to your phone?

If not, maybe you are just missing some drivers. I do not use Windows myself, so I cannot help you on these kind of driver issues, but maybe you find some answers here (I know it says for FP2, but the necessary ADB drivers should be the same for any phone). (Maybe one of the Windows users in the forum can jump in here and clarify if this could be a issue, why the connection may not work).

What I mean is, maybe ADB doesn’t work because a driver is missing.

Btw: When “adb devices” does not find your phone, you can save the time of trying different commands, it won’t work either.

1 Like

thank you once more for your answer! This time I needed much more time because I’m not very a technical expert… I let a colleague have a look on my phone and also I gave him all your information. But he didn’t find a solution either.
I didn’t have used ADB on computer before and infortunately I didn’t have activated either “adb debugging” on my phone when it was still working. I suppose that could be the reason why it isn’t working now on my computer.
I installed only “Minimal ADB and Fastboot”, when I tried to install ADB via the informations on it shows me “[Error] Device not found” when I try the button “Install”.
Today I bought an SDXC Micro-SD card for use “backup user data” in the recovery mode of the phone, but it shows me once again another error: “Error: No SD-Card”.
Now I suppose that I don’t have further possibilities any more to avoid the reset the phone without have backuped my files :frowning:
Thank you nevertheless for your help!!!

Did you install the adb driver first? Else you can’t use the minimal adb and fastboot tools…

If there’s an unofficial TWRP or CWM recovery for the FP1U, and if the FP1U has an unlocked bootloader (or easily unlockable) for flashing the recovery with fastboot, you can follow this FP2 tutorial I made:

Be careful, some parts are FP2 exclusive (how to get the recovery, button combos), but almost all would be the same.

I’ve never tinkered with a FP1/U, so let’s see if someone with more knowledge of the FP1U can give their approval to the method.

1 Like

There is CWM by @chrmhoffmann:

The bootloader is unlocked and can be accessed following the instructions here. (Instead of Recovery Mode select Fastboot Mode.) Then you can follow these instructions starting from point 6 to flash the recovery.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

For me, it is quite possible to use adb for backup on a screen broken FP1.

If you had usb debugging activated in the developer settings, it is.
Otherwise I’m not sure if your device will authorize your computer to access the phone via adb.

I would like to recover files on my stock FP1 (not FP1U), but it doesn’t get past the Fairphone startup screen when booting, and I hadn’t turned USB debugging on before.
I can access recovery mode. ADB on my computer (Linux Lubuntu 16.04 32 bit) detects the device with only sideload permissions. Is it possible for me to flash the recovery?

These two links no longer provide instructions on how to access Fastboot mode or how to flash the recovery. I haven’t been able to find any instructions on how to do this over adb sideload, and would much appreciate it if anyone can help!

Alternatively, would it be possible to reinstall the OS using “Update from ADB” (in order to fix what I believe is a software issue) without deleting the files, so that I could then take a backup as usual?

You are looking for this post:

Thank you for these links. I see that step 2 of the installation instructions is to execute “adb shell”. When I try to do that on my device I get “error: closed”, presumably because USB debugging is not enabled. Does this mean that I can’t install CWM recovery?

Is it possible to reinstall the OS over “update from ADB” without losing my files, or is my only option a hard reset?

Sideloading should only update the operating system, but leave user data intact.


Thanks for the clear and concise reply. Last question before I go back to experimenting on my own: how do I know which version of the OS to reinstall?

Do I take the first one, the last one, or just try different ones until I find one that works?

Ideally you would use the one that was installed before the phone got soft-bricked. If you don’t know, which that was, you should use the latest version.

Attention: You must use the one that fits your storage layout.

I don’t remember modifying the storage layout (although I guess I have no way to verify this now), so I’ll try with the most recent version for the original layout. Thank you for your help!

1 Like

Let me know if you have succeeded or have further questions. :slight_smile:

Just to give an update on what happened:
I reinstalled/updated the OS to the 1.8.7 version (for the original storage layout), but I had the same problem. I then tried with the 1.8.5, 1.6, 1.3, 1.1 and 1.0 versions, all with the same result. @Stefan suggested that parts of my data partition might be corrupted. I was originally going to test with the OS versions for the new storage layout for the sake of completeness, but applied the 1.8.7 layout upgrade first. (I forgot that this would wipe all the data anyway, so we’ll never know if the other updates would have fixed it without data loss or not.) This sadly meant a full data wipe, as expected, but at least the phone now boots properly and in general seems to work just fine.

1 Like