How do I switch the GPS on/off with Fairphone 2 Open OS


I’m using the Fairphone2 Open OS.
At first, I thought the GPS did not work at all; and maybe it did not… So, I changed INTERMEDIATE_POS=0 to INTERMEDIATE_POS=1 in /system/etc/gps.conf as suggested in GPS doesn´t work on FP Open OS (and I switched to European NTP servers while at it). Anyway, now the GPS seems to be working for me. Good.

But, while the “GPS pushpin” indicator is visible in the top bar while I’m using OsmAnd, it is otherwise absent. So I have no way to tell if GPS is on or off, which is a big deal on a battery-powered device!

— How do I tell if the GPS is on or off?
— And how do I turn it on or off?

Note that I have the “Power Toggles” installed. Unfortunately, it just won’t light its GPS indicator on: there’s a rapid switch to on, then it’s back to off, always, regardless of the actual status of geolocation if OsmAnd can be relied upon regarding the ability to geo-locate or not. Thus the Power Toggles cannot act as an indicator nor can they reliably be used for switching the feature on or off…

I believe you are experiencing the following known issue. It is probably the same in FP OS and FP Open OS. There is a workaround described in the topic:

@paulakreuzer, thank you for the link. It helped me it the most unexpected way :smiley:
I’m still not very familiar with Lollipop, and I simply missed the place where on and off took place for the GPS; now I’ve found this place in the settings, and I’ve found the indicator (it’s not always visible as it used to be, though).

So this topic can be considered solved. There’s still a bug in Power Toggles, but that’s outside the scope of FP’s forums…