English

How do I reset FP Open OS?

Hi,
something is wrong with my FP Open OS 16.10. I would like to do a complete reset of my phone to FP Open OS 16.11.
I downloaded the fp2-sibon-16.11.0-manual-userdebug.zip and tried fastboot -1 update. But nothing happend “no android-info.txt”.
How do I flash my phone? Can I do it with a .zip on my sd-card?
When it restarts, can I then go into TWRP to update my Xposed?

Go to TWRP:

  • do a reset including the system partition
  • reboot to recovery (you can’t reboot to system as it was erased)
  • TWRP will ask for permission to modify the system partition, allow it.
  • tap “install” and find the zip on your SD card
  • you can install the XPosed zip in the same step
  • reboot to system and hopefully all will be well
2 Likes

After everythin supposedly worked, I install Calendar Widget und then start Titanium Backup and get the backup to restore Calendar Widget as it was before?

and the manual-userdebug is the correct file?

and with reset, do you mean wipe or restore?

Yes, yes and wipe. :slight_smile:

1 Like

sorry to bother you again, Advanced wipe (and everything), format data or just wipe?

So, i wiped everything in advance mode (except the SD-card). Now verification fail on the .zip. do I need another zip-file?

Uncheck zip file verification before installing a file :slight_smile:

doesn’t work either. Is it because I have MTP enabled`?

Thought you’re trying to install from recovery?
In any case. If you actually wiped everything (incl. your /data partition) you could as well simply flash the whole system via fastboot (method 2 from here).

Ok. I don’t seem to understand the difference between wipe&new and recovery. I thought recovery would restore FP (normal/gms) OS. I wanted to reinstall the latest FP Open OS.
I tried fastboot with the manual-userdebug.zip. But that didnt’t work. I don’t understand the mentioned “Method 2” either. (tried unzipping, tried flashing… nothing worked)

I started a cmd.exe (Windows) in the minimal & adb fastboot tool. With adb devices I didn’t find my phone. Fastboot devices worked. When I fastboot there (with the manual userdebug or gms) it says “no android-info.txt”.

That’s why we have a dictionary. In short: Recovery is a set of tools you can access on your phone even if the system is messed up - on FP Open that recovery is TWRP. A Wipe is an action where you delete files or even reformat a partition (like data, system, cache and recovery [don’t wipe recovery!]).

What error message do you get now?

2 Likes
Updating partition details...
... done
Full SELinux support is present.
MTP Enabled
Installing fp2-sibon...manual-userdebug.zip
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
Error flashing zip "fp2....zip"
Updating partition details...
... done

FAILED

That’s all. TWRP log was saved on SD-card, but I can’t find it.

So did you actually wipe all partitions? This means, including /data? Then you have deleted your data partition and the easiest way to restore your OS is to flash the whole system.

How did you try to use fastboot?
When following the method 2, you need to bring your device into fastboot mode. This means, when powering on the phone, press vol. down + power at the same time.
When you find your device with “fastboot devices”, you’re there.
You can then follow the method 2 from the link above, meaning extacting the “manual-userdebug” file, go into the directory where you have extracted them to, and execute the flash.sh (on linux) or flash.bat on Windows (actually I never used it on a Windows machine, but you can find more details in method 4 here, which is the same procedure for the FP OS; just the file is obviously a different one).

If you did not wipe (i.e. delete) your /data partition (thus all your data/settings/apps), then it should be sufficient to only apply the ota update file Fairphone provides, or you can manually flash the /system.img which you extracted from the “manual-userdebug” file above. If you look for the right command on how to flash the system.img, open your flash.sh or flash.bat file and find the command inside :slight_smile:

Actually, @paulakreuzer, are you sure it is possible to use TWRP to install the “manual-userdebug”?
I thought from TWRP you can only install the “ota-userdebug” file, but that with the “manual-userdebug”, which @Friek has downloaded and tries to use, you need to go via fastboot?
I actually never tried to install an OS from recovery, so I may be wrong here.

1 Like

Hi,
I deleted everything. As I wanted a complete new start.
Yes I was in fastboot mode.
So, (Teilerfolg) I unzipped the manual-userdebug… and started flash.bat… but I didn’t work. I then moved all the files into the same folder as the fastboot.exe. Then it worked. I will change this wiki to make it simpler.
Then installed Xposed and my emojiis (@Roboe: thanks)
Now to the setup.
Thanks for your support.

2 Likes

I just had a look at it. @rootboi’s wiki is not working anymore. Since there was a modem update (I think with 16.09) the contents of the zip file changed and you need to start now the flash.sh rather than using fastboot command for the filename, since now the update files also include the modem files. I suggest to rather look at the instructions on the code.fairphone.com on how to install, as it is up to date).

If someone has time this should be changed in the wiki as well!

For clarity’s sake, the flash.sh script is just a list of fastboot commands (five additional targets for all the firmwares), so you will still need fastboot to be installed. If fastboot isn’t installed in location that is added to $PATH, the script will likely fail, unless fastboot is in the same folder.
(I’m guessing @Friek won’t have it in path, as they’re working from the install folder and copying all the files there).

As this is mainly relevant for windows (Linux users will typically get it via their package manager, which should adjust path automatically), here’s a hint for adding fastboot to $PATH in windows:

If fastboot is included on the path, installing Open should be as simple as unpacking the manual update file and running flash.bat. (provided the phone is properly connected and in fastboot mode, of course).

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.