Home button not always working

Hi you all,
I’m quite happy with my fairphone, but sometimes the home button simply does not work.
I’m on fp os cherry 1.6 and often when I touch the home button nothing happens, so can’t use properly the multitasking neither go back to my home screen.
This thing is particularly frustrating while browsing the internet or using big apps like spotify and want to check someting on another app.

Anyone with the same issue? I tried out lot of differnts launchers but nothing seems to change.


The menu and back buttons work well?

@Stefan yes they work both great! They never miss a tap…

Hmmm. That’s weird. I thought it might be related to what @humorkritik experienced, he couldn’t use any of his buttons anymore…

@humorkritik did it start with only one button not working?

@a_bet I think the best case in your situation would be if it was a software problem and somehow the OS got messed up. Then a hard reset should do it. If this doesn’t resolve your issue, you should contact support directly. Let us know anyways. :smiley:

Thank u very much @Stefan, I hope so… The fun fact is that sometimes it works and sometimes no, so I would say it’s probably a software problem: very often I just need to lock and unlock my phone or wait for a short while.
Anyway, I’m not gonna hard reset my phone right now, I think I’ll try some app to access the multitasking in a different way.

1 Like

Exactly the same thing happens to me as well. It is also just happening from time to time. Also sometimes it helps to lock and unlock the phone or to wait for some time, but sometimes I need to reboot.

Just realized that sometimes the home screen function works (eventhough responding slower than usual), but not the multitasking function…

1 Like

I observed the same. In my opinion the threshold between click and “long press” is somehow marginal, and a slight finger movement changes long press to a useless click, explaining the intermittent character of the effect (if I am right).

In the Settings menu (German: Einstellungen) there is the submenu Accessibility (Bedienungshilfen) with the entry “Touch&hold delay” (Reaktionszeit …). It was set Short, I changed to “Medium”.

Now it looks better! - the Home button works always for me!
But, not yet certain about it, maybe some button clicks have to be done more carefuly (generally said) to get done, feeling not confirmed by now.

Feeback welcome …

– Franz

1 Like

I have the same problem: sometimes the middle button works fine (it always goes to the home screne), but sometimes it doesn’t show the multitasking function.

Now, I also set the touch&Delay to Medium, let’s see, if it works better.

Thanks @Franz for the tip!
I tried it out and I must say it’s going a little bit better. Unfortunately the multitasking non always work, neither the home button, but it seems the response improved a little.

Same problem here. I set the touch&Delay to Medium but it seems not working.

meanwhile I am afraid my tip is misleading. I get a “working press” often, but stil fails too. so the parameter change did not really fix it.

It works enough for me, because I get used to it and stil trying to improve finger tracks for my regular tasks …


Has anybody found a solution for it by now? Still happens for me from time to time and I find it quite annoying…

Have you tried a hard reset to rule out a software failure? If you don’t want to hard reset and if you don’t mind using alternative ways of accessing the navigation bar’s functions, or if the hard reset shows that you suffer a hardware failure rather than a software failure, you could install the Xposed Framework and GravityBox and then do one of the following:

  1. Go to GravityBox > Navigation Bar, tick the main control (perform a reboot) and check activate navigation bar.
  2. Go to GravityBox > adjust PIE-control > activate PIE-control and select Always.