Help with OS reinstall

Hi everyone!
I got my FP2 last october, and it’s been crap. I sent it for repair, they did nothing and it’s still crap. I don’t use it any more and I couldn’t get a refund. I tried playing pokemon go on it and it wasn’t working very well. I thought I should try to install the open os and se if that helped, but pokemon go wouldn’t allow me to log in. So I thought I should install the original OS again. The installation completes, but the phone gets stuck on starting screen. It’s the logo and the moving dots, but nothing else happens. I tried reinstallning, samething. Any suggestions? Or did I brick it?


Do you still get recovery mode if you press Power + Volume Up?
Bear in mind that can use quite a bit of battery installing software.

I have the charger plugged in :slight_smile: I tried recovery mode and I got the green android figure laying down with an error triangle coming out of his stomach…

How long did you wait? Last time I installed the original OS it took ages for the first boot. Stayed on the exact same screen for a couple of minutes if I remember correctly.

It’s been on the same screen for about 30 minutes now. The animation with the blue dots is still working.

Ok, in that case I think we can assume you waited long enough.

What I usually do is take out the battery and let the device cool off a while before trying anything else.

I let it rest for about an hour, and now tried starting it again. It’s been five minutes but nothing happens except for the first screen :frowning:

Just to make sure: you reinstalled the OS using this description?

1 Like

Yes I did. I tried reinstallning two times but no differance. I tried to install open os now again to see if it even boots.

It starts fine with open os. Too bad pokemon go doesn’t work :frowning: but I guess that means the phone isn’t broken. Is there any other way to install original os?

You could boot into the TWRP recovery, then wipe the phone completely and try installing again …

In TWRP do Wipe - Advanced Wipe - check “Dalvik / ART Cache”, “System”, “Cache”, “Data” and “Internal Storage”, do not check “Micro SDCard” (if available) - Swipe to Wipe

When the wipe is done, turn off the phone before starting up and installing again.


I tried it, I’ve been at start screen limbo for about six minutes.

What’s the filename of the OS file you try to install?

FP2-gms-18.04.1-manual and I have windows so I used flash-for-windows.bat

Hmmm … I don’t get how installing Fairphone Open OS works and installing Fairphone OS doesn’t work even after a complete wipe.

If you want to try, there’s still the TWRP way of installing Fairphone OS …

1 Like

It worked now! I gave it about 10 minutes and it started up. Thank you for your great help!


Hooray for patience … good to know it might take so long.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.