GPS not working with Fairphone Open OS

Hey All,

I know there are tons of threads about this topic and yet none helped me fixing my GPS.
I bought the FP2 in January, instantly installed FOOS and never got a working GPS signal.
With the help of this forum I connected the FP once to some satellites, the accuracy was a few Kilometers off though. When I went a train ride the GPS got stuck somewhere in the middle of Germany. All apps located myself at this place for the next weeks. Meanwhile service is not available anymore, just like in the beginning.

I have used FasterGPS to change the gps.config, since I couldn’t get write-access (due to some other issues I might have with SD & internal storage mixup).
Unfortunately I can’t tell explicitly all steps I’ve tried for a fix, since I did so many different setting changes, apps, and whatnots. Basically everything I’ve read in the Forum.

Is there a way to find out if my issue is caused by male-functioning hardware without installing another OS? Is there a debug-guide I could run through, to provide more specific information for the FP support or expert-users?

I totally can live without GPS (a nice take-away from the past 5 months), but still it would be nice to have.

Thanks to all and sorry for opening the x-hundreds thread about GPS…

1 Like

Make sure you try everything (that is relevant to the FP2) from the gpsguide.
If none of it helps then it’s likely a hardware issue and you should contact Fairphone to get it repaired or replaced.

aight will do so. Thanks a lot @paulakreuzer

Generally for me the headline does not sound convincing. FP2 is shipped with FPOS only!
But since you instantly reflashed the phone with FPOOS you have performed the first step taking a great influence in system operation.

So now you most probably cannot proof for sure if GPS did not work initially right after “unboxing” with the original OS.

At least that´s what I read from your post.

If something went wrong with the reflashing this usually would not be covered by warranty “usually”, but this is FP…any other manufacturer would not even listen any further to your matters now or maybe offer a repair on your costs.

FPOOS does work fine and reliable for most users. Flashing can go flawless if someone knows what he´s doing. I have learned doing something crucial like this is always at anyone’s “own risk”. Now it´s unsure whether your problem is hardware or software related.
FPOOS also should offer a factory-reset option you could use since you don´t want to switch back to standard FPOS. But returning it to FP is another option.

Is that relevant?
FPOOS is officially supported by FP, so even if the process of switching somehow broke GPS that doesn’t void the warranty or change FP support’s responsibility to help in any way.

Not if it’s officially supported.


If the problem is with the software, I would not expect a case for warranty anyway. Resetting the phone should be sufficient (the loss of data will never be covered, except by specific insurances).
If it’s a hardware failure, there might be trouble only, if this failure could be sourced in switching the OS, which I really doubt is possible. And if it’s a defective hardware, every manufacturer would have to treat it as warranty. Of course this does not mean, they would. :frowning:

To decide, if it’s really caused by FPOOS, which seems unlikely, the phone could be changed back to FPOS.

And as @paulakreuzer just posted, in this case FP is officially supporting FPOOS.

If on Fairphone Open OS why not install SatStat found in F-Droid and check results?


Oh yes, I think so.
With this headline and introduction it puts an alleged negative focus on FP of having shipped a faulty / not fully tested device to the customer.
For example a different headline like “GPS not working with Fairphone Open OS” would have no such negative focus on FP.
If it had been working with the stock OS it would at least rather look like the step of reflashing done something. Hence a software issue would be more likely than a hardware fault.
Now no one can tell for sure what´s the cause leaving the impression to potential customers that there is a risk when purchasing a new FP2 of maybe receiving one not been properly tested.
It´s not the warranty in my mind here, but the bad taste that remains.

I’ll just point out the most relevant point for FP Open in the gpsguide @paulakreuzer already mentioned:

As explained in the guide, network location improves the Time to first GPS fix (TTFF), which is probably your issue here.

On Android with Google Mobile Services (i.e. GApps or GMS), Google provides a service to get network location, but as FP Open doesn’t ship GMS because they aren’t open source (nor free, BTW), you need to set it up. Luckily, FP Open comes with support for UnifiedNlp —an open-source way to choose which service to use for network location—, so I suggest downloading it and using MozillaNlpBackend for Mozilla’s crowd-sourced network location service.

1 Like

Hey Everyone,

thanks a lot for your quick replies! FP is not only great because oft the supportive community…

First I’d like to apologize for my bad wording. I totally see your point @Patrick1 and will change the topic right away. If I knew that GPS won’t work I would have tried it before flashing…
I’m not sure if it come across wrongly but I’m not at all angry or similar because of the issue and neither I want to put any negative focus on FP! I am aware that using an open OS can lead to issues and so far I accepted all inconvenience caused by it. In fact I’m more than happy to have a supported OS which allows me to go google-free. I am actually positively surprised how much open source apps and apks from devs directly I have found and how little I had to suffer for a phone without google services.

@paulakreuzer I’ve seen your guide a few moths ago and went through it, but I will do it again, just to be sure that I didn’t muss anything; maybe that time I’ll have better luck.
Also I will check out UnifiedNlp as @Roboe has suggested. Thanks to both of you for your hints.

I will let you know if anything improved my GPS. … and if it won’t I will still be a happy FPOOS user…


Also now that I think of it… the possibility that it is a hardware issue is not too strong I guess. I did get a signal once, even though it was not precise at all…
what do you think?
I’ll stay on it!

I though for quite some months my Nexus 4’s GPS was ruined (running CyanogenMod without GApps and with freecyngn) until @larma launched UnifiedNlp back in 2014.

The story has repeated itself now that I fixed my old N4, flashed it with LineageOS without GApps and waited for thirty minutes to get a fix in a centric place of Madrid (spoiler: 10 satellites and I didn’t got it! :man_facepalming:). UnifiedNlp (well, microG) and a manual A-GPS update just solved it.

1 Like

As for my personal experience, GPS on FPOpen is very frustrating but it works.
The first time I try to connect to GPS in a new area it takes ages to find my position (more than 10-15 minutes), the next times connection becomes faster and faster, until becoming almost instantaneous in places where I use it often. I guess there is some kind of memory cache.
Also, anywhere I am, GPS connection sometimes is lost and takes a few minutes to be found again.

I find SatStat to be a useful app because it helps monitoring what the GPS sensor is doing and the number of satellites it is connected to.
Moreover, I feel that keeping SatStat open helps to find the position when GPS is trying to connect.

The principle of GPS is a “visual” connection between the device and any GPS satellite. Inhouse the connection often is lost, outside in the green or a bit away from high buildings should keep the connection stable.


Of course, and disconnections do happen more likely when satellites are
hardly visible, yet (anywhere I am) I notice more random disconnection than reasonable

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.