GPS fix takes very long after update (with e.g. and GPSTest)

In that case you might break the record of the longest uptime :wink:

What is the record? Is there a thread for competing? I’m at 520 hours :sweat_smile:

1 Like

I’m also “struggling” replicating the long fix issue. It definitely happened to me once after getting out of subway - the phone was looking for a fix for 5 minutes or so. But since then, I can’t replicate, not even with a freshly restarted phone. The fix is almost instant. But no system update came since I had the issue.


This is really strange. Had the same behavior after the january update - took about 10 minutes to get a fix. GPS status incdicated a GPS week number rollover problem.

Two weeks later it suddendly worked - fast fix.

Yesterday I installed the february update, and … no fix.

Looks like AGPS data is totally ignored, starts with only showing one to three GPS satellites, after some minutes GLONASS and GALILEO and the rest show up…

Rebooted the phone several times, but this does not fix the issue. :frowning:

1 Like

I’ve installed the Feb update yesterday, rebooted twice, and now I just went to a window and got a fix in a few seconds. The support has told me to install GNSS Viewer app and take screenshots when the issue appears. If anyone tests for this, please, take the screenshots.

  1. Download and install GNSS Viewer from the Play Store.
  2. Place your phone next to a window, on a balcony, or in any place where you have a clear view of the sky, with no obstacles.
  3. Make sure “Location” is enabled on your Fairphone 4.
  4. Start the GNSS Viewer app and take screenshot(s) of what you see on the screen.
  5. Wait 10 min. and take screenshot(s) again of what you see on the screen.
  6. Send us all the screenshot(s).

Tinkering around I found a procedure to get my AGPS running again.

  1. Turned off network, WLAN, GPS.
  2. Used GPS Test to clear assist data.
  3. Rebooted the device.

Now I’m getting a fix in about 1 second.


The above procedure did not work for me but shutting down and powering on after clearing assist data with GPS test.
Rebooting was not enough. Only powering off, then on.


I haven’t experienced this problem at all. Google Maps works fine, but also the FP Camera takes pictures with the right location.

I have yet to test it with the latest update. But with the previous one it would occasionally (at completely random time and location) take ages to get a fix.

Hi Razem, did you have some time to check if this is still an issue with the latest update?

I normally have mobile and wifi data switched off and have noticed at least once that it took a long time for the GPS to get fix. Once a data connection was established and the A-GPS data downloaded, the fix was obtained a few seconds later.
Maybe the A-GPS data is accurate enough to get a fix quickly for a few days?
Still have to check a few more times.
The OS version is february 5, 2022.

The latest update might’ve fixed this issue, could you please update and test again?

I am still waiting to be informed that the latest update is ready.
When that happens, I shall do the tests again.


Well, it’s complicated. :smiley: I usually use for navigation. And for some reason, the app frequently has a problem with getting the GPS location on my FP4 in the navigation mode. The current position shown on the map is correct, but the moment I start navigation, it does not appear to be able to obtain GPS data. Note that it works fine with any other phone at the same location. Also when I try other apps such as Google Maps or Waze, it works fine. Even GPSTest usually shows a pretty quick fix. I tried to clear the assist data and tried the same app ( a few days later and it suddenly worked fine. So maybe the problem was inaccurate/outdated assist data? I don’t know. Or maybe the app’s just broken. But I didn’t really have this problem with any other phone and it’s pretty weird.

And this did work fine before the January update? I’ll update the title a bit so it’s more clear this doesn’t affect Google Maps, geotagging pictures, Assistant, etc. I’ll also mark in the wiki article that a workaround exists, i.e. using Google Maps. And I’ll change the impact to a green circle, since it works fine with Google Maps, which most people will be using for navigation. So for most people it works fine, so my interpretation is then that the impact is low.

I don’t know, I didn’t travel that much during December and January. And it’s still a bit random, but it currently affects only this app. I think the difference might me that both Google Maps and Waze use Google Location Services (which apparently work fine), but this app seems to be using the plain Android location API (because I can also find it in the Huawei AppGallery). But this doesn’t really explain why GPSTest manages to get the correct location while cannot. :smiley:

1 Like

I have now installed the latest update some days ago and done a few tests.
It appears that the gps has not improved.
Even after having cleared data using GPSTest and rebooted, waiting a day, it still takes minutes to acquire a first fix.
As I have experienced the time to get a fix might differ from day to day, I compared the time to fix with GPS sports watch next to the fp4.
The watch acquired a fix in less than two minutes while the fp4 needed several more minutes.
GPSTest appears to acquire a fix faster than OsmAnd which I use to log tracks.

I don’t have this with Google Maps or when I shoot pictures and geo tags are added. Could it be that GPS always takes a minute to form a constellation to get a location fix? Android improves this by using known Bluetooth and WiFi signals for location as well. I know that the TomTom in my parents car also takes about a minute to get a fix on location. Depending on the line of sight, if there are no large buildings or even trees nearby it is faster.

Just trying to pinpoint if this is actually a bug, or just using the location services differently, and thus it’s slower to get a location. Because then it’s not a bug, those other apps should use the location APIs in Android to acquire a location faster.

Edit: Just did a test with my Pixel 3 and GPSTest, it takes more than a minute to get a location fix. So I think we can then confirm that it’s most likely an app specific issue, since location works fine otherwise on my Pixel 3 and Fairphone 4. I’ll mark it as solved in the wiki because it seems to work as it is designed to.


Android should download GPS Ephemeris data and Almanac via network. If the download was successful the sensor can immediately start triangulation giving a TTFF in seconds (hot start).

What I’ve been experiencing was in the range of a “cold start”. See Time to first fix - Wikipedia

Google Maps and using WiFi and Bluetooth signals for location services aren’t acceptable workarounds for me because of privacy concerns. And it wouldn’t help me hiking, out in the woods.


Has the new OTA improved / resolved that issue for you or others? :thinking:

1 Like