GPS doesn´t work on FP Open OS

:point_up_2:here! I installed microG instead of GAPPS. I got unifiedNlp working, but on ‘device only’ in the settings, there is no way I get my location

Have you been outside with your phone for 5 minutes under free sky with “device only” in the settings?

I do have openGAPPS installed, but I only use GPS for location (never used network before), and can confirm that GPS works on 16.06; at least with Oruxmaps (as it did on 16.04 as well; never tested on 16.05).

As I lost the changes I made to the gps.conf by updating the Fairphone to 16.06, I now made a copy of the gps.conf on my sd-card. So that I can copy the file, instead of making all the changes again.

What changes except intermediate pos did you make? You can easily change that with FasterGPS btw.

1 Like

These changes I also made.

1 Like

I had the problem with UnifiedNLP. It seemed to sometimes get stuck provide bogus/no values in “high accuracy” mode and did not let gps values through. When I uninstalled UnifiedNLP the problems disappeared. Sometimes it helped when i switched location mode from “high accuracy” to “device only”. I can attest to the fact that no gos.conf fiddling is required to get gps working on FPIS 16.05/16.06.

Gps not working as well here (fposos 16.06). Satellites can be found but it takes way too long (more than 5 minutes at least) and as soon as I turn off the display or just switch from osmand to another app the signal is lost again (gps symbol on the top bar disappears as well). Very annoying.

PS: Just to add a few details:
I have no NLP stuff installed, OS is not self-compiled, opengapps pico is installed but play store and google service are disabled. It seems to make no difference if I use gps on “high accuracy” or “device only”.

Same problem persists on my phone… it seems that there is no coherence how the problem appears… sometimes it takes 3min sometimes 15min to get a fix… I really doubt that there is any correlation to installed apps/software including unified nlp or Xposed. Probably to some missing. Somtimes I suspect the binblobs because of this intransparent behaviour of a gps-module which works and doesn’t work at the same time. Can’t say if its broken like for replacement or not…

I’m on Fairphone open 16.06. Installed µG unifiedNlp (NoGAPPS) from Fdroid.
GPS works on ‘device only’ and Osmand~ (takes about a minute to get my exact position).
Whait i did was change gps.conf “intermediate_pos=0 to 1” and the workaround described by ‘Unified NLP on Fairphone 2’

Have two backends installed ‘LocaGsmNlpBackend’ and ‘LocalWifiNlpBackend’.
First backend works but LocalWifiNlpBackend doesn’t seem to store any Acces points.

Same here. FPOS easily takes 10 minutes to find any location while satstat shows a 10/16 fix all the time. When I shut off the displaY it starts from scratch and takes another 5-10 minutes. Very frustrating, that is.
No gapps i stalled. No unified NLP installed, just gps enabled.

Have you downloaded a database? local = offline = needs a database

1 Like

Hello, It works now but the GPS needs to find your location first (can take a while) ,the moment the GPS has your
location then it starts recording the AP’s in your area so LocalWifiNlpBackend doesn’t need a database, it creates it’s own.
I think i was a little to impatient before.

For LocaGsmNlpBackend I made the phone build it’s own local database with Mozille Location Services enabled ( took about 2 hours to create it and you need a steady internet connection). Didn’t use Opencellid because it always gives an
error while building the database.

1 Like

I am using FP Open OS 16.06 and updated OpenGAPPS pico (version from 20160611) to pico (version 20160709) and now the error Message

disappeared! And everything seems to work fine. :slight_smile:
Please Note: GPS-Only was always working for my device!

3 posts were split to a new topic: Unfortunately, Google Play Store has stopped

I tried the steps and Tipps here , but if i open osmand it JUMP through hole City and after time crashes and must reboot. Could that be solved in the next update for open OS?

Have you tried reinstalling OsmAnd and/or clearing it’s cache?

Now i tried to clear cache, now somand works. Must try if its works with and Pokémon go :stuck_out_tongue_winking_eye:

1 Like

:flag_de: I have received the following answer from support in German:

Hallo ,danke
für Deine NAchricht. Bzgl. des Fehlers, dass beim Klick auf die Karte
die App abstürzt haben wir unter dem Betriebssystem Android 6.0
festellen können. Bei Google wissen sie schon um dieses Problem und
suchen nach Lösungen ->
Wir rechnen damit, dass Google den Fehler mit dem nächsten Update
behebt. Allerdings sollte dieser schon in der neuesten Version unserer
App behoben sein. Könntest Du bitte prüfen, ob Du ein Update der App
installieren kannst. Bzgl. Deines Betriebssystems haben wir leider
bisher keine Erfahrungen ob bzw. wie unsere Apps darauf funktionieren.
Da unsere Apps für die offiziellen Versionen von Android und iOS
entwickelt wurden, können wir auch nicht für volle Funktionalität
garantieren. Auf den “fused provider” als Standortdienst greifen wir
nicht zurück.Es tut mir leid, dass ich Dir keine positivere Antwort schicken kann.Ich wünsche einen schönen Tag.Schöne Grüße

Jessica - Support

:flag_gb: In english and short:

We have this problem with Android 6.0. The app crashes, when the map is selected. Google knows the problem and is looking for a solution.
We expect that google will fix the bug in the next update. Also this bug should be fixed with the next version of our app. Can you check if you can update your app? In regards to your operating system we do not know it and only guarantee for the function on official versions of Android and iOS. We do not use the fused provider as location provider. I am sorry that I can not give you a positive answer.

So it seems that the problem is not coming from the “fused provider”. On the other hand Roboe wrote that only apps which specifically check for the absence of the fused provider will probably work. This is not what they say.

Does the link they sent me tell anyone anything? Is there a chance, that with an update this problem might be solved (I heard google sends out monthly patches to Android providers)? I guess not, since FP Open OS is based on Android 5.1 and not 6.0. And there it should work (even though they did not write that specifically).

… and on our phones android 5 is installed. I bet that this Jessica has no clue what “fused provider” is.

Did you try to start the app with location set to “device only”?

1 Like