GPS activates itself (Drei Austria / Italy)

i am not sure if this is a new prolbem, but…
…yesterday my gps turned on, while i was making outgoing phonecalls.
the dateservice and wireless-connection was turned off (since the gps-problem seemed to occur only when data-sercie was on)
my provider is Hutchison 3Drei in Austria and i have the FP1.

oh, i just read that others allready experienced that same problem with outgoing calls and gps-activation.
so never mind…

Just for the records: I am facing exactly the same problem: since about 10 days my GPS turns on whenever I activate mobile data or make/receive phone calls. My provider is 3 in Austria as in the most other cases. I hope we find a solution soon…


also, just for the record: “Me too” :slight_smile:

FP1(U) using the operator “Drei” in Austria, GPS activates itself every few minutes.

Maybe an interesting aside: Seems to be location-specific (happens at work, but not at home).

I’m based in Vienna, so I could come to the Austrian Fairphoners meetup in March, if that’s any help.

Also, I’m a software developer, so feel free to send me dangerous commands to troubleshoot the issue and/or brick my FP :smile:

1 Like

Some relevant logs with adb logcat would be interesting. That’s not less than I could do at our next meetup… :blush:

adb logcat -b radio could be interesting, too.

1 Like

A post was split to a new topic: GPS tries to activate for incoming call

how can i send/post an “adb logcat”? or what do you need from us?
(sorry, i have no clue, what to look for or where to find it :blush:

According to @Rene_Sendlhofer Drei Austria admits that there was a cell update and that they don’t care about the FP1 having problems with it. -> Bug report

@gege23: Here is more info about adb.

Excerpts from my adb logcat can be found here (I tried to reduce it to ~1k hopefully relevant lines):

Username: fairphone
Password: WDd25E19PpVC27tw

(I password-protected the file since I saw some sensitive data such as telephone numbers, and I cannot be sure I managed to delete all of those). I’ll try to run the “-b radio” tomorrow, but can’t promise anything, unfortunately.

@Stefan Thanks for the update, sounds awful :stuck_out_tongue: If it resolves the problem, switching operator is actually a viable alternative for me…


There are many GPS-related things in your log file.
But I don’t really know what happens at what time.

According to the bug report there are three steps to reproduce:

Could you start the log do those steps, wait until GPS activates itself and stop the log?

Anyway, this seems to be (another) Mediatek-related problem (there are other devices and carriers that seem to exhibit this issue).
It may be too much work, but could you try to reproduce this in the beta KitKat build?


My cousin is on Drei, I could borrow his SIM card and try to reproduce the issue in #kitkat .

PS: Yeah, timestamps would be great! :blush:

1 Like

I became aware of this topic a couple of days ago. I’m using my Fairphone on Drei/Austria and I had the problem with the switching on of the GPS for a couple of weeks now (can’t say since when). I assumed that this was an app-update running Amok

Anyway: what is unusual is that today I didn’t have to turn off GPS all day (first time in weeks). From what I understand in the previous posts here is that this is a problem of the Chipset and the Carrier. As I haven’t changed the Chipset on my Fairphone then Drei/Austria must have changed something. Is that possible?


Edit: I draw this back. After 24 GPS-less hours it started activating again

@YtvwlD That is exactly what I did, I just tried to cut out the relevant parts of the log (and probably failed… sorry for that).

I’ve now uploaded a bigger log file:
(same username/password as before)

I’ve done the following:

  1. Wait until the GPS symbol appears
  2. Disable GPS completely on the phone (in the settings)
  3. Attach to USB, start adb and wait until the GPS symbol appears again
  4. Stop adb & upload logfile

Yes, I will update my Fairphone to the KitKat beta during the weekend and report back.

@Stefan Ah, good point, my bad. I’ll include the timestamps in future traces!

Many thanks for your help!


New adbcat logfiles!

  1. I didn’t know that “adb logcat” also pulls historical data, so the previous logfiles are probably garbage (I deleted them already from the folder)

  2. New files:
    Username: fairphone
    Password: WDd25E19PpVC27tw

“adb logcat -v time” (GPS switched off, turns on at around 10:25 or 10:26am):

as per request from @YtvwlD, “adb logcat -b radio -v time”: (GPS switches on around 10:00am):

Hope this helps!


Short update: I installed the beta KitKat build yesterday (FP1-1.9.9-pre3-1479835251), with mixed results…

  • The good: I do not see the location symbol anymore at the top
  • The bad: Battery drains enormously fast (will attach myself to :slight_smile:
  • The bad/2: Battery history still reports GPS as being frequently on for long stretches at a time.
    Also, sometimes the “Location” setting reverts to “on” and the Google Play services are listed in “Recent Location Requests”. Also, the back of the Fairphone (where the logo is), stayed pretty warm thoughout the day, but now it feels better, maybe a one-time glitch…

So, overall, I’m not sure that the update improved the situation wrt. GPS… Maybe it’s just “better hidden”.

1 Like

Also have a look at this topic:

KitKat has some GPS issues on its own (that’s 1 reason why it hasn’t been released).

Ps: Great that you are putting so much effort into this! :slight_smile:

1 Like

Ah, thanks a lot for the link, will follow that topic.

Heh, I’m pretty enthusiastic about the Fairphone :slight_smile: (plus, I’m a backend developer usually, so this is a nice chance to learn something new, too)

1 Like


I am facing the same mentioned problem.
FP1U, network provider: 3,

GPS is activates itself automatically when switching on the data connection, thats already known.
I just want to add another weired aspect:
Also calling someone (with GPS and data connection deactivated) sometimes activates the GPS. Not always, but sometimes… I have not found out more.

Has anyone an idea?
Because this bug is quite restrictive… you have do deactivate the data connection always…

Please check out our bug report: