Google sync lost after update

My bad Stefan!

After almost 21 years of Internet services hosting, and various online activity, I really should have read the Banner :blush:


Never mind haha :slight_smile:

@all: I was just thinking: Did anyone of you try to run the Fairphone OS 1.8.7 update again (not just the Google Apps installer)?

To do so, go to the Fairphone Updater app > Advanced Mode > Android for Fairphone > Latest version > Install.

Does this solve the problem for any of you?

Edit: Apparently this does not solve the issue, as @Mark_Tiramani states here.

Hi Elise_Ross,

Your tip worked for me !!

Obviously this may not work for others, but it is the only thing that brought Gmail push notifications back to life for me! Many thanks!!

I went to “Apps” -> “Google Play services” -> “Uninstall updates” -> clicked “OK” then “OK” again at a second warning: “Do you want to replace this app with the factory version?”. The app is uninstalled and a notification appears stating that “Gmail won’t run unless you update Google Play services”. Touching this notification brings up the GPs screen to “UPDATE/OPEN” GPs. I updated GPs and the notifications were fixed. But after a reboot the WiFi icon is grey again and GPs has to be reinstalled to reactivate push notifications. For now this is at least a working fix since I rely on the push notifications for work.

The first time I did this the phone notification mentioned “Maps” the second time it mentioned “Gmail”. I have no idea if this is of any significance.


1 Like

I’ve tried this already and it didn’t work. Elise_Rose’s solution doesn’t seem to work for me either.

Found another thing that worked for me: apparently, sync was disabled for the ‘primary’ inbox after the update. To change this, go to settings for Gmail, then click your account, then ‘manage labels’, then ‘sync primary’. I receive updates from gmail again. However, I also noticed that ‘android device manager’ doesn’t ‘see’ my Fairphone anymore when I try to access it from a computer. Anyone with the same problem?

Could this be related to the loss of the Android-ID?

1 Like

This seems to work for me aswell! Thank you so much.

Hi. Basically I ran the updater again (Apps/(ALL)Fairphone Updater/… and as it was installed already the only thing I missed on the installation time was to press the red banner about GoogleApps. All seams to be back to normal.

Hope it helps.
Thanks Stefan

1 Like

Re-running the Fairphone 1.8.7 updater did not work. Do not do this if you already have push notifications working temporarily!
It actually broke push notifications again, and this time the Google Play services reinstall does not fix it. Bummer.

The SL Push Tester app works fine. The WiFi icon is blue. But no push notifications come through for Gmail.


It worked! It was simple… thanks a lot!

1 Like

I followed the instructions on, after another reinstall of the update and the gapps.
For now, android device manager works again, and I also receive push notifications from Gmail

Hello! I have the same problems and many more… I wrote an e-mail to the support many days ago, but no reply… So: Sync of my contacts/calendar etc. stopped working even before the latest system update. All my contacts and calendar entries got lost after the update (Kola Nut 1.8.7). Can’t import them from the cloud although sync is activated. Password is correct! Deinstalled and recreated the Google account several times. Made the system update a second time, didn’t change anything. Can’t download any apps because of the storage problem. (So my mail app doesn’t work any more anyway. And I already had to delete several important apps because of the alleged lack of storage.) Can’t do the repartitioning of the storage because I can’t make a backup of the phone because my computer can’t “see” the phone (I already tried several USB cables). I’m rather desperate and really don’t know anymore how to solve all these problems… PLEASE help me!!! :frowning: Thanks.


Do you use a Mac, Linux or Windows?

The trick with the Labels worked for me (my wife’s phone). :smiley:
In our case only the “sent mails”-label were synchronized… :confused:

Re-running the Fairphone 1.8.7 updater did does work after all… sort of.:
Afer reinstalling the 1.8.7 Fairphone update using Stefan’s method above the Gmail interface may display the messaging sync for an email account as ticked: In “Settings” “Sync Gmail” is ticked. “Days of mail to sync” may show the previous setting (“30 days” in my case). So, I thought all was set, but no, after touching “Days of mail to sync” it showed no sync! (I am 99% sure of this but it all got very confusing!). So after reinstalling 1.8.7 and Google apps, rebooting, and installing a Google+ update, and checking that “Days of mail to sync” is set… push email now works.


Finally… My phone seems to be a smartphone again, yippieh! I managed to do a backup by using an SD card, then did a hard reset and the storage partition upgrade. It was a lot of work and waiting and numerous restarts etc. … and of course all my settings were gone. Also, when I wanted to restore everything, the phone didn’t find the SD card! :frowning: But after another restart, it went well. Now everything works again, including the sync, and I can download new apps! Thanks to Luc from the support team.

1 Like

I can confirm this behaviour after the 1.8.7 update

What have been done:

  • install update
  • install gapps
  • clear cache
    no automatic gmail sync work even if google account indicate sync is on.

I can acces my email/calendar/contact but I had to refresh them manually.

Reseting sync days in ‘Gmail/manage labels’ and then set it back to ‘30 days’ works for a few times but then mail sync stops again.

Sync/push with other non-google apps work perfectly (like k9mail)

Any one with a stable solution ?

Not sure whether my problems were caused by the same issue that others are experiencing, so YMMV. I’ve started from fixing ADM not working, rather than push notifications not working, but in the end both problems were gone. What I’ve done is followed instructions that are basically identical to those posted :

Which fixed ADM for me (my primary goal). After this I still had a lingering issue with push notifications, which for me disappeared after toggling ‘Settings > Data usage > [menu key] > Auto-sync data’ off and on again. I haven’t had any issues after this (around a week) or after a reboot. It probably doesn’t hurt to disable auto-sync before following the instructions above and enabling it again just before the reboot step - but I haven’t tested this.

Macbook Air, Mac OS X version 10.7.5.