Google play gone from my phone

I have posted this in two forums as I was not sure which category to post in:
I just got my fairphone. So far its not going so well. I downloaded google apps the way the phone instructed me when it was first turned on but now it seems to have completely gone off my phone. I can’t find an icon for it anywhere so can’t access it to download apps.:-/ When I first downloaded there was play icon that gave me access to the store. Unfortunately however the phone could not download basic apps such as facebook and googlemaps. It kept saying there was an error then would freeze on that page of the app store and need switching off to be able to navigate off the page. I have updated the fairphone softwear on fairphone update (cherry and the like). I thought this make my phone able to at least download these basic apps but no! Now there is no icon at all. The phone did go through a phase of asking me to log onto my google account when I pressed the google play icon but once I had already done that it seemed incapable of taking me the store and just said I was already logged on. Now the icon is gone altogether! Does anyone know what it happening? How do I get onto goodle play and is it possible to download apps like facebook? I am starting to wish I never ordered this thing! :-/. I should try the customer services email but I tried them to asking them a question before I got the phone and they never replied. Maybe I should have taken the hint and ran! You can’t even get through to them on the phoneline it just asks for a pin number which I have not been given!

perhaps try the installer again? If it has disappeared from your home screen(s) you can usually add it again; it’s not listed under apps but if you go to the apps screen there’s a second tab called ‘widgets’ and the google apps installer widget should be there somewhere (don’t know on which page since i have a number of additional widgets now)

I have looked but it’s not there at all :frowning: . Don’t know how I can get it back.

Sound like you are quite overwhelmed by your smartphone experience. Do not despair, we’ll do our best.

First, maybe you can help us to help you.

What information do you get if you press the menu button for a longer time, choose Manage apps and scroll down to “Google Play Store”?

Do you have the Launch button? What do you see if you press it? What information does the app show?

When I select manage apps and scroll down to g there is no google play store in the list. I don’t know what a launch button is so I don’t know if I have one. I have only just got my fairphone so it’s summer 2012 batch.

Hi Ruth,

I have tried to get my phone to work for 24 hours now. After a hard reset and a re-installation of Cherry OS I now all of a sudden got back to the initial process- and the google store app is back!

So first check out how to do a hard reset (don’t forget to backup), then re-install the latest blue fairphone update (don’t touch the green android OS button) and give superuser access. Then re-install the blue cherry update again- and all of a sudden it worked for me!

I hope that helps.


and here is how to do a hard reset.

Good luck!



If you can’t find the Google Play Store and the Google Play services programs in the ALL tab of the Manage apps list (see below), then you apparently do not have them installed.

Considering the Launch button, see also below: if you choose an app from the Manage apps list, and scroll down, you launch the app with it.

If you don’t have the Google Apps installed at the moment (what I suspect, since you could not find the Google Play store in the Manage apps list), you might re-install it.

You should be able to do so by going to the Widgets section of you app drawer, looking for the Google Apps installer, picking it up by holding your finger on it, draw it to one of your home screens, and drop it there. Then you should be able to go through the installation and login process again, and you probably do not need to hard reset.

By the way,

you have a 2012 Fairphone? Now that’s what I call an early bird! :wink:

1 Like

Hi Humorkritik
Thanks for trying to help so far. Sorry for the typo with the year :-/. No I wasn’t that early.
I did install google apps orginally as in structed when I first turned the phone on. It is actually listed under my downloads but its not on my phone. I don’t know what happened :-/. The installer is also not under my widgets. All this happened after I update to cherry and the other software.
Can you help?

Hi Ruth, it’s perfectly normal (though not very convenient) that those Google services disappear when doing the “Cherry” update. It’s strange, though, that the “Google Apps Installer” seems to have disappeared from you widget list as well - as this is an integral part of the OS that can’t be deleted, normally.

Maybe you should try one last time: Go to your Apps section by doing a swipe gesture from the side of the screen and touching the circle with the six dots in the middle. The Apps list will appear - touch “WIDGETS” on top of the screen. The widgets are listed alphabetically - look for “Google Apps Installer”. If you find it, touch it long, then drag it somewhere onto your home screen. Touch the Google Installer on the home screen and re-install Google services.

If the Installer really isn’t in your widgets list, something has probably gone wrong during the Cherry update. So, you should try to run the update again. Make sure to save any personal data that might already be on your phone to a micro SD card first, as this data might be deleted during the update.

Hoary! I have my fairphone up and running at last. Trying the cherry update again worked.After that the Google play installer appeared on my phone and I was able to download it. Now I have all my favorite apps installed;bar a few- like the Good Shopping/Ethical Shopping Guide :frowning: . They don’t seem to have their app on Google apps. So I can’t have their app on my Fairphone- ironic ! Still at least I’m now happy I bought my Fairphone. Hopefully it will be plain sailing from now on! :slight_smile:

Thanks for the help forum users! :Think

1 Like

Ironic indeed! Hopefully you can find some other app that can fill the gap, e.g.

Also, have a look at this thread: Ideas for fair or eco apps?

Hi Shyen
I have to thank you so, so much!!! I had the same problem and had tried to solve it with one of the fairphone support team members, but nothing worked. I wasted so much time on the ways he told me, but nothing was successful. Then I finally found your post. And it was my last hope (I was about to throw my fairphone in the rubbish bin). And…. it worked!
Thanks a lot.