Google apps not working

Sorry to ask what I think I am not the only one asking, but I am totally un-techie, and don’t understand what I’ve read elsewhere.

I have a fairphone, bought this summer. I am still on 1.6. It tried several upgrades (over a dozen) unsuccessfully, and i can tell i am still on 1.6 because i found how to look that up in the Updater. The icons for my google apps are still on the home screen, but if i try to use them it says they’re not installed. The google apps installer is greyed out and says they are installed.

I would prefer to stick with 1.6 for now - I can’t face getting to 1.8 - but would like to get my google apps working again.

Can anyone help? I am not very good at this, so very simple descriptions for an idiot would be really helpful.

Thank you!

Have you tried this? (CAUTION: This will delete all shortcuts to apps on your homescreen)

Thanks - that says it only works if you have 1.8, and even if I wanted to, I can’t now.

How come? Could you elaborate?

the link you posted to, if I’ve understood it rightly, says it only works with v. 1.8. My phone failed to upgrade from 1.6 correctly before the upgrade was withdrawn/abandoned.

This also applies to 1.6 so please try @Robin’s suggestion.
And otherwise maybe try re-installing 1.6?

Thank you, I will try it.

i wouldn’t have the first idea how to even think about re-installing 1.6, whatever that means.

I’ve followed the clearing OS data link, and restarted the phone several times, but my google apps have completely disappeared and the installer is greyed out, and when i log into the google play on my computer it says they are installed on my phone :frowning:

@MichaelHopkins, Have you tried this?

yes, that’s what I’ve done.

Im sorry to hear that this did not help you. :[

Could you please try the following steps?

  • Go to System settings -> Storage -> Downloads -> Tap the checkboxes of all the update/Google files -> Tap on the little trash can
  • Go to System settings -> Cached data -> Clear it by confirming OK
  • Go to System settings -> Apps -> Choose the tab All -> Search for Fairphone OS and Fairphone Updater -> Clear data on both these apps as suggested by @Robin (Please do this again)

If this doesn’t solve it then please try doing the 1.8 update manually again as explained in this article.

Thanks. I’ve tried all that again, twice, and restarted twice, and the Google apps installer.

I am unable to manually update to 1.8 because the instructions are totally incomprehensible to me. I realise I am not a technical as most FP users, but I’m not and I can’t understand them.

Also, I am not sure that i want version 1.8 at the moment, because the rollout has been postponed.

48 hours ago I had a really nice working phone which was the happiest I’ve ever had. I now I’m saddled with a phone that cost me a fortune, and is unable to offer the most basic functions I need and consider reasonable in a phone. Very upset, confused, and disappointed :frowning:

Success! A hard/factory reset has done the trick!

So simple, and it took me so long to figure it out.

1 Like

I’m pleased you got this working.

Nobody wants to be told a hard reset is the best option to go for, but sometimes that’s the one that does it. It should of course be a last resort :wink:

This topic is now closed. New replies are no longer allowed.

1 Like