GiffGaff issues with latest FP2 OS

Hi all - Just bought a giffgaff sim to use for mobile data. I’m a UK user with a co-op sim also inserted. So basically I just want to use data from giffgaff as it’s cheaper than a co-op bundle!

Tried to change the APN settings as per giffgaff guidelines - Doesn’t work. Looked online here and saw this fix from last year 3G/4G on Giffgaff

This doesn’t seem to work now as the latest OS doesn’t offer switching the other, in this case co-op sim, back to 2G. Only options now are 3 and 4G,

The only way I can get the mobile data to work is by de-activating the co-op sim. I tried turning off data with the co-op sim, having data set to giffgaff, calls and SMS to co-op, that didn’t work. So it looks like the only way it’ll work now is by de-activating the other non giffgaff sim, which can’t be right surely…

Anyone else tried to do something similar or come across this issue with giffgaff and the latest FP2 OS?

I could just port my number to giffgaff, but I think I’ll still have to keep the co-op pay as you use sim going as part of the co-op licensing deal here in the UK. In which case what’s the point in having 2 sims if you can’t change options between??

Are you aware that although the Fairphone is dual sim, you only can give one sim 3/4G?
The other sim has to put on 2G.
Which sim gets the 3/4G doesn’t matter and switching the settings is always possible, as long as one sim is on 2G, the other can have 3/4G


Aye, that fix I linked to from last year states that, but when i go to change the coop sim to 2g, in the preferred network setting, that’s not an option, again just 3 and 4g are listed.
Am I missing something??

For some people, this seems to work (click through to the original post for better formatting):


Yep, full reboot did the job - If in doubt just turn it off and on again eh…


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.