Ghost inputs on FP4

Not yet… It comes and goes without any apparent reason. I did submit a ticket to Fairphone support, but nothing but a semi’automatic reply with troubleshooting steps (test touch screen and reset the device).

1 Like

Hi, I have the FP4 now 1 week and I have ghost input when charging.
When holding the phone the screen swipes up and down and when typing the entry code, double or more of the chosen digits appear.

Hi and welcome to the forum.
Have you considered if the charger is grounded?

You may have a leaky charger which dumps through you when you touch the screen or you have a tendency to hold static electricity which then dumps through the phone. The first option is more likely so try an alternative charger and ensure it has a grounded earth pin

Hi, I assume the charger is OK, since it is a new original Samsung fastloader. I bought it 2 weeks ago for the S9 I replaced by the FP4 now. I will check the outlet in the wall.

1 Like

Dear community, my name is Christoph and I bought my FP4 in July 2022. Since several weeks I have an issue with ghost touching and as the official Fairphone support didnt answer my requests since more than 14 days now I am hoping to get support here:

From time to time (sometimes every 10 minutes, sometimes once an hour) the phone reacts like I would wildly touch the screen and for example swipe or zoom in or do single touches. To visualize whats happening I am using an the “Android developer option” to trace the touches that happen. In the attached screenshot you can see a result of this. Apparently the issue is happening around the display center line - that´s always the case as far as I saw it so far. Not always it looks such chaotic or intense, sometimes it´s just short single swipes, sometimes it´s something in between.

Installation of firmware build 163.20220826 didnt resolve my issue.

Did somebody see similar issues? Might that be related to electrical contacting in the touch sensor or the plug connector? Thanks for any ideas :slight_smile:

VG, Christoph



Hello. I had a similar issue on a different phone (Asus Zenfone 2), it was caused by a faulty digitizer. If you are comfortable with disassembling the phone, you can try reconnecting the display. Maybe it’s just an imperfect connection. Here’s a video guide:

If it doesn’t help, then I would suggest you to #contactsupport. I think this should be covered by warranty.


Welcome to the community :wave:

I’ve moved your post to this existing topic. There hasn’t been a clear cause identified so far, so I’m not sure how far along a fix is :thinking:

If you didn’t get any response from support (no ticket number), consider to #contactsupport again, the more people report issues, the higher the priority.


Thanks Hirnsushi (nice username btw :rofl: ), for some reason I didnt find this existing post - at least this shows that I am not alone :wink:

Would be great if the other victims of this issue could also use the android developer option to try to trace the ghost touches. Maybe this gives additional food for thoughts.

Steps to do (Thanks

** Open the settings of your Fairphone 4*
** Secondly click on About the phone*
** Secondly click on Software Information*
** Find Version number and press it 7 times in a row*
** Unlock your Fairphone 4 by performing the pattern or by typing the PIN code or password*
** Developer mode activates*
** You will be able to see Options for developers in the System settings of your android*

  • Choose Developer options and in area “Input/Eingabe” activate both options (In my german version this is “fingertipps anzeigen” as well as “Zeigerposition”)

Now your screen will trace all touches and so you also see where the ghost inputs are happening. Once it occurs take a screenshot (press “reduce loudness” plus “on/off” button simultaneously) before touching the display again as this deletes the traces of the ghost touch.

Hope to see some answers :slight_smile:

BR, Christoph

PS: Yes, I am frequently askign the fairphone support for an update. Let´s all do that so they have to react to it.


Hi Razem, yeah, sounds a good idea to dis- and reconnect the display/touch cable. Will try this later. Thanks.

BR Christoph


I’ve also been seeing this issue occasionally (once every few days) for months now. The only thing I’ve changed is the screen protector I use (to a Brotect AirGlass one) - I have not yet tried removing it to see if it fixes the issue.

Happens when not charging. I don’t recall whether it has happened whilst charging. I live in the UK, so humidity is 60-70%

Debug pointer location shows an erratic input exactly in the center of the screen rapidly moving up and down.

I find it strange that these reports have come in at similar times. Either a software update that affected sensitivity/thresholds or a defect in the digitizer that only appears several months after manufacturing!

I’ve previously seen this thread, but was reminded about it after this post on Reddit:


Funny enough, it started for me about two weeks ago. Happened three or four times, but only once since I enabled the debug cursor info three days ago. Exactly the same pattern both of you describe.

I’m currently using iodéOS and the last update was months before the occurence, so it doesn’t seem to be something introduced with the last updates. The phone was unplugged, so definitely not a problem with a faulty USB cable. And I don’t use a screen protector or even a case. The problem didn’t stop when I completly removed my fingers from the screen.

I use this as well and dont have the issues so far, so I would doubt its the culprit


Now I can provide my own screenshot! :tada:

But I still have no clue what triggered it.


Just opened the phone, disconnected the display cable, blew some air on both plugs with a medical pipette and reconnected. keeping fingers crossed that this is solving the issue…

I will report.

BR, Christoph


I dont want to post something pre-mature but so far at least I can say it didnt get worse by a.m. measure :slight_smile:


Same here. I sent the link to this thread in my support ticket.


I am increasingly positive on the result of the dis- and reconnecting with intermediate cleaning: No more ghost input events I was able to track since two days now. There was one event which I am not sure about whether or not it was ghost input or just a fat finger. Definitely by far the longest time without the issue since it occured first time :slight_smile:

so I encourage everybody here to do the same and report the result!

BR, Christoph


Yesterday I found out that I can trigger the ghost inputs by slightly knocking the phone’s back against my hand.

After that I disassembled and disconnected the screen. After reassembling it, I was not able to trigger the ghost inputs any more as described above.

Therefore it seemed to be a connection problem of the display connector.


Thanks @katho80, that´s backing up the hypothesis of the bad connector as root cause. I tried knocking the back of my phone but wasnt able to trigger it.

Update on my own FP4: After 4 days without recognizable ghost input it again happened yesterday. It was a massive ghost input and also happened app. 5 times in 36 hours. Thats less than before I opened the phone but yes, it´s annoying to have it back. Still I am convinced that the connector is the root cause, otherwise I wouldnt have 4 days without any incident after fixing it.

Not sure how to continue now. The FP service told me (after calling them; no reply to my service ticket) that I would need to send it in and it would take app. 2 weeks before I have it back in my hands. Pretty unattractive option.

Greetings, Christoph


I’m glad I’m not completely alone in this issue, but also disappointed to see there’s no real acknowledgement of the issue from Fairphone, or a proposed fix beyond sending the phone in.