Gesture typing (Swipe) Function not available without Google Keyboard

You have to install the Google keyboard or another keyboard app in order to use this function.

Doesn’t this count as a bug? Either the option should go away because it’s misleading, or whatever Google Keyboard installs should be installed by default…


well, yes, but actually it is not an FP2 bug, its an AOSP keyboard bug. I had this on Omnirom 5.1 also… AOSP keyboard FC with swype…


If this is still true, then the gesture typing library is missing in the Fairphone Android. And in that case I’d clearly consider it a bug that could be and should be fixed through an OS update.

If you can’t / don’t want to include this library in your ROM, then you should disable the gesture typing option completely.

The workaround would be to install the Google keyboard, but I personally don’t really want to do that.


Or any other keybord app, if you don’t want an other Google app :smile:

1 Like

Good point, but I’m generally happy with the AOSP keyboard and don’t really want another company to be able to read my keyboard presses (although it should be fine if the app doesn’t get internet permission).

Do you know of any simple, nice to use and open source keyboards that support gesture typing?


I use the SwiftKey-keyboard. Definitely not open source without internet access, but I find it very easy to use (also because of the multilingual option)

1 Like


where can one find the option “Slide Keyboard” in order to write messages quicklier?

Thanks in advance.

You’ll need Google Keyboard.

Because you have the same issue in Omnirom, you can draw the conclusion that this is not a bug of FairphoneOS?

I use AOSP keyboard with Cyanogenmod on my old i9100, and swiping input works correctly.

@paulakreuzer, I don’t understand why this point should not be considered as a real known bug of FairphoneOS.


Thanks for your help.

It’s a bug in a few roms. And known by many. Probably a library which comes with Google keyboard, either in form of some gapps, or maybe the ROM maintainer knows to include it. I don’t know which it is, so you could argue…

Well I agree that the misleading settings item is a bug but since I have no idea whether it’s a FP bug or not I just added it to the feature requests list. You can vote there by :heart: liking the post.
I guess the easiest way to “fix the bug” would be to remove the option to turn on gesture typing from the settings unless you install Google Keyboard. But I think you’d rather have the feature added for the standard AOSP keyboard, hence -> Feature request.



Small issue: in FP2, while typing a message - the ‘swipe’-function (where you form words by going from letter to letter) does not seem to work and there is no previously installed dictionary; except for the names of my contacts: dictionary (Dutch) is becoming ‘larger’, because the words I type seem to be saved.

Input via momevent is ticked on, …

anyone has the same problem?


Android (AOSP) keyboard does still not support “swype.” (although there’s a setting). You have to change to Google keyboard (or others) instead. You may search for more details in this forum, it has already been discussed somewhere)

Android (AOSP) keyboard DOES support “swype”. I have been using it on cyanogen with my old phone. So I think adding the supposed missing library would be great


I am using Fairphone Open OS & I don’t want to use Google Keyboard, but I REALLY want to use swype input… frustrating! Is there another workaround or FOSS keyboard that supports it? (I like AnySoftKeyboard but still no swipe)

Edit: I tried just replacing the library as explained here but it had no effect… working on it


I am the same here, I’d like to keep it minimal. Did you find any solution for that “swipe” issue?
I’d like not to have to download more apps or features…

Especially now that the Google Keyboard (Gboard) starts connecting to the internet to download things like GIFs, I’d like to stick with the AOSP Keyboard. But I miss gesture typing very much.

1 Like

This topic was automatically closed 53 days after the last reply. New replies are no longer allowed.