Genshin Impact: Strange Behaviour and it's getting worse

Hi Guys

I hope you’re able to help me.
I bought the FP3+ some month ago and want to install Genshin Impact. The app itself can be installed (from Play Store) but the ingame download fails always with various error messages (-9102, -9006). I tried factory reset and even system recovery mentioned here:
I tried with and without SD and diffrent SD card but nothing help. Even worse now in the first-time-wizard i can’t even log into my Wi-Fi because I always the get the error authentication problem. Afterwards through the normal way it works without issue. Additionaly the screen brightness seems to be buggy as well. It automaticly gets fully dark.
Do anyone have an idea what the problem could be?
I assume it’s either an deep software issue or something with the hardware.
Can someone do me a favor and try to install the game to see if it works on their side?
Additionally does someone know how i can completly wipe the phone and reinstall it with an pure fresh OS from extrnally?

Welcome to our community forum :slight_smile:

Regarding the screen brightness issue, this is a known problem since the most recent update and meant to be fixed with the upcoming one:


For the adaptive brightness bug (known, as urs_lesse says) see also a dedicated thread here.

Some people report having managed to re-train the algorithm (requires a certain amount of persistence and patience I expect), I just turned off adaptive brightness. Remember you can modify brightness by sweeping down twice from top of screen.


Fair enough. As soon the first-time-wizard is over its acceptable as it can be managed through the control panel. Nevertheless the brightness bug is my least issue.
Intrestingly I found out that the authentication issue can be bypassed by using the QR scanner instead of typing in the password manually.
But my major problem still remains. It seems I’m unable to download the app. It’s either somewhat instable WiFi or corrupt storage. Or do you have an other idea? And have you an idea how to resolve it?
Can someone with an FP3+ try to install it as well just be make sure the issue is not with the app itself?

Reading from your first post “with and without SD”
Do you know how it is formatted? As internal memory or portable storage?
Many users having it formatted as internal memory sooner or later ran into troubles.

I’d like to use it first and foremost as internal memory but I have tried both. Neither worked.

In general terms, only use SD cards as portable (external) memory.
As Patrick1 says, lots of people have run into problems when formatting them as internal memory.

I want to avoid moving apps manually to the SD card. I’d did that on my current/old phone and that’s an pain in the ass even with apps like AppMgr III. Never the less it does not solve my current problem as neither of the SD card formatting option nor without any SD card works.

I seem to remember in the past seeing apps like this failing at an initialization stage due to insufficient immediate bandwidth (ie the bandwidth available at the time of initializing the app).
What sort of connexion do you have (also, wifi 5 GHz recommended)?

I tried it always through WiFi connection which marks my phone as 5 Ghz and I get at somewhere between 140-150 Mbps.
Sidenote the ingame download fails always at around 3-5%. If that may hint to something…

140 Mbps is surely fine.

Here are a few other aspects you might want to check:

  • Interference from Anti-virus or other anti-malware. There are reports of some security software interrupting downloads or access to the app resource downloads.
  • Some Internet service providers are blocking access because of possible security issues. Try changing your DNS server or using a VPN.

For DNS: go to Settings > Network and Internet > Private DNS (usually set to “Automatic”), you could either try setting it to “Off”, in which case you’ll be using your provider’s default DNS, or set to “Private DNS provider hostname” and indicate which host, such as or

I’m not saying I recommend these DNS providers but using them temporarily may allow you to get round your difficulty with Genshin.

1 Like

I dunno, but do you have issues with downloading other stuff? If not, I would guess the problem is not on your end.

Do you happen to know when that’ll be rolled out?

Nope. My guess/hope was that the update would be rolled out in time ahead of the start of FP4 delivery, but that time window is obviously getting quite small now. But that’s just my pure speculation founded only on what is publicly known (I don’t know anything more about the update than everyone reading the forum).


Switching DNS to the one from google didn’t helped. Same errors as before.

I havent installed any anti-virus nor anti-maleware on my FP3+ and I have only a stock router from my ISP. I could download and install the same App on my PC and old phone through the same router so I doubt there lies the issue.

I can download and install any app from Google app store. Only this one app seems to have an issue when it has to download additional data in the app itself.
Therefore I want to know if any of you run in the same issue as I do when they use this app.

If you do a factory reset it will wipe the phone and set it up with the last full OS you had. That means it will also be the last updated version.

Alternatively you could try this

Sorry, for just coming back to the SD-card as internal memory issue (unfortunately I can’t help with your main concern).
I fully understand where you come from.
Still, …
Apart from some problems being caused by that setup in general, it is a major risk for your data, since SD-cards are not as foolprove as interal memory.
There have been some users reporting a broken SD-card. And in that case all data is lost. So, you should at least backup your data regularly, when using the SD-card as internal memory.

You might already know this; I just wanted to post it for other users reading here. :wink:

I really hope, you find a solution for your troubles. :+1:



so after a long time i did some more testing with now the latest software version of the phone.

If i download it through WiFi i get the -9102 at several steps in the download process and on every retry i get some percentage more. Looks like for me as if he would loose the connection. I oberserved that also outside the app that the phone looses the WiFi connection (even though he has max signal). Tbh I doubt that the issue is on my AP as non of my other devices seems to have this issue. On some old Fairphone post(which I can’t find anymore) I found that this was a known issue. Is this still the case?

If I use any SD Card formated as internal with mobile connection I get the -9006 error around the 5% mark.

If I use no SD Card or use one as mobile but just use the internal memory with mobile connection it works fine.
What I couldn’t test though is what happens if I would use it as Mobile formated but move the app on the SD card because I can’t move it. In fact I can’t move any app because the option does just not exist. On my previous phone it could be found under the storage section in the apps. But now there is only clear cache and clear storage. Got this option move to some other places or for any reason removed completly?
I can in fact move the app to an SD card on my old phone(Galaxy S8+) so I don’t think the app itself is locked.

I also installed the OS fresh from PC. No change.

Does no one has an FP3 who could try if it works for him?

Does anyone has an idea where the problem is?
An mobile formated SD card without the option to move my apps isn’t a solution as the internal memory with 64GB is for me just to small.

Are you sure you can’t make enough space on the internal 64 by using an SD card formatted as Portable/ External by moving all media (photos, music, docs) and some, if not all, apps from the internal 64?

Two others reporting on use of this software. You could exchange your experiences.

You can configure apps like Camera and Open Camera to use the SD card for storage when it’s formatted as portable. In this case the app itself “remains” in internal memory but all the bulky data will be on the SD card.

Thanks for your investigations.