General collapse of FP2

Hi - I have a FP2 which is about three years old, and has had a couple of replacement components (mic module, sensor module). But over the last few days it has become intermittently unresponsive to screen touches, and intermittently doesn’t come out of standby when I short-press the power switch. When it does work it seems to freeze randomly, not consistently in any particular app - and sometimes after maybe 20 seconds it unfreezes, but mostly it doesn’t. Occasionally when the screen comes out of standby it’s corrupt (random dots and lines) - then sometimes I short-press power a couple of times and it comes back, and sometimes it doesn’t come back at all.
This has developed gradually over the last few weeks, with all symptoms occurring more and more often.
The randomness of the symptoms makes me suspect that it isn’t just the screen component, or indeed any other single component. I’ve taken all the modules out and cleaned the connector pads, but that made no difference as far as I can tell.
Does anyone have any idea whether this indicates a problem with the screen, which could be fixed by replacing that module?
Also - does anyone know any way of retrieving data from the phone main storage (not SD card) if the phone screen doesn’t work, even though the phone seems to switch on, and the charge indicator LED appears to work correctly, indicating that there’s some processing activity going on?
Grateful for any advice!
Thanks
Nik

I just tried the following … with a working display, but without using it, so this should work if not a faulty display module or a faulty connection to the core module would interfere with phone functions somehow …

Connect your phone to a computer via USB.
Boot the TWRP recovery on the phone, see #twrpwoflashing.
When TWRP is booted, it should enable MTP, so you should be able to see the phone on the computer and copy files from Internal Storage.

That is, if you have not encrypted the phone.

If you have encrypted the phone … and if you are using Android 7 … then TWRP would need you to enter the decryption PIN/password before it can enable MTP.
To enter the PIN/password without a working screen you would have to connect a keyboard via a USB OTG adapter and enter the PIN/password blindly after enough time for TWRP to get to the password prompt when booting.

If you used a pattern instead of a PIN or a password, here’s how to translate the pattern into a password you can enter … https://twrp.me/faq/openrecoveryscript.html … section “Specific pattern decrypt note”.

If you are using Android 8, 9 or 10 in the form of e.g. LineageOS, then TWRP can’t decrypt user data.

For things outside of Internal Storage there’s supposedly adb backup according to https://twrp.me/faq/openrecoveryscript.html … section “HOST SIDE” … but this requires user interaction on the display to start the backup, so the display would have to work for this … and then adb backup wouldn’t be needed, because TWRP’s UI would be usable.
(Furthermore, adb backup is currently being reported as deprecated when you run it, so it most probably will not work from some future version of ADB on anyway.)

1 Like

Thanks - that’s a brilliant post.
I installed fastboot on my (Ubuntu) laptop. Then I started the FP2 and the charger LED flashes blue, which isn’t normal and indicates an unusual boot state, so I guess I managed to boot it into Fastboot mode.
But unfortunately after doing that, my FP2 isn’t listed when I type fastboot devices. So not sure where to go from here.
I don’t think my phone is encrypted - I do have a screen pattern set up for accessing it, but I’ve never selected any encryption as far as I know.
But it’s entirely possible that the phone is malfunctioning - after all, if it was working OK I wouldn’t be here. :slight_smile: I’ve no idea whether there is a problem with the screen module or the core (or both), but I’d be prepared to buy a screen module in the hope that it will fix the problem.
However, when I tried to order a screen module from the Fairphone shop, I wasn’t able to complete an order because there were no delivery methods available.
So if anyone has any suggestions for fixing the fastboot solution, that would be great.
Equally, does anyone know whether Fairphone are actually supplying any orders at the moment, since it’s impossible to complete an order on their shopping cart (at least for shipping to the UK)?
Thanks
Nik

Sounds good, Fastboot Mode does the LED flashing blue thing and some vibrations at the start with current firmware … to distinguish it from a hanging system boot attempt.

4 things to try …

  1. A different USB cable … there are cables out there only for charging, which wouldn’t work for data.

  2. sudo fastboot ...

  3. The official Android SDK Platform Tools, in case you used the tools your Linux distribution offered (which should be up-to-date, but who knows).

  4. A Windows computer. (I know, I know, but Windows tends to give less trouble with this.)

1 Like

Did you run it from your normal user or from root? Normal user may require special udev-rules (which I know only from adb). Probable workaround: Execute fastboot as root user.

In case that the phone freezes are caused by a non working touch screen and you own an USB OTG adapter, connect a mouse to your phone to simulate touch screen gestures with click and drag & drop actions.
TWRP sometimes does not offer a working MTP connection. In this case, choose Mount, then click on Disable MTP and again on Enable MTP. Disconnect the adapter and connect your phone to your computer. Hopefully you are now able to access your data.

2 Likes

Hi again - sorry this thread went to sleep, I had to take a break.
Thanks for the cable suggestion - fastboot now detects my FP2 and I can (apparently) boot it into TWRP:

me@mylaptop:~/Downloads$ sudo fastboot boot twrp-3.2.3-0-FP2-signed.img
downloading 'boot.img'...
OKAY [  0.326s]
booting...
OKAY [  0.012s]
finished. total time: 0.338s

But MTP doesn’t appear to start, or at least nothing auto-mounts on the laptop - and the FP2 screen remains blank. Syslog contains:

Apr 16 16:09:45 mylaotop mtp-probe: checking bus 2, device 5: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-2"
Apr 16 16:09:45 mylaptop mtp-probe: bus: 2, device: 5 was not an MTP device
Apr 16 16:09:45 mylaptop upowerd[1107]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb2/2-2

@W900 - I could probably cobble a USB adapter together, but I don’t know how to “simulate touch screen gestures with click and drag drag & drop actions” without being able to see anything on the screen - I wouldn’t know what I was clicking on or dragging. Have I misunderstood something?
More generally, for those more experienced with this kind of troubleshooting - do you think the symptoms I’m describing suggest a faulty screen module, or a fault with the phone core? It would be nice to get the data off the phone, but probably the most valuable thing on it is the text message history, which I presumably can’t obtain by MTP access to the filesystem anyway. So I’m in two minds as to whether to buy a replacement screen in the hope that’ll fix it, or whether to give up on the phone altogether - any thoughts, however uncertain, would be much appreciated.
Thanks
Nik

Before you buy a new display you could ask a #fairphoneangel for help. He/she could give you a display for testing.

1 Like

Thanks - I’ll give the Angels a try.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.