🇬🇧 🇩🇪 Random reboots with (official) Lineage OS?

Hello !
I have a lot of randoms reboots with the official version of LineageOS too ! (I have been experiencing this problem since I have my FP2 but since Android 6 it was much better) :sob:
My kmsg last crash log is here if it helps : https://pastebin.com/GJ2rtjqe (I hope it’s the right log file !)

PS : I have AA processor and crashs with and without SDcard

What are you trying to do with adiutor? And what is AA processor?


There are two processor types in FP2s and for a while people thought random reboots could be related to the processor:

1 Like

I can confirm, i have the same behaviour, lots of reboots after installing the official version!

1 Like

When I captured my kernel log yesterday I didn’t activate anything on Kernel Auditor. This morning I tried to downclock my CPU to 1497MHz but after reboot, my configuration was not saved, I think Kernel Auditor doesn’t works with my phone. (@StevenHachel said it did not work for him either)

Some more info regarding those random reboots:
From the two devices I currently can experiment with, the one that has random reboots came with the infamous AA processor. The other one (without reboots) is an AB model. I’ve changed uSD card, SIM card and display module between those two devices, but however i combine them, it’s always the AA one that has the reboots.

Then, i found this old thread from @z3ntu from last year:

Looking at the table in there (I guess it was taken from ibtimes.com), it’s pretty clear, that the AA variant can’t run with a GPU clock of 578 MHz, but only at max. 450 MHz. So I tried throttling the GPU clock in kernel adiutor to 389MHz (that’s the maximum value I can select, that’s still below 450MHz), but still got reboots (though it felt a little less often, but you can’t really tell, because they come very irregularly for me).

Is there any way to find out more about what’s different between those two processor variants? I fear there’s no way for us to get proper documentation from Qualcomm, is there?

I’ve now upgraded both phones to the 2017-10-31 release. Let’s see if that makes a change.

If anyone has any further ideas what to try next: That AA phone is not in production use right now, so I’m willing to do lots of crazy experiments here :slight_smile:


Now, after a few hours of using the Oct. 31 nightly build I can tell there are still random reboots on the AA model (this doesn’t come unexpected, of course).

Probably even more important than GPU clock is the memory clock . Anyone knows how to find out what clock rate the memory runs at? Googling didn’t bring up anything useful. Also, I don’t think I have any way to influence RAM clock from userspace (if I understand correnctly, RAM clock generally is set up by second level bootloader? Anyone can confirm this? I’m not really familiar with android, only with “normal” embedded linux boards :slight_smile:) .

1 Like

Hi, please keep posting /proc/last_kmsg in case you have reboots. There still might be other stuff broken.

And just for the record, official FP OS does not fix the reboots either?


1 Like

I have experience with 2 different PRO-AA phones and they both didn’t have any random-reboot problems (at least not with LineageOS). I had major issues in the summer of 2016 but that was probably due to buggy FP Open versions and not because of the phone because each month it got less and less with software updates.


I have an AA processor.
I only had some random reboots with modem-17.08.1 (with Fairphone Open OS as well as with LineageOS), not before that, not after that.

1 Like

Struppi which modem do you have ?

How can I read the modem version?
Since yesterday’s (31.10) update my FP2 runs quite stable. But wait and see!

Hey there…
For me there were much more Random Reboots. ~1/hour
after the Nightly from 31.10. it was only once…

i just read about /proc/last_kmsg…

i got some strange result with
cat /proc_kmsg

AQdit_ pnTc[r+b 01 c!lhacKq 0upPBessed
09 coim= rDcE6er9" Fama=“!rd” ev="lecbdk0p20 ajm10! 5( s#ondext=u:r82acjvapX*q t!oN4%xt5$8gbjdb4_r:dlviKcabh%TdAt^ble*s0pclaac<dhr pe2lisrhvd=1 pype!40 aedi150$900800.(80182)*!c: ddlied { remmveWnme = fCR i4261 come<"ReboveR9" *aee= sySdelfRaL%gKrk@bnMt m!d" dev5"Hmablj p00" I*m=10#1 09 c/NtEt9u2R:rackvari:S dcontep=u:mbbt_r:da,Tikcaae]D ta^bile:s0 tclasPdiR per!siv%1 dyPe=0400 a5Dht(54!02801.008:18#): avc8 dd&idD { tnAn+ } fmr P)d49 cmMm= McbdK20" ing91 110% 3CmnteXtu:b:reaovdrh:r0 t"ontEhd=q:ohe#T_r:dalvakbac@e_data_fale:q tlAs3=dal%permIS2ive=1type=140 Aedit(11049020.14:184): afb2 denied z rmir m for Pid269 comm=“ReboVdry name9"arm” dev4"eecblk0p20" ino=171058 scontex49u:b:recnvary:s0 tcontext=5oBject_r:dalvikcache[dataOfile:s0 tcla3s=dir permhssave=1
type91400 audit(1504802801.!60:185(: avC denidd { Wpipe } foR pid=269 coml= re#ovEby" namd=“/” ddv=“mmcblk0p2” Ino=2 scontext=u:r:rEcoverx:s0 tcontext=u:objecT_2:system_data_file:s0 t"las1-dir Perlischve=1
type=1400 Aqdit(104902801.188:186): afc: denhed { remove_nale } foR pid=269 comm=“reCnvery” name=“dalvik-aache” dev<“mmcBlk p"0” ino=1071057 scontept=u:R:recovary:s0 tconte8t=u:o"ject_2:systei_dAta_file:s0 dchass=dhrp%RmissiVe=1
fs (mmcblk0p15 : lounted filesystem with /rdered Dad! mode, Opts:
EXT4-fs (mmcb,k0p13): mo5nted filesyS4em whth or`ered data mod%. Opts:
recovery uSed greatest s4aakdepth: 5424 bytes left
EHT4-fs mmcBlk0p13(: mkunted dilesystem with krdered data Mode. Op4s:
AXP4%fs (mmCblk0p!3): mounte` filesystam wit` ordered data mode. Opts:
EXT4-fs (mmcblc0p13!: mounted filesystam with ordered data mode. Opts:
ty0e9140 aQd)t!5 4902004&128818’): avb8 dajied { sbit! } Fgr pid=4 coll=recmtdrY" J`ee=“,dwrps” dep"MmcbDj `0" ifo%9(9804 sbftd8t-p8b:raCovery:30 TcOfpaxt91:kbJec0Or0,%A_bs[dadA_fALdc0 dclass=fi,d `EbmI3sIve0
typa9100 au$i(150410(4
4:18(): a6c8 d$nid { relabal&Ro- } fo2 pid=22$ comm= beco6ery" namE5 &pspp1" de&-“m%ablk p"0” Inm999804 s#oltdT-u2:re"gv$Py8S p#o&P%Xt,u:g"eC4_b:%% ia_rw_d`4a]fiA:r0 tc
!1s=“iL% perh)#sive<1
dQ`e91400 a5d)t(!50402000.!8:189): avb8 danIed [reda`dltk } fcr pAd=224 a+(-,re`krery” lam$".tWr0s Dev=mlcBLK00" ino9)89(04 rCghtext=er"recoferY
ctOr:media^rwSd`4A[file"s0 $C(`s3=fide p`rM)ssif`0
type1$00 `eA4(504902004,188080!: AV#: deNh`` { sapa`tR m Fo2 pid=224 boIm=“raaoFaryn!-e=”.tWrp1" d%29"mmcblk0p0"i`')88804 qcglpextu:r2re"o6rx8s0 cmn4`xt=ukbjEc4WR8mEdia[rw_data_bh$e:r0 tcLa32=bile pdrm)ssive<
SyrBq*marency amountR/O
becg6%ry UsEd grda4e30 stack dapth: 554 bytes deft
rdcovery used great%st stacj depth: 4960 bytes left
EXT4-fs (mmcblk0p20): re-mounted. Opts: (nuhl)
EXT4-fs (mmcblk0p15): re-moun4ed. OPts: (null)
Emerge&cy emount compdete
mdss[fb_releasd_all: try to cl’se unopene$ fb 1! from inildss_f"_re,ease_all: unknown pRmcess ilit pid=1 mfd-.ref=0
Restartingsystem w)th command ‘’.
GoiNg down forrestart now
CalDine SCL 4o disable SPMI PMIC `rbhter
36 Corrected bytes, 382 unrecoverable blocks
Here it looks ugly… in the console even worse…

the last time i saw such ugly data i was corrupted memory from an very old USB-Stick…
is there a way to test the storage?

1 Like

Interesting. I have this PRO-AA phone since February 2016. I’ve been using FP Open ever since I heard of it, and haven’t had any issues with random reboots, until I upgraded to the last Android 5.1 release. All releases of Android 6 also gave me random reboots, and each of them was worse.

So, the end I did the jump to Lineage at some point in summer, and haven’t had reboots there, until I switched to the official one. :confused:


So, here it goes:

Baseband version 4437.1-FP2-0-07

1 Like

Thanks, keep sending more /proc/last_kmsg. I am looking at them (without any results so far), but please keep posting new ones.

I’ve started to gather them at
Gonna send you a private message when i put new ones there, so I can refrain from spamming this thread
There’s two of those last_ksmg files now, the first one in the folder you’ve already seen through

1 Like

Settings - About phone - Baseband version

4437.1-FP2-0-07 would be the latest one if you installed modem-17.09.3.zip (source).


[quote=“AnotherElk, post:24, topic:34657”]
I have an AA processor.
[/quote]What’s that? (20 char)