Future Android version for the Fairphone 1 / 1U

Info is here!!!

@michaelp I think Android 4.3 bears the same difficulties as Android 4.4. We are still hoping, that at least an upgrade to Bluetooth LE emerges. (If you know someone who could be interested, consider forwarding the job offers.)

It’s a feature that was removed by Google in KitKat, so I wouldn’t depend too much on it if I were you (that would go for any phone). The good news though, is that the FairPhone is rooted, which means you can install Xposed on it. Xposed is a framework that allows “modules” to be installed that can change a whole range of things on your phone. A popular Xposed module is Xprivacy, which can be used to restrict permissions for individual apps and basically does the same thing as App Ops.

2 Likes

For info, AppOps Xposed module has been launched which brings back the App Ops settings in android 4.3 and above, unfortunately we don’t get anything in 4.2 :cry: so Xprivacy is the next best thing

Hi there,

To join the discussion, I personally don’t care too much about the features of new versions, up to now I can do anything I need with my present version, BUT…

I think security updates are a must. And considering the strange behavior of google described in the link below, I think something has to be done. Not providing any chance to get security updates for a OS which is widely used by phones which are still sold right now is a no-go. I know Fairphone is a rather small project, but the idea of the project is putting pressure on the big players in the business regarding fair conditions during the hardware manufacturing. The same thing could (and should) be done regarding the software. Since putting pressure on google itself might be more difficult than supporting some third party developers, I assume pushing CM-development is the way to go. I am not skilled enough to contribute code myself, but I will happily donate something if that is of any help.

I am not so sure anymore about CyanogenMod. The FSFE says that

Newer versions [of CM] also include the proprietary Google Play services.

I think Fairphone OS is more Google free because you can choose not to let Google Services into your phone. (Also see our discussion over here)

So bottom line, I think the way to go is to make it easier to have any OS ported, not just CM. It seems far more sustainable to me.

1 Like

I am not quite sure if the FSFE is correct about that. To my knowledge, when installing CM yourself, you always have to install Google Play Services manually. It might be different on phones that come with CM preinstalled…

So true.

Ok, I should have not been that specific. As I said, my priority is security updates for the OS which is on my phone, and I also like a google-free phone.

I thought CM was the “go-to” solution to the problem, since it is still android which means all the apps work etc, but I haven’t used it so far on my own phone and didn’t know about details like the ones you linked to.

I also share the demand for a OS that is as google-free as possible. As I said, I am not an expert on this, so: If for example CM-support is pushed by the fairphone team (which seams to imply getting drivers for the hardware from the manufactures and stuff like that), and everything related to this is made available to other OS-devs, that would be what you want?

And future versions of the phone could try to get hardware that is fair as well as open, to avoid these portability problems as much as possible…?

No, not exactly. What I mean is that they should get the “drivers for the hardware from the manufacturers” and let the programming stuff do other people. There is a CM port to the FP1(U), but it would be much easier for the developers if Mediatek would release all their source code + documentation.

In terms of sustainability, providing updates and patches in the first place certainly seems to be the essential issue here. These days, the UXSS bug,for example, and Google’s refusal to patch systems from 4.3 downwards worry me. Patching security bugs, however, can be done without upgrading to a new Android release.

Still, with new useful and interesting features being introduced in new Android releases, I think it can be considered a sensible contribution to the longevity of smartphone devices to provide their users with upgrades. Having a history of doing so might also open up a wider circle of potential Fairphone-buyers!

I just made a check concerning this vulnerability at http://m.heise.de/uxss-check (only in German unfortunately, but green means save, red doesn’t) and my Fairphone is not at risk.

But I fully agree with the rest of your post, the hardware and its software should be more controllable. From what I got so far this is the way the FP team wants to go anyway, and a big step into that direction is expected for the new device.

1 Like

All users of Fairphone 1 should be aware of the following:

  1. If you check the vulnerability of your FP 1 with http://m.heise.de/uxss-check, make sure you use the built-in browser. If you use chrome or firefox instead, you will (misleadingly) be told that your phone is not affected. If you wonder why you are not safe by just switching the browser, please read on.

  2. The vulnerable “webview” component of android 4.2.2 (the version running on FP 1) is not only used by the built-in browser but also by many apps (e.g. for showing ads). Therefore, while switching the main browser is certainly (!) a good idea, it does NOT suffice in order to avoid the security risks imposed by the unsupported webview-component. For somewhat more detailed information about the problem, and about what you can do in order to avoid unnecessary risks, see: http://heise.de/-2552659 (in German).

However, some of the necessary security measures are quite complicated and/or restrict the usability of the phone, and the article also makes clear that the only really secure option would be to update to Android 4.4 or 5. I still hope, therefore, that Fairphone will find a way to make an update of the FP 1 OS possible, simply because the flaws of webview already puts FP users at risk.

2 Likes

@real thank you for your extensive comment. I think it would be nice to see some of your thoughts in these threads:

I think it would be a shame not to offer upgrades to Android 4.3 or 4.4 if the goal is to make a phone that is supposed to last. Anyone who wants access to new useful features in Android or new apps that use these features will basically need to buy a new phone, even if there is nothing wrong with it. For instance, lately a lot of cool gadgets have been coming out that need 4.3/BLE to work; if I understand correctly then FP1 has a BLE chip that is unusable because Android 4.2 does not support is, which just seems like a waste. Not to mention the security issues that are discussed above. I understand the issues with the chipset, but if the folks at Fairphone are true to their philosophy then this should really be a priority.

1 Like

I just heard about the new Fairphone 2 and thought it was really cool, but already got Fairphone 1 and cant afford a new one, but i heard that it will recieve Android Lollipop 5.1, will the first Fairphone also get a software update?

I think that the current version is fine, it meets most of my needs and it is a nice operating system. But i now have Andriod Lollipop on my Nexus 9, and it is in my opinion alot better, it looks nicer, has better and more features and is allround better. And now as the Fairphone 2 is promised to have Lollipop i don’t really see why you shouldn’t be able to apply it to the 1 generation older FP1.

There is a comprehensive support article about this. Please also read some posts here in the forum, we have had lengthy discussions about this issue.

I merged your two posts. If you want do add something to a post after having saved it, click the little grey pencil to edit your post.

1 Like

TL;DR;

[quote=“Rinkan_Finkan, post:91, topic:67”]
why you shouldn’t be able to apply it to the 1 generation older FP1
[/quote]FP could. MTK (manufacturer of FP1s SoC) doesn’t want them to and does not give the code FP needs.

1 Like

Is the default Android browser part of the AOSP code? If so, can’t FairPhone just fix the webview UXSS security issue?

There seems to be hope for future updates after all:

1 Like

Discussion continues in above posted thread.

This topic is now closed. New replies are no longer allowed.

2 posts were merged into an existing topic: Hope for future FP1 Android updates