Future Android version for the Fairphone 1 / 1U

I agree with Daryl; I just started another topic regarding the new Android Smartwatch (running on Android Wear - sorry, didn’t see this topic). It needs an Android Phone running on 4.3 or higher.

I see that there is some work done on Cyanogenmod on Fairphone, but it doesn’t support dual sim and bluetooth, so not an option for me. It becomes painfully tempting to buy another Andriod phone - but then the ‘fair principle’ is out of the window.

I want to have both! :wink:

Maarten.

2 Likes

Just received my Fairphone, and discovered the issue with my gadgets not connecting. I really am gutted. I am a passionate cyclist, and the gadgets are really part of the fun for me. This basically means that if my Fairphone doesn’t get v.4.3 then I will sell it, and by an Unfairphone that has it, and this would kind of defeat the point of buying a Fairphone in the first place. I don’t care about v4.4. But all the gadgets I have seen need 4.3.

2 Likes

I can only advise you to be patient for a little longer. Keep in mind, that only ~29 % of the Android devices around right now are 4.3 or higher (source)

I’m certainly willing to wait, but I’d need to know that it is gonna happen, even if it’s a way down the road.

I have the same problem as other users. I want to use some gadgets and all of them need at least Android 4.3. I was thinking to try some new Android watches as Motorola 360, but it works with Android Wear which needs at least Android 4.3… If my Fairphone is not soon updated I will sell it.

1 Like

I think that if what you are saying is true, then you should consider selling it as soon as possible and as little used as it hopefully is.

How soon is soon enough for you?

What if they were to tell you that an update to 4.3 is not likely to be achieved this year? Would it be too much to wait?
What about next spring or summer?

Based on what I read about it so far, which includes the unofficial 4.4 testings, I doubt that FP will be upgraded to 4.3 “soon enough” or even at all.

Bye :wink:

Im 99% sure the reason all those gadgets need 4.3 is that they communicate with the smartphone via BlueTooth 4.0 Low Energy (BLE for short), which Android started supporting from 4.3 onwards. BLE is very energy efficient, which is particularly suited for [small] gadgets so they only need to be recharged once a week (e.g. a smartwatch or health gadget) or even can work for several years on a single, non-replaceable battery (e.g. some cycling gadgets). Btw, the gadget I mentioned in my post above is also cycling-related ;-).

But indeed, this means we can’t use any of them until the phone is updated to 4.3 at least. Of course, it would be very silly for Fairphone/MTK to invest time in 4.3 given that 4.4 is equally available. If we’re going to update, we might as well receive the improvements of 4.4 over 4.3. Let’s keep our fingers crossed, and put some (well-intentioned) pressure on Fairphone to let them know a significant part of their userbase really does expect an upgrade to 4.4 in the not-so-distant future !

In response to van’s question: indeed, each person will probably have a different definition of “soon enough”. Personally, I would hope to see Fairphone updated to KitKat by January 2015 (which by the way is 14 months after the release of Android 4.4.0, and 6 months after the release of the current version 4.4.4) - although sooner is always better of course. If the update still isn’t forthcoming by that time, I think I will look for another device as a primary phone, unfortunately …

Not updating to a newer Android version starts to sound like planned obsolescence eh? :wink:

Anyway, I’m hopeful, considering the cyanogenmod breakthrough. Bluetooth doesn’t work with it yet but give it some time and they’ll figure that out as well.

1 Like

I don’t think they planned it, but other than that: let’s hope the Fairphone staff are quite aware of the bitter irony of this particular situation …

The CM breakthrough is very good news indeed (also because it shows that technically, it is perfectly possible). However, the fact that there may be a good alternative custom ROM at some point in the future does not absolve Fairphone itself from providing us with official Android updates for at least a few years. It’s great that we may have the option to install a different ROM, but we shouldn’t have to switch to an unsupported ROM just to have an already long-available current version of Android. Or at least not now: the unofficial ROM-route would be quite acceptable in 5 years time (but will any hobby developer still be interested in a 5-year old device then ??) but for the first 2-3 years Fairphone should provide official upgrades!

That is definitely true ! And I think that also if other people are now saying they are happy enough with this version at the moment, they will be disappointed in just an year… so even if won’t be possible have a pure android kit Kat, seems to be possible have the cyanogenmod 11! Fairphone should be willing to develop a cyanogenmod 11 without bugs for us, in this way they also will achieve their promise to let us choose which operating system using.

Most of you already said it much better than me. But I am going to say it anyway:

Keeping the operating system up to date most definitely prolongs the usefulness and viability of a smartphone. If the Fairphone does not receive an OS upgrade (or alternate firmware) within the next year or so it will be just as obsolete and disposable as all those other disposable phones being shat out by other manufacturers.

I say this having had first-hand experience. My first smartphone was a Motorola Milestone. I absolutely loved the design and feel of the phone but to be fair it was already considered dated by the time I bought it. I had a good first year with it, but as time progressed it kept getting slower and slower. Some apps outright refused to run on Android 2.1, others ran too slow to be of any use. After an agonizing few months of uncertainty (for a while it seemed that the Milestone would stay at 2.1) Motorola finally released the 2.2 firmware. The improvements were marginal however.

Skip ahead a few months and I was just about ready to ditch my phone for a new one. It was just too slow to be of any use with most apps not even supporting 2.2 anymore. A friend of mine insisted that I try Cyanogenmod and so I did. The result was nothing short of amazing. It now ran Android 2.3.7, this might not seem like much but kernel improvements made the phone much faster. Not being hampered by the shit the vendor put in helped as well. Using Cyanogenmod, I got another 2(!) years out of the phone before the touchscreen finally gave up.

Now I own a Fairphone, and to be honest I am a little disappointed. Android 4.2.2, no cyanogenmod, no Firefox OS. Perhaps I should have done my research, doubts were already raised about the alternate firmware issue back when I ordered. Perhaps I just hoped those issues would sort themselves out.

Those were my two cents. Does anyone have a link to an official roadmap for future firmware versions, or a reaction of the Fairphone crew? At the very least someone should have said something tangible about this stuff? Maybe I missed it.

Also relevant; major security issue in standard Android browser: http://tweakers.net/nieuws/98479/oudere-android-versies-zijn-vatbaar-voor-ernstige-privacybug.html (Dutch)

2 Likes

@teejoow

There has been some effort concerning cyanogen mod + android 4.4: Cyanogenmod 11 for Fairphone FP1(U) Install guide + experiences

I have downloaded it but not tried yet. Sounds very promising, we should support the developer financially!

Yes I read about that, very promising indeed. The thread mentioned some problems with the dual sim feature. Shame, since that is my favourite feature. I might try it in the future though!

That, however, does not take away the responsibility of the Fairphone crew to provide regualr updates and enable alternate firmware by providing the relevant software. If they truly want to make a phone that will last they musn’t stop at the hardware, that’s what I wanted to illustrate with my previous post.

2 Likes

Hi,
i know the Fairphone Software team is not the “biggest” one.
When i bought my Fairphone I really hoped that they will communicate more.
More as 'its done when its done’
If they like to ship a update to 4.4 end this year they should have a update plan. New version - testing / programming the fairphone software - alpha - beta - update…

It would be nice to tell us more about this topic. So we can deside what we do.

Chris

1 Like

@Noxorius - unfortunately that’s an over simplification of the problem. To develop a 4.4 release the FP need the support of outside organisations such as the chipset manufacturer. At the moment this support is being given to large producers, and it’s more of an ‘if’ than a ‘when’ for FP getting support from Mediatek to implement a release.

This support article was updated last week to give a bit more info on the current outlook for a 4.4 release

2 Likes

The new version (CM 11 M10) carries some updates for multisim suppport (see changelog) maybe that will be able to provide full dualsim support for Fairphone. Any feedback on that would be great!

1 Like

bought a micro-sized Arduino Bluetooth Low Energy shield, but alas, its only compatible with Android 4.3+ (!!), :-/

So, i tested CM 11 M10 Multisim features with 2 sim cards. What I was able to test was: Data Connection with Sim Card 1, Calls and SMS with Sim Card 2. No flaws with that.

3 Likes

Cool! I might give it a try later this week. Don’t have a lot of spare time right now.