Front facing camera not available anymore in camera apps

Hi there,

My front facing camera is not displayed in any of my camera apps, so I can’t use it. It’s like it’s never been there, vanished from all camera apps just the hardware proves it exists. I can’t recall when exactly it disappeared from the screen, but I miss it dearly.
I closed all camera apps, restarted my phone, and cursed heartily - all without success. Is there anything else I can do before trying the dreaded factory data reset?


If I remember correctly, following the procedure describing how to test the screen, there should also be a menu item to test also the cameras (please someone correct me if I’m wrong as I tried only one time to get into the “testing menu”).

In engineer mode (by dialling *#*#3646633#*#*) I could only test the back camera…

No, it’s not in engineering mode, it should be in the menu in recovery mode which you can see following the same procedure of the touch screen testing.

EDIT: thanks @paulakreuzer for editing adding the link :slight_smile:

Thanks! Did it and for Sub Camera the screen goes black for a second and back to the list of Item Test options. In comparison: the test for Main Camera shows a nice test coloured screen before it switches back to the list.
Does this mean my front camera problem is a hardware issue?

I fear yes, just tried the test and selecting Sub Camera it enables the camera and I can see myself like in a webcam.
Try to contact the support team.

I will, big thanks for your time and good advice!

1 Like

Please share with us how the story ends. :slight_smile:

How did the story ended for your camera problem?
Because I maybe also have this…

Finally I also did the camera testing in Factory Mode and the result was the same as for @Cosy_Lethargy:

  • Main-Camera: It shows an image with about 6 colored stripes for 1-2 seconds (NOT the live pic of the camera - why?)
  • Sub-Camera: It switches black for less than 1 second (Also no LIVE pic)
    After both I am landing back in the menu, no more options for camera available.

In the normal FP-OS only the Main-Camera is working properly and there is no button anymore to switch to the Sub-Camera…

Thus I will write the support, but any recommandations what I could try until then?
Cheers, Robert

… just a question during testing the Main Camera in Testing Mode – this is the status quo:

Maybe I have to remove the battery to get out of this “frozen black screeen”… Holding eg the power button do not cause something…

But as described above a screen with “6 colored stripes” had to appear?
Hmm, it seems to be the same effect as using the (default) camera app: such an app trying to use the camera crashes!

But is there a possibility only to test the sub/front camera? → Edit: I found the item for a separate test of the front or back camera. The front camera works! But the rear/main camera not – same result as before: the system freezes and I have to remove the battery…

thank you!

I got in touch with Fairphone support. They sent me detailed instructions
how to fill in a special form and package the phone to send it to their
address in the Netherlands for repair. Since I hadn’t caused the problem, I
wasn’t charged and got it back about 10 days later. While it was with them
I could follow the progress through a link they sent me as soon as they
received the phone. All fine since then. But make sure you back up your
data before you send the phone in, they will wipe it clean.
Good luck!

Just to get this clarified:

If the main camera of the FP1 works, what should the main camera test (in factory mode) show?

I tend to think the six coloured stripes indicate a broken camera. Right?

UPDATE: OK, I was now able to test working main cameras on two FP1Us using factory mode. In each case, the factory mode main camera test displays solely the coloured stripes. Now I wonder if the test simply does not work or if this is indeed proof that the camera works (the reason is that I have yet another FP1U that I cannot unlock to verify its main camera operability).