Front camera won't work with non-native apps

Hello,

I just switched back to Fairphone OS after several years of Lineage OS due to stability issues, and was welcomed by a new camera bug \o/ .
Since the native camera app has a well known out of sync flash issue (I thought it was only on Lineage OS but I have the exact same on Fairphone OS), I quickly installed Open Camera. Yet while the rear camera works fine, the front one turns black when I move during video preview and recording.
At first I thought it might come from the gyroscope or the proximity captor, but it turns out it occurs whenever the front camera doesn’t receive enough light (yet works fine in photograph mode)… I tried another camera app (as complete as Open Camera) and got the same result, though it works fine with the native app…
Has anyone run into a similar bug ? Otherwise something might have gone wrong during the installation of the OS, but I prefer checking the other possibilities before losing all my settings over again…

Thank you all in advance !

Normally when there are issues with Stock Cam App, Open Camera always works, so its strange. Which front camera Version are you using? Have you tried to clean contacts? Else you can clean cache and storage of the App.
Which FPOS Version habe you installed?

2 Likes

Thank you for your reply !
I didn’t know there were different versions of the front camera, how can I check which one I have ?
I tried cleaning contacts, and even ended up installing FPOS over again, but still the same problem…
I installed the last version of FPOS : 21.12.0-rel.1
The bug also happens with the camera app Manual Cam (DSLR pro…), but not with all apps of the playstore.
The bug is highly related to the amount of light received by the front camera, as it doesn’t happen when I put a white piece of paper 30 centimeters over the camera, but does happen if the piece of paper is dark.

In the camera app settings, you should have multiple options when setting the cameras’ resolution. The first incarnation of the FP2 selfie camera had (a maximum of) 2 MP, the second had 5 MP. The cameras’ maximum resolution might also be shown in the General Settings of the phone (System/Model/About the phone, something like this).

2 Likes

Ok, thanks ! So I have the second camera, with 5 MP.

1 Like

Most camera apps don’t seem to have this bug. By now I’ve found only 3 where the bug occurs: Open Camera (https://play.google.com/store/apps/details?id=net.sourceforge.opencamera), another camera with similar features (https://play.google.com/store/apps/details?id=com.lensesdev.manual.camera.pro), and a “copy” (same settings and shortcuts) of Open Camera (https://play.google.com/store/apps/details?id=hd.camera). However another “copy” of Open Camera doesn’t have the same bug (https://play.google.com/store/apps/details?id=hd.best.camera)…

I would open an issue in the bug tracker

1 Like

Do you think I should also open an issue for the flash out of sync ? I’m surprised there isn’t already one as it seems to be a very common and annoying bug (though there is an easy workaround).

I actually dont know what “flash out of sync” means. But sure if you know its common, open an issue and add the workaround, what might helo to identify the bug.

It’s just that with the stock camera app, on both FPOS and LineageOS, the photograph will be taken too long after the flash so it will be black. And the workaround is just installing Open Camera :smiley: