FP4 - very privacy-friendly custom ROM iodéOS

I can’t boot into recovery. When I select recovery mode the device boot’s into boot loader again!
Recovery has only worked a short time to the first reboot. After a bootloop I had once the message in recovery that my device is corrupt.
I think only Fairphone support help. But I had no answer until now.

It was the cable or the fastboot version. Don´t know exactly. I had change both. With a new cable and fastboot version, I was able to start a >fastboot boot iode-2.4-20220405-FP4-recovery.img<. Later I could flash a/b partition an could boot into recovery.
May this was the problem: ‘iode-2.4-20220407-FP4.zip’ (~94%) Success
The new flash ends with “Total xfer: 2.00x”.
So I cloud boot into iodeOS.
The only problem I still have is to lock the bootloader again. fastboot flashing get_unlock_ability shows (bootloader) get_unlock_ability: 1, but if I lock the bootloader the device wont boot the system and goes to a bootloop.
I used the 20220407 files.
I checked it with 20220405 files. But now I get the “Device corrupt” message again and can´t boot into recovery! :roll_eyes:
A couble of tries later I flashed 20220407 version and was able to boot into iodes. But without locked bootloader. But with access to USB debugging.
Is there anything I can check what the reason is with the bootloader?

Does somebody flash lode with the latest stock update?

Its maybe the same problem, others have with /e/OS
As I remember its because of a wrong slot.
In which slot have you sideloaded the image
Then try to activate the slot explicitly before unlock bootloader.

fastboot --set-active=a
If installed in a
fastboot --set-active=b
If installed in b

Since locking mode was fixed

I’ve not been able to reproduce the problem with an /e/OS phone (even when latest FPOS version was installed before). I.e. I could always lock the bootloader without any problem.

For me on iode it is also not reproduceable

I was on slot b. Have seen it in recovery or so. It’s also for not clear what the problem is. I did everything like described. I also test the different version. Not change. But here is the message different .

This, is exact my problem. Some guy report that unlock_critical fixed the problem, but I did that in my desperation yesterday.

I have had exactly the same issue yesterday. Also the part with 94% and still printing “Success”. And for the next tries “Total xfer: 2.00x” (Except when I tried 2.3 in a very desperate moment… ;)) The only difference I guess is, that I used slot a instead of b (don’t really get that part though). I really would like to find a solution in which I can lock the bootloader and be able to do further updates without wiping my data or keeping the bootloader unlocked forever…

On which position in you manual should we active the slot, before or after flashing?
If I was on slot b with the last fastboot, could it be a problem to flash now on slot a?
Where can I see on which I am?

in recovery and bootloader

Didn´t see in bootloader, but in recovery. I´m on slot b.
Could this the problem?
If so I’ll try on slot a. Unfortunately need to start from beginning. Did not finish my phone configuration. So it is not so hard to waist time. :smirk:

Did another try, but stuck in fastboot flash avb_custom_key avb_custom_key-FP4.bin is not writing! I changed the slot to a and come to write the avb key. Flashing recovery and erasing the key was working, but not writing the key. I tried 3 differend cables. No chance.

After about 15 tries I could send the avb. So I progress. I doublecheck if I’m on slot a and did a fastboot flashing lock and … device locked and corrupt! :woozy_face:

No chance wether 20220407, nor 20220405.

When I see the “Erasing” logo, what does the device erase?

User data, not more.

:confounded: this is so frustrating… I wonder if it will work out if we try iode3.0 … but not sure if we can go back then? When I tried adb sideload 20220405 I got the feedback that this image is older than the current image and, thus, it won’t be installed !? (even though I of course did the factory reset before) Guess I will still try on the weekend if there is no other update until then. :crossed_fingers:

@FairphoneHulk I followed your instructions on the iode forum from 5th April. But I used 20220407. I ended up in a bootloop aswell.

In my recovery I saw that I was in b. So I set it to a (fastboot --set-active=a) and iode started like a charme. But it was still with open bootloader. Locking the bootloader results in a corrupted device message.

By unlocking in fastboot, flashing the recovery and the key (is that needed?) I can boot iode without problem again (with reset data of course). I still don’t want to start setting up my phone now because I feel like I want a closed bootloader even though I didn’t have it on my FP2 for years now…

you, @wurzelsucher and maybe @Hubble also used version 220407. I used 220405 and did the update to 220407 via OTA.
Don’t know if it is the issue. For me and some others worked my instruction without problems. Don’t know what happens on your side…sorry

1 Like

I now believe that no one has any perspective at all. In which situations and with which constellations it works or does not work.
There are so many different options:

  1. Which OS do you come from, which version?
  2. Where do you want to go, with which version?

I’m now at a point where I can’t say anything more and, above all, can’t recommend anything anymore.

Just my advice, just like @hirnsushi already said: Until there is no and above all tested solution, I would leave the bootloader unlocked.

Lots of discussion, lots of confusion. I myself have no more perspective.

here in this Thread
and here and here

1 Like