FP4 - very privacy-friendly custom ROM iodéOS

Do you think it could be a good idea to make a wiki to show the current state of iodé for FP4 ? (and maybe other ROMs, if they want to add it)
EDIT : found it


I added the last line of the screenshot to show the iodéOS 3.0 release :wink:

2 Likes

Has anyone successfully sideloaded 3.0 from 2.4, with a relocked bootloader? Might test this version if possible.

Yes, did it exactly that way, without wiping data.
Just sideload image in recovery and reboot.

You’re also welcome to meet the iodè Matrix room:
#iodeOS:matrix.org

1 Like

For unlock the bootloader I found another command here:

Is this step 7. necessary?
In a Command Prompt or a terminal, type: fastboot flashing unlock_critical and press the “Enter :leftwards_arrow_with_hook:” key
And do I understand that correct, for build’s after 20220405 I need to flash the new avb_custom_key-FP4.bin?

It’s all dexcribed here: Unlocking criticals is not necessary

===================== WARNING : LOCKED BOOTLOADER =====================
Starting from 20220405 build, Android verified boot is activated on FP4.
A new version of avb_custom_key has been generated, required for builds starting from 20220405.
If you want to relock your bootloader or already relocked it: flashing the updated avb_custom_key is required (so a locked bootloader must be unlocked again, and data will be wiped).
If you don’t or badly flash avb_custom_key and relock your bootloader, or if you install builds starting from 20220405 with a locked bootloader without flashing the updated avb_custom_key, you will brick your device.
If you didn’t, or don’t intend to lock your bootloader, you’re not concerned and can flash all builds without wiping your device.

You can flash it with original instruction:

Or in more detail with mine:

  1. remove SIM card and check that akku has at least 50%
  2. eneable USB Debugging and “Allow unlock OEM” in Developer Options
  3. check if adb is working and device is recognized correctly =>adb devices => ACK USB debugging on phone-screen. check box: always trust
  4. adb reboot bootloader
  5. check if fastboot is working and device is recognized correctly =>fastboot devices
  6. fastboot flashing unlock => Acknowledge unlocking on phone (VOLUME UP + POWER) Device is doing a factory reset and reboots to system
  7. start again in bootloader => switch phone off. pull out USB cable. press Volume (-) and put in USB cable in. Keep Volume (-) pressed. Phone should start in bootloader. (¹)
  8. check if fastboot is working and device is recognized correctly =>fastboot devices
  9. fastboot flash recovery_a iode-2.4-20220405-FP4-recovery.img
  10. fastboot flash recovery_b iode-2.4-20220405-FP4-recovery.img
  11. fastboot erase avb_custom_key
  12. fastboot flash avb_custom_key avb_custom_key-FP4.bin
  13. press VOLUME UP until see message reboot in recovery. Then POWER
  14. From recovery => Factory reset => Format Data/factory reset
  15. From recovery => Apply update => Apply from ADB =>adb sideload iode-2.4-20220405-FP4.zip
  16. back to bootloader mode. From recovery => Advanced => reboot to bootloader
  17. check if bootloader unlock ability is possible =>fastboot flashing get_unlock_ability → (bootloader) get_unlock_ability: 1 ==> if you get 1 then follow with step 18) otherwise do not lock bootloader (can brick your phone) and follow with step 19)
  18. fastboot flashing lock
  19. reboot system. First should see a Lineage screen doing a wipe. After a second (automatic) boot you should see the yellow boot screen and then the iode bootscreen.
  20. start setup wizard

(¹) From FP Support Page:
Alternatively, you can disconnect the USB cable, turn off your Fairphone, then connect the cable and hold the volume down button. After a few seconds, you’ll see the fastboot mode

2 Likes

I flashed like discribed, but it fails! Everything look good during the flash.
Now I can see the boot screen, can hear a short vibration and then the device reboots.
In recovery the device shows “It’ corrupt”.

via my instruction or via official instruction? Have you entered all steps exactly?
what did you flashed? 220405?
Have you installed avb_custom key? the right one, not the old?
Can you boot in bootloader? via Volume and Power buttons?
If yes, what do you get if enter command: fastboot flashing get_unlock_ability

With your instructions, but I used the new version 20220407.
Here’s my flash log:
[ iode]$ fastboot flash recovery_a iode-2.4-20220407-FP4-recovery.img
Sending ‘recovery_a’ (98304 KB) OKAY [ 2.553s]
Writing ‘recovery_a’ OKAY [ 0.259s]
Finished. Total time: 2.832s
[ iode]$ fastboot flash recovery_b iode-2.4-20220407-FP4-recovery.img
Sending ‘recovery_b’ (98304 KB) OKAY [ 2.424s]
Writing ‘recovery_b’ OKAY [ 0.211s]
Finished. Total time: 2.643s
[ iode]$ fastboot erase avb_custom_key
Erasing ‘avb_custom_key’ OKAY [ 0.012s]
Finished. Total time: 0.017s
[ iode]$ fastboot flash avb_custom_key avb_custom_key-FP4.bin
Sending ‘avb_custom_key’ (1 KB) OKAY [ 0.007s]
Writing ‘avb_custom_key’ OKAY [ 0.009s]
Finished. Total time: 0.040s
[ iode]$ adb device
adb: unknown command device
[ iode]$ adb devices
List of devices attached
removed sideload

[ iode]$ adb sideload iode-2.4-20220407-FP4.zip
serving: ‘iode-2.4-20220407-FP4.zip’ (~94%) Success
[ iode]$ fastboot devices
removed fastboot

[ iode]$ fastboot flashing get_unlock_ability
(bootloader) get_unlock_ability: 1
OKAY [ 0.000s]
Finished. Total time: 0.000s
[ iode]$ fastboot flashing lock
OKAY [ 0.026s]
Finished. Total time: 0.026s

Bootloader was unlocked successful shown in bootloader screen.
File were downloaded from this side:

I see:
(bootloader) get_unlock_ability: 1
OKAY [ 0.001s]
Finished. Total time: 0.001s

And “DEVICE STATE - locked”.
This is my first corrupt device, after flashing about 20 Samsung phones successfully.
All files have been checked via sha256sum correctly.

Did your phone successfully wipe after relocking the bootloader?

If not, I would boot into recovery and do a wipe (called factory reset) from there.

Did you do the factory reset before sideload the image?

(bootloader) get_unlock_ability: 1
You unlock ability is still 1
You should be able to unlock it again and do the process again.
Until it is not 0 it is not really bricked.

avb_key is correct one

1 Like

I saw a circle animation an below erase.
I can´t get into recovery. If I set “Recovery Mode”, device boot’s into bootloader again.
The first time I boot into recovery after I had the bootloop, I saw “Device corrupt” message.

I tried “fastboot flashing unlock” and the fastboot status is now unlocked. But I can´t flash something.
If I use fastboot flash recovery_a iode-2.4-20220405-FP4-recovery.img, I see:
Sending ‘recovery_a’ (98304 KB)
but no writing.

Don’t really know what happens in your case.
But if you flashed initially 220407, I would not flash recovery 220405
If your bootloader is unlocked now again, I would boot into recovery, do a factory reset and flash the image via sideload again.
Then I would boot without re-locking the bootloader again. See if this works
Then I would enable developer options, check if OEM unlocking is enabled, boot into bootloader, check if unlock capability is given and re-lock the bootloader.

I can’t boot into recovery. When I select recovery mode the device boot’s into boot loader again!
Recovery has only worked a short time to the first reboot. After a bootloop I had once the message in recovery that my device is corrupt.
I think only Fairphone support help. But I had no answer until now.

It was the cable or the fastboot version. Don´t know exactly. I had change both. With a new cable and fastboot version, I was able to start a >fastboot boot iode-2.4-20220405-FP4-recovery.img<. Later I could flash a/b partition an could boot into recovery.
May this was the problem: ‘iode-2.4-20220407-FP4.zip’ (~94%) Success
The new flash ends with “Total xfer: 2.00x”.
So I cloud boot into iodeOS.
The only problem I still have is to lock the bootloader again. fastboot flashing get_unlock_ability shows (bootloader) get_unlock_ability: 1, but if I lock the bootloader the device wont boot the system and goes to a bootloop.
I used the 20220407 files.
I checked it with 20220405 files. But now I get the “Device corrupt” message again and can´t boot into recovery! :roll_eyes:
A couble of tries later I flashed 20220407 version and was able to boot into iodes. But without locked bootloader. But with access to USB debugging.
Is there anything I can check what the reason is with the bootloader?

Does somebody flash lode with the latest stock update?

Its maybe the same problem, others have with /e/OS
As I remember its because of a wrong slot.
In which slot have you sideloaded the image
Then try to activate the slot explicitly before unlock bootloader.

fastboot --set-active=a
If installed in a
fastboot --set-active=b
If installed in b