FP4 SIM card not working anymore

Hey everyone,

had my new FP4 now for 6 days and love it. Installed all the apps that don’t need SIM card (needed to wait until today for company VPN which is combined between phone number and device ID) and it worked fine.
This morning I transferred the SIM card from my old device to the new one, it recognized it, told me the phone number and so on. Whatsapp got its data recovery and everything.

Then, an hour ago the SIM just ceased working. I thought it might be a service problem, but in the old device the card works fine. Restarting and taking the SIM out and inserting it again didn’t work on FP4. Same problem still, card doesn’t work anymore.

Any ideas why that might be? As I said, in the old device the card still works and I honestly have no real desire to do a factory reset just to check that…

Can you try with a different SIM card? Also, when you insert the SIM, do you hear a click? Maybe it’s just not properly inserted or poor contacts.

1 Like

How do you mean “the SIM card does not work”? Is the card not shown in the SIM card settings, or does it show the SIM but fail to connect to mobile network?

Also, from which operator is the SIM and which country are you in?


Hey both of you.
I only have that one SIM card so I can’t test that. But the card does work in a second phone. And yes, it clicks softly, when inserted. As I said, it worked for about an hour in the FP4, then suddenly the phone says there’s no SIM inside.

I’m a customer of German Telekom in Germany, why?

OK, seems to have been a very sudden problem with the SIM itself, even though in my old phone it still worked.
After getting a replacement card everything’s fine for now.


@Avalon Did the problem occur with your new SIM-card again?

1 Like

I nearly don’t want to answer you, but I’m swallowing my pride here and give help to others that might be as stupid as myself.

But short answer: Yes, a new SIM card solved that problem.

I’m still not 100% sure the SIM card want at fault as well, but I’m sadly 100% sure that I’m at least partially at fault here.

I tried to turn off WLAN-calls option if I recall correctly and there’s a button for SIM usage.
To anyone having that particular problem: DON’T turn that off. You’ll basically deactivate your phones ability to use the SIM card.
I’m addition to that, once it’s turned off, you can’t search for WLAN call anymore as that menu is turned off. You’ll have to go to your provider settings and turn it back on. That option has nothing to do with WLAN call itself xD

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.